locked
Skype 2016 client prompts for MFA every time the computer is restarted RRS feed

  • Question

  • Hi ,

    We have  O365 with 2 factor authentication configured and Lync 2013 On premises environment

    For some users , every time the computer starts, Lync would prompt for MFA  code, We found that that this is happening because it is trying to query EWS ,  which is on O365, after entering the MFA code , EWS status shows OK

    This only happens for Skype and not for Outlook.

    Trying to figure out , how to make sure MFA is not prompted everytime , the  system starts.

    Thanks 

    Avi


    Monday, August 26, 2019 1:32 PM

All replies

  • Hi Avyan,

    Please refer to this blog:

    Try to add the registry on the client side:

    For Skype for Business 2016:

    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Lync

    Then, apply the AllowAdalForNonLyncIndependentOfLync registry key setting:

    “AllowAdalForNonLyncIndependentOfLync”=dword:00000001

    Refer to this article for more details:

    https://docs.microsoft.com/en-in/SkypeForBusiness/troubleshoot/hybrid-exchange-integration/allowadalfornonlyncindependentoflync-setting


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Tuesday, August 27, 2019 5:47 AM
  • Hi Shaw_Lu,

    We already have this registry in place and the EWS works fine  on skype client.The problem is with the MFA  code prompt , that the skype client receives , when it starts for the first time.

    Tuesday, August 27, 2019 8:45 AM
  • Hi Avyan,

    It is quite strange. I think maybe it could do a network monitor (e.g. Fiddler or Wireshark) to check which hits the MFA code.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Proposed as answer by Shaw_Lu Monday, September 2, 2019 7:32 AM
    Friday, August 30, 2019 8:43 AM
  • Hi,

    Is there any update on this case?

    Please feel free to drop us a note if there is any update.

    Have a nice day!


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Thursday, September 5, 2019 7:20 AM
  • Hi

    I am having the same or similar problem where skype asks for the MFA code but if cancelled works anyway.  It asks each time the system is restarted but signs in OK if the prompt is cancelled.  We to have the AllowAdalForNonLyncIndependentOfLync reg key already in place.

    Thursday, September 5, 2019 10:10 AM
  • Hi Shaw,

    Sorry. Couldn't reply earlier.I am still looking for solutions.we had opened a ticket with o365 team but not of much help.They asked us to open a ticket with Skype onprem team.Not sure how much they  can help

    Thursday, September 5, 2019 8:02 PM
  • Hi Avyan,

    Is there any update with this case from MS support?

    If there is any result, feel free to post a note.

    Have a nice day.


    Best Regards,
    Shaw Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, September 11, 2019 3:23 AM