none
Google Chrome (without NPAPI Plug-in) support for SharePoint 2013 RRS feed

  • Question

  • Hi All,

    It is found that Chrome without NPAPI Plug-in will not be fully supporting SharePoint. And by end of Sept, these plugins will be history.

    There are words in and around various forums that SharePoint AUG CU 2015 is gonna fix this. However I have not seen anyone confirming this. People are still looking for solution.

    I would like to know weather AUG CU did actually solve this or there is no solution available till date?

    Friday, September 4, 2015 10:49 AM

Answers

  • It didn't. The August CU just sends the click on links to Office Web Apps, disregarding the "Open in client application" setting on the specified library. From Office Web Apps you can click "Edit in Word" and from there Chrome will launch Word with SharePoint context intact. But that is a heck of a band-aid considering that capability was always available in Office Web Apps.

    In my book redirecting a user to perform more clicks is not a fix and creates an unsatisfactory user experience of multiple clicks and waiting in order to open a document which worked fine yesterday (btw. Chrome v.45 is out as of today, NPAPI is dead).

    I'm dying over here with staff expecting a fix!



    • Edited by xMarcus Thursday, September 10, 2015 9:27 PM
    • Marked as answer by IMSunny Thursday, October 8, 2015 1:24 PM
    Thursday, September 10, 2015 9:24 PM

All replies

  • I'm not sure if you're running Foundation or Licensed SharePoint 2013, so the links for either of the KB articles for their August CUs can be seen here

    http://blogs.technet.com/b/stefan_gossner/archive/2015/08/11/august-2015-cu-for-sharepoint-2013-is-available-for-download.aspx

    I can't see anything in the kb articles that address this concern specifically though.

    Looking at the comments in the TechNet thread, it seems MS is aware of the issue but as yet have not released any fix.

    http://blogs.technet.com/b/office_integration__sharepoint/archive/2015/04/24/unable-to-open-sharepoint-documents-in-rich-client-from-chrome.aspx


    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Friday, September 4, 2015 11:09 AM
    Answerer
  • Thanks Steve! I did go through the KB articles and could not find anythingrelatd (as you mentioned as well). Also, it's a co-incidence that I also referred to the Technet article's comments and got to know users are still looking for a fix. 

    Therefore thought of posting it here, if in case someone has recently fixed it by applying the CU. It looks though, it hasn't happened yet.

    Friday, September 4, 2015 12:08 PM
  • It didn't. The August CU just sends the click on links to Office Web Apps, disregarding the "Open in client application" setting on the specified library. From Office Web Apps you can click "Edit in Word" and from there Chrome will launch Word with SharePoint context intact. But that is a heck of a band-aid considering that capability was always available in Office Web Apps.

    In my book redirecting a user to perform more clicks is not a fix and creates an unsatisfactory user experience of multiple clicks and waiting in order to open a document which worked fine yesterday (btw. Chrome v.45 is out as of today, NPAPI is dead).

    I'm dying over here with staff expecting a fix!



    • Edited by xMarcus Thursday, September 10, 2015 9:27 PM
    • Marked as answer by IMSunny Thursday, October 8, 2015 1:24 PM
    Thursday, September 10, 2015 9:24 PM
  • I would also like to know anyone found a workaround for this?? (Especially on environments without Office Web Apps)

    For now we are just throwing everyone accessing collaboration sites with a Non IE browser a warning message.. 

    This might help someone as we are waiting for MS to get this patched.

    	function checkForNonIEBrowser(){
    		//check on team sites only
           if(_spPageContextInfo.webTemplate == "1"){
    			if(navigator.userAgent.indexOf('MSIE') === -1 && navigator.appVersion.indexOf('Trident/') === -1){
    				/* Non-IE browser detected. Add warning message*/
                    if (typeof asyncDeltaManager != "undefined"){
                        asyncDeltaManager.add_endRequest(addMsg); //after MDS loads the changes
                    }
                    else {
                        addMsg();
                    };
    			}
    		}
    
            function addMsg () {
                ExecuteOrDelayUntilScriptLoaded(function(){
                    var statusID = SP.UI.Status.addStatus("Browser Warning:", "Please use Microsoft Internet Explorer to view and edit documents directly from this site.");
                    SP.UI.Status.setStatusPriColor(statusID, "Yellow");
                }, "sp.js");
            }
    	}

    Monday, November 2, 2015 4:04 AM