locked
Windows Management Instrumentation Service continually corrupts itself RRS feed

  • Question

  • Hello,

    I have been running Windows Vista SP1 for a while now, and it has become a habit to type msinfo32 into a command prompt daily in order to see if my Windows Management Instrumentation Service has been damaged again, in which case it displays the message,
    "Cannot access windows management instrumentation software. Windows Management files may be moved or missing."  This causes a few programs to stop working, in particular Steam applications.

    I have tried uninstalling a defragmenting application I use and switching anti-virus programs with no effect.

    I have tried fixing the problem using Tim Quan's suggestions in this thread: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1615707&SiteID=17.

    To fix this problem, I have been running system restore to restore the computer back to when the files have not been damaged yet.

    This seems to happen periodically with no apparent cause, it can sometimes be days, sometimes hours, with no relation to installing programs, OS updates, or anything else.

    I'm running Windows Vista SP1 Home Premium.

    Anyone have any light to shed on this situation?

    Thanks.
    Tuesday, November 11, 2008 10:45 PM