none
unable to connect to the analysis services server in the data analysis view RRS feed

  • Question

  • Project 2007 server on SQL 2008

    I am getting this message in the data analysis view when trying to connect to the analysis server. I was able to build the cube successfully so I don't understand why it would failed on the data analysis view. I followed the MS KB927159 and enabled the access data sources across domains option but that didn't help.

    Any suggestion?

    Thanks

    Thursday, February 2, 2012 11:45 PM

All replies

  • Hi,

    Did you install Microsoft SQL Server 2008 Analysis Services 10.0 OLE DB Provider on your client system?

    Review following steps

    http://technet.microsoft.com/en-us/library/dd285466(office.12).aspx

     

    Thanks,

     


    Hrushikesh Deshpande – DeltaBahn Senior EPM Infrastructure Consultant
    Friday, February 3, 2012 5:16 PM
    Moderator
  • double check that ReportViewers group is in the local MSASQLServer**** group and that users have been added to the ReportViewers AD group.

    Cheers


    Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA, MCC 2011
    www.WhartonComputer.com
    Friday, February 3, 2012 5:24 PM
    Moderator
  • Thanks,

    I installed the 2008 AS OLE DB provider on my desktop and it still give the same error when hitting the click to refresh database list.

     

    Keith

    Friday, February 3, 2012 5:42 PM
  • Hello Keith,

    Make sure to add your PWA site under Trusted sites in IE and set the security level to low for the same.

    Also are you able to access the view from any other system like Server? Is this issue is user or machine specific?

     


    Hrushikesh Deshpande – Senior EPM Infrastructure Consultant, www.DeltaBahn.com
    Friday, February 3, 2012 6:14 PM
    Moderator
  • try accessing this directly from the server.

    Also, I've had issues with the *correct* OLE DB provider http://www.applepark.co.uk/sql-server-native-client-%e2%80%93-64-bit-failed-to-build-the-olap-cubes/ 


    Ben Howard [MVP] blog | web
    Friday, February 3, 2012 6:40 PM
    Moderator
  • This is not user or machine specific. The accounts I used is the SSP admin as well as the administrator account in the project server. Also, I also put the site in the local intranet\trusted zone.

    I can't access the site from the server directly as IE in the server has special security settings that is blocking the access to it.

    One thing I noticed is that after I logon as the SSP admin , the Project server site showed (in the upper left corner) as Windows system account, e.g. sharepoint\system instead of domain\sspadmin_name. Is this normal?

    I also verified the cube was created successfully by logon to the MS SQL management console.

     

    Friday, February 3, 2012 7:38 PM
  • If current logged in account is farm admin "System Account" will be displayed

    Assuming you have created a Data analysis view, make sure that you have added My Organization category in the view settings.

     


    Hrushikesh Deshpande – Senior EPM Infrastructure Consultant, www.DeltaBahn.com
    Friday, February 3, 2012 7:41 PM
    Moderator
  • Hi Hrisid,

    My Organization is already under the security category.

    Keith

    Friday, February 3, 2012 8:07 PM
  • is your PWA site added under trusted sites?

     


    Hrushikesh Deshpande – Senior EPM Infrastructure Consultant, www.DeltaBahn.com
    Friday, February 3, 2012 8:28 PM
    Moderator
  • yes it is
    Friday, February 3, 2012 9:02 PM
  •  It was the firewall setting. The project server used a named instance of the analysis service which use a dynamically assigned port which is blocked by the firewall. Now I need to figure out how to configure the analsys service to use a fixed port instead. Thanks again for all the input.
    Wednesday, February 8, 2012 8:04 PM
  • What you probably need to do is open port 1434 which allows the SQL browser to be seen.  Make sure the SQL browser is running on your AS box.  The AS will then talk to the Project Server via named pipes.  I've also had to open port 2382.


    Ben Howard [MVP] blog | web

    Wednesday, February 8, 2012 9:24 PM
    Moderator
  • For some reason, I can only communicate with the AS server from the clients by opening the port that the AS is listening. I managed to assigned a fixed port and it worked without need to specifying the port no. from the client side (it won't work if the port is not open in the firewall). So far, everything seems to be working. Thanks again.
    Thursday, February 9, 2012 10:20 PM