none
sharepoint.aspx is empty - no content / does not load

    Question

  • Hi Everyone,

    I admit I got totally stuck. Cannot get to load: https://namehere.sharepoint.com/_layouts/15/sharepoint.aspx

    A bit of context:

    I wanted to limit the visibility of "Site content" in the top-right cog menu and still let users browse the pages on the root Team Site. With that I found that _layouts are limited when this particular piece of permission is removed/retracted "View Application Pages  -  View forms, views, and application pages. Enumerate lists."

    So I have created custom permission level:

    List permissions: View Items, Open Items
    Site permissions: View pages, Use remote Interfaces, Use Client Intergration features, Open.

    with that done - I have added "Everyone" with such permissions to the root and removed from the standard "Read" SP group.

    Now - sharepoint.aspx does not load for anyone, other pages from _layouts are totally fine.


    When looking F12 in console I get this:

    HTML1506: Unexpected token.
    File: sharepoint.aspx, Line: 36, Column: 1

    Any help appreciated!

    Thursday, February 16, 2017 7:11 PM

All replies

  • Hi NosferKG,

    HTML1506 is one of HTML5 parser warnings. These warnings don't necessarily mean a page is broken, but that the provided HTML is invalid per the HTML5 standard.

    Common causes of these warnings include missing or additional characters, and mismatched tags. Read this article for more information about HTML5 parser warnings.

    For this issue, please click on “Line: 36, Column: 1” link in the console to see which script/code is broken.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, February 17, 2017 9:31 AM
  • Seems that there was an expired token - when it got refreshed page started to work. 

    There is still a question on why it affected only that specific page.

    Friday, February 17, 2017 10:53 AM
  • Hi NosferKG,

    Does this page always need to be refreshed for making it works when opening it?

    The cause of this issue could be the code in this application page.

    Please compare with other application pages to see if there are some specifics in the sharepoint.aspx application page.

    It would be better if you could provide the code of this application page.

    Best regards,

    Linda Zhang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, February 20, 2017 2:28 AM