locked
Problem with Decimal Symbol RRS feed

  • Question

  • Hello,

    I just have a problem after the transfer of the exact copy of a cube on another server. Let me explain :

    With the cube on the server 1:
    I open ProClarity (heavy client), the decimal symbol of my indicators (calculated or not) is a comma. That's what I want.

    With the cube on the server 2:
    I open the same ProClarity, the decimal symbol of my sources indicators is a comma, the decimal symbol of my calculated indicators is a point.

    The consequence of this problem is: when export to Excel (French version), Excel does not recognize the point, only the comma. This is a big problem for us.

    I did not explain this behavior.
    Have you any idea what could cause this problem?

    PS : The version I use is ProClarity 6.3.133.502 with Microsoft SQL Server 2005.
    Friday, January 9, 2009 10:40 AM

Answers

  • Sorry that I have taken so long to post again. 
    The problem was actually the SP2 ! 

    Thank you all for your answers.
    Amélie
    • Marked as answer by Amélie ANNE Wednesday, February 25, 2009 1:49 PM
    Wednesday, February 25, 2009 1:48 PM

All replies

  • Hi Amélie,
    do you have install SP2 of Proclarity

    here you can find some technical informations about SP2
    http://support.microsoft.com/?kbid=958294

    This SP2 fixes some format problem may be in you case this could be an issue for you

    best regards

    Bohor
    Friday, January 9, 2009 2:50 PM
  •  
    No, I have not installed SP2 yet, but I do not see why it is bound.
    I'm using exactly the same ProClarity (on my PC) with the two cubes.

    But ProClarity Analytics Server is installed only on the server of the CUBE 1. Does this may be a link? Should I install PAS necessarily on the same server as the CUBE I want to open with ProClarity in heavy client?

    Thank you for your answers.

    Amélie
    Friday, January 9, 2009 3:26 PM
  • Hello Amelie,

    I'm sorry to hear you're experiencing trouble with the export feature.  Can you please tell us what Operating System language you're using on the client machine?  Also, are you working with localized data?  A French cube perhaps?  When you state that Excel does not recognize the point and only the comma, do you mean that the Excel spreadsheet shows the value with no separator at all?  Or does it display a comma in place of a point?

    Thank you in advance for the additional information.

    Amanda
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, January 9, 2009 6:50 PM
  •  
    I'll try to explain. But is it possible that I send a screenshot?

    It is not with the export feature that I have a problem, but with the display of the decimal separator within ProClarity.

    In ProClarity, we want a comma as a decimal (French format).

    With the cube 1 on the server 1: The separator is a comma, but with the cube 1 on server 2, the separator is a point for calculated indicators (but a comma for sources indicators, which is extremely bizarre !!).

    Excel displays correctly the point and the comma, but only the comma is known as "number", the point is treated as "text" and prevents the calculation of excel formulas.

    On both server (server 1 and 2), language is English. The cubes are on each server,  and have been developed with SSAS.

    I hope I have answered all your questions. Feel free to ask me more!

    Thank you!
    Amélie
    Friday, January 9, 2009 8:52 PM
  • Does anyone have an idea for my problem?

    Thank you in advance ...
    Monday, January 12, 2009 11:13 PM
  • Hi Amelie,

    Can you please post a screen cap? You might consider uploading your attachment to
    http://skydrive.live.com and including a link to it within your next forum posting. Can you please include a capture of the data within the cube browser (in SQL Management Studio) along with a capture of ProClarity's output?

    Thanks in advance,

    Amanda


    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 13, 2009 4:50 PM
  • I'm wondering if this thread helps you at all...

    http://social.msdn.microsoft.com/forums/en-US/sqlanalysisservices/thread/aa3dc0e2-b386-4098-96ae-93efdd73c25c/

    So, the first thing to check is to be sure the regional settings on the server hosting PAS are set to support the number formatting you desire (French, in this case).

    As PAS relies on the UI to select the language, you may need to install the French language pack (or French version of PAS).  Once PAS knows the user is operating in the French language, it will send the LCID for French to Analysis Services, and the data should be formatted correctly.

    Let us know if you're still running into problems after going over this information.
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, January 13, 2009 11:26 PM
  •  
    I may have found the solution.
    SP2 is not installed on one of the two servers.
    It will be installed tomorrow, I will keep you informed of the result.

    Thank you very much,
    Amélie
    Wednesday, January 14, 2009 5:24 PM
  • Sorry that I have taken so long to post again. 
    The problem was actually the SP2 ! 

    Thank you all for your answers.
    Amélie
    • Marked as answer by Amélie ANNE Wednesday, February 25, 2009 1:49 PM
    Wednesday, February 25, 2009 1:48 PM