locked
SharePoint Designer workflow task - problem with multiple users selector in InfoPath form RRS feed

  • Question

  • Gentlemen,

     

    I have got an issue with InfoPath form generated for my SharePoint Designer workflow task. There is a multiple users selector that requests users from a task assignee. The problem is that only the first user entered got saved.

     

    I am using SharePoint 2010 Standard Server (release). Steps to reproduce are the following:

    1.       Create a new workflow with SharePoint Designer

    2.       Add action “Collect data from a user”

    3.       In Custom task wizard (while configuring what data to get from a user) add a form field “Users” of type “Person or Group”

    4.       Set “Allow multiple values?” to checked.

    5.       Publish workflow (InfoPath form will be generated for the task)

    6.       Start a workflow.

    7.       Task will be created and assigned to a user.

    8.       Edit task and specify multiple users in the “Users” field (users are AD accounts and are part of the Owners group for the site)

    9.       Complete task (data will be saved to the task item).

    10.   Result: only first user is saved in the “Users” column of the task.

     

    I have checked the form generated with InfoPath Designer and everything looks fine. Additionally I have tested this scenario on the SharePoint 2010 Foundation deployment. For aspx form that has been generated everything works as expected and all users got saved into the “Users” task column.

     

    Could you please advise on this problem. Is there anything I do wrong or this is an issue with InfoPath 2010 forms?

     

    Thanks,

    Dmitry Rogozhny.

    Tuesday, July 27, 2010 9:37 AM

All replies

  • Hi, I have same problem. Maybe you solved it already?
    Monday, August 2, 2010 8:53 AM
  • Hi Tomas,

    Nope, I did not figure out what was wrong. We have used a workaround with a customer to specify a fixed number of review users (i.e. I have added 3 separate single user fields for a task). Probably you can use the same approach in your case.

    Thanks,
    Dmitry Rogozhny.

    Tuesday, August 24, 2010 8:33 AM
  • You're saying the exact same setup worked in SPF but not in Server Standard?  If so, I will submit it as a bug to the product team and see what's up.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, August 25, 2010 5:16 AM
  • Clayton,

    That would be great if you can do this.

    The generated content type for the task is the same for Foundation and Server (i.e. there is a multiple users field for both cases).
    The only difference is that there is ASPX form generated for Foundation (which works fine) and InfoPath form generated for Standard edition (which does not work as expected and saves only the first user entered).

    Regards,
    Dmitry Rogozhny.

    Wednesday, August 25, 2010 1:54 PM
  • Dmitry, good news (or bad news, depending) is that the product team was able to repro the issue and is logging as a bug with the owner of that feature.  More to come...
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Thursday, August 26, 2010 1:07 AM
  • Let's call it even. I will be really glad if this issue get fixed with next service pack.

    Thanks a lot for your help.

    Thursday, August 26, 2010 7:09 PM
  • I have the same issue !

    Any news from product team about this issue?

     

    Thanks !

    Friday, October 15, 2010 2:17 PM
  • I have not heard back since they logged it as a bug.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, October 15, 2010 3:15 PM
  • Any further news on this one?
    Tuesday, March 8, 2011 3:27 AM
  • OMG!!

    same issue; it seem that anybody will reply with the solution.

     

    I made some test using SharePoint 2010 + infopath2010+workflow task "Collect data from user"

    and it works with windows xp and and Explorer 7.

     

    But when I try the same thing in windows seven (no servicepack1)(Explorer 8) I got the same issue only the first user entered got saved.

    I posted the issue in the following link

    http://social.msdn.microsoft.com/Forums/en-US/sharepointworkflow/thread/d785d368-7134-4fb5-8a59-0c21be1d57e4

    I hope to get an answer soon.

     

    Thursday, May 26, 2011 7:58 PM
  • Is there a solution to this out there yet? By the way, it works fine in an initiation form (which requires the workflow to be started manually). Not much of a solution but it just proves that it's not an inherent limitation in SharePoint Designer for handling a People or Group field with multiple users selected.

    • Proposed as answer by Nazar Kravchuk Wednesday, June 1, 2011 4:16 PM
    • Unproposed as answer by Nazar Kravchuk Wednesday, June 1, 2011 4:16 PM
    Tuesday, May 31, 2011 2:44 PM
  • I faced the same issue but now I have workaround:

    1. Create additional (hidden) field "TemporaryString" with Single Line of Text type
    2. Customize Task Form: Set default value to TemporaryString as fx formula: eval(eval(Person, 'concat(pc:AccountId, "; ")'), ".."). Where Person is field "Users->pc:Person". Check "Refresh value when formula is recalculated".
    3. Then use TemporaryString instead of Users field
    • Proposed as answer by Matt Paul Friday, January 6, 2012 6:05 AM
    Wednesday, June 1, 2011 4:28 PM
  • I have the same issue.  Nazar, I will try out your workaround in the near future and tell you how it goes!

     

    - Matt


    Matt Olson, MS Content Development Specialist MCITP, MCTS
    Friday, June 10, 2011 3:59 PM
  • Nazar, this solution worked for me, but I'm running into another problem with it. I'm trying to take the account IDs that are now in string form (semicolon delimited) and set a list item's read permissions to include those users in a workflow (through the "Add List Item Permissions" action in an impersonation task)- the problem is that the conversion is failing. I'm not exactly sure why. Do you have any ideas?
    Friday, January 6, 2012 6:11 AM
  • Abuse, did you find a way to convert the string type (TemporaryString) to Person or Group type? I have no idea after  a lots of efforts
    • Edited by BkanYs Tuesday, January 10, 2012 2:55 PM
    Tuesday, January 10, 2012 2:52 PM
  • Hey Clayton, is this bug logged somewhere that be referenced online? If so, could you provide the link? Has anyone figure out a workaround for this? The "eval(eval(Person, 'concat(pc:AccountId, "; ")'), "..")" workaround discussed doesn't seem to work when trying to use the values in the "Add List Item Permissions" workflow action (the conversion fails everytime).
    Tuesday, February 7, 2012 5:44 PM
  • Same issues here, and I am using the December CU


    Personal Blog: http://thebitsthatbyte.com

    Tuesday, February 14, 2012 9:18 PM
  • Same issues here, and I am using the Februari CU

    My SharePoint Blog

    Monday, June 18, 2012 9:37 AM