locked
Unable to backup Windows XP SP3 to WHS when other pcs can RRS feed

  • Question

  • I have been working to get my home server completely setup and have been able to backup 2 laptops (wireless, Windows XP Home & Windows Vista Business) and my media center (Windows 7).  However, I have been unable to backup my desktop pc, which my wife uses.  It is running Windows XP Pro SP3.  When I attempt to run a backup, the backup starts and is much slower than my other machines at doing that.  Before it can even get to 50%, the backup fails.  When I look at the event log on the client I receive the following:

     

    Event Type:    Error
    Event Source:    HomeServer
    Event Category:    HomeBackup
    Event ID:    773
    Date:        5/9/2011
    Time:        1:00:37 AM
    User:        N/A
    Computer:    VAN-K
    Description:
    Backup of volume C: to HOME-SERVER failed: Microsoft.HomeServer.Backup.Protocol.ProtocolException: Client / Server connection lost
      at Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.TryReconnect(Int32 localGeneration)
      at Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.ReadWithReconnect()
      at Microsoft.HomeServer.Backup.Protocol.ReconnectableStream.ReadByte()
      at Microsoft.HomeServer.Common.Client.BinaryReaderEx.ReadLong()
      at Microsoft.HomeServer.Common.Client.BinaryReaderEx.ReadInt()
      at Microsoft.HomeServer.Backup.Protocol.BackupProtocol.GetResponse()
      at Microsoft.HomeServer.Backup.BackupOp.BackupOperation.DoWorking(BackupVolumePhase phase)
      at Microsoft.HomeServer.Backup.BackupOp.BackupOperation.RunWithoutCatch()
      at Microsoft.HomeServer.Backup.BackupOp.BackupOperation.Run()

     

    I have started some troubleshooting steps.  I have taken an external hard drive I own and plugged it into this computer and attempted to backup just the external drive.  This worked.  So, I assume there is nothing wrong with my network or network card on the client (nor the whs).  So, this leads me to believe there may be something wrong with the hard drive of the desktop.  I have ran chkdsk /x /r multiple times, and not errors are reported.  I do know that way back in the past, I did have to repair this hard drive but did so with the Western Digital tools and have no issues since. 

    So, my next troubleshooting steps were going to be to plug in the hard drive from this desktop into another pc as an external hard drive and attempt to back it up that way.  If that works, I would probably assume that the drive is ok and that I would be either looking at the hard drive controller on the motherboard or something wrong in Windows XP SP3.  I have also thought about while the hard drive is removed from the desktop, installing windows in demo mode on another hard drive in this desktop and attempting the backup.

    Is there anything else I should be trying or is there something I may be missing?  I did notice that I had some issues when I had system restore disabled on the desktop when attempting the external hard drive backup.  And, since I read that a restore point needs to be made, I enabled the system restore (previously had it disabled when creating nightly images to external hard drive).

    I appreciate any troubleshooting tips anyone can provide.  I'm not necessarily looking for the answer (while that would be beneficial), just some ideas.

     

    Desktop details:

    DIY build

    Motherboard: Biostar K8VGA-M

    80 GB IDE hard drive (WD)

    Windows XP Pro SP3

     

    Thanks.

    Tuesday, May 10, 2011 12:47 PM

All replies

  • I'm getting the same error under that same conditions except that I'm running Windows 7.  Have you made any progress?

     

    Thanks.

     

    Wednesday, June 15, 2011 9:55 PM
  • I ended up finding out that my issue was an installation issue with home server. I had attempted to install using an external dvd rom, built from an internal drive in an external enclosure. Found out the drive was going bad, so I installed from a thumb drive without error and this fixed everything. I backed everything up to an external hard drive first, and forced a full reinstall. I did replace the nic in the pc I was having issues with, only to find that it didn't correct my issue. Sorry can't be more help.
    Thursday, June 16, 2011 8:07 PM