locked
Big NAP problem RRS feed

  • Question

  • Hi all,

    Sorry if this problem has been discussed, I need a link to it. I have tried out to find a solution, but I found none.

    I have a big problem with NAP in Windows 2008. Here is the story: I have Windows 2008 x64 installed. The network card had a fix IP, like 192.168.0.6. I get out to internet through a cable router. I also run Linux x64 on Vmware server.
    I read about Hyper-V and I wanted to try it. I installed it and also I installed NAP.

    When I tried to run my Linux on Wmware, it said that 64 bit is not available any more, even if it was the day before. I suspected that these 2 server roles, Hyper-V and NAP were responsible for that and I uninstalled them. After this my Wmware x64 Linux works perfect, so Hyper-V has disabled this. But after I uninstalled NAP, I cannot connect any more to internet using a fix IP. If I use a fix IP, I get in the network properties that acces is available local only. I have trried everything I could find on internet, including route delete, netsh reset for IP4 etc, but nothing works. The only way to connect to internet now is to use DHCP IP, which is provided by my router.

    The router is OK (I found something like reset the router, but didn't help), because in my Wmware Linux I have a fix IP and it connects to internet without any problem.
    I wantto get rid of NAP (I don't need it, so please *do not* try to convince me to use it) and I want to use a fix IP.

    Is there any way to make my Windows 2008 to use again a fix IP, except to reinstall everything?

    Thank you.



    Sunday, May 11, 2008 9:55 PM

Answers

  • Hi,

     

    I don't think you installed NAP, because it is not a server role. Did you install some services under NPAS (network policy and access services)?

     

    When you can only reach the local network but not the Internet using a static IP address, but it works with DHCP this indicates one of two possible problems:

     

    1) Your default gateway is incorrect

    2) You DNS server settings are incorrect

     

    Make sure your default gateway is the LAN address of your cable router and you have valid DNS server addresses when configured for a static IP.

     

    If you need help to troubleshoot this, please provide the output of ipconfig /all and route print -4 when using DHCP and again when configured with a static IP.

     

    Thanks,

    -Greg

    Monday, May 12, 2008 3:01 AM