none
Known issues connecting to vCenter over DA? RRS feed

  • Question

  • I have a vCenter server in my test lab, and a vSphere client on my laptop.
    The laptop is also configured to use Direct Access as I find it so convenient.

    But if I try to use the fqdn of the vCenter server from my laptop while outside of the office, I get an error about unable to resolve host name.

    server1.lab.domain

    Is this expected behaviour?

    Thank you.
    Thursday, October 14, 2010 9:29 PM

Answers

All replies

  • Hi,

    We were using vSphere client fine before our recent upgrade to v4.1, but we now get the same error. We have been trying to track down the error without luck.

    From looking at network traces, it appears that requests to find the correct VMware host bypass the DA NRPT and try and find the VMware hostmame using the Internet DNS server instead of the DA DNS server.

    Cheers

    JJ


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, October 15, 2010 11:07 AM
    Moderator
  • Update: Apparently the issue is now with VMware engineering and is a suspected vSphere client issue that will need to be fixed...
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, October 15, 2010 12:58 PM
    Moderator
  • I've pointed our app compat people to this thread.

    Thanks!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Friday, October 15, 2010 1:10 PM
    Moderator
  • Are you guys any closer to publishing some form or dynamic list of DA application compatability?


    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Friday, October 15, 2010 3:23 PM
    Moderator
  • Hi Jason,

    I don't know if we have any plans on publishing a public list.

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Monday, October 18, 2010 10:54 AM
    Moderator
  • Hi Jason,

    I don't know if we have any plans on publishing a public list.

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx

    :(
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Monday, October 18, 2010 11:06 AM
    Moderator
  • In the mean time you might find publishing vSphere as an RDS RemoteApp to be a functional workaround.
    MrShannon | TechNuggets Blog | Concurrency Blogs
    Tuesday, October 19, 2010 2:14 PM
  • Thanks!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Tuesday, October 19, 2010 3:01 PM
    Moderator
  • In the mean time you might find publishing vSphere as an RDS RemoteApp to be a functional workaround.
    MrShannon | TechNuggets Blog | Concurrency Blogs

    Yes, but not ideal...
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    Tuesday, October 19, 2010 11:08 PM
    Moderator
  • So, Jason. Have you found any workaround yet?

    Thanks!

    Tom


    MS ISDUA/UAG DA Anywhere Access Team Get yourself some Test Lab Guides! http://blogs.technet.com/b/tomshinder/archive/2010/07/30/test-lab-guides-lead-the-way-to-solution-mastery.aspx
    Wednesday, October 20, 2010 11:15 AM
    Moderator
  • No (apart from thin-client options) so still waiting on VMware to provide a fix...we think it is a vSphere client issue, but the client version is tied to the server version so it is not possible to rollback to a previous client :(
    Jason Jones | Forefront MVP | Silversands Ltd | My Blogs: http://blog.msedge.org.uk and http://blog.msfirewall.org.uk
    • Marked as answer by Erez Benari Wednesday, November 24, 2010 7:42 PM
    Wednesday, October 20, 2010 11:30 AM
    Moderator
  • I know this is an old thread but I wondered if a work around / fix has been produced. Same problem with vSphere v5.1.0
    Tuesday, March 25, 2014 5:01 PM
  • Yes, it was fixed by VMware quite a while ago and I tested the working version at that time (so it definitely worked)...according to my notes here: http://blog.msedge.org.uk/2010/11/uag-directaccess-application.html it was fixed in version 5.0 update 1 and later of the vSphere client...

    Maybe you have other manage-out problems, or does everything work apart from the VMware client?


    Jason Jones | Security Consultant | Microsoft Consultant Services (MCS)

    Tuesday, March 25, 2014 5:16 PM
    Moderator