none
Invoke-QuickStart : Cannot find container specified RRS feed

  • Question

  • Hi Folks, 

    I am almost done setting up my FIM password reset tool, but I am stuck on almost final step,which is "QuickStart tool" synch with AD. PS command that I use looks like this:

    Invoke-QuickStart –Container “OU=test,OU=City,OU=Users,OU=Workstations,OU=branch Office,DC=Domain,DC=Net” –DatabaseName FIMpassword –DatabaseServer Server2 –ForefrontIdentityManagerServiceBaseAddress http://localhost:5725 -Forest Forest.Net –ActiveDirectoryManagementAgentCredential Domain\SA_USR –ForefrontIdentityManagerManagementAgentCredential Domain\SA_FIM_USR –RunInitialLoad $true –verbose


    And I get following error:

    VERBOSE: Verifying the forest and account
    VERBOSE: Verifying the container
    Invoke-QuickStart : Cannot find container 'OU=ARJS test,OU=Kaunas,OU=Users,OU=Workstations,OU=COWI Lithuania,DC=COWI,DC
    =Net'.
    At line:1 char:18
    + Invoke-QuickStart <<<<  -Container "OU=test,OU=City,OU=Users,OU=Workstations,OU=branch Office,DC=Domain,DC=Net"
     -DatabaseName FIMpassword -DatabaseServer Server2 -ForefrontIdentityManagerServiceBaseAddress http://localhost:5725 -
    Forest Forest.net -ActiveDirectoryManagementAgentCredential Domain\SA_USR -ForefrontIdentityManagerManagementAgentCre
    dential Domain\SA_FIM_USR -RunInitialLoad $true -verbose
        + CategoryInfo          : InvalidArgument: (:) [Invoke-QuickStart], PSArgumentException
        + FullyQualifiedErrorId : Invoke-QuickStart,Microsoft.IdentityManagement.QuickStart.InvokeQuickStart

    Can anyone help me with that? If you need any additional info, please let me know.


    Thursday, June 19, 2014 10:55 AM

All replies

  • Hi. It seems that you have wrong container address. Please verify if you have: "OU=ARJS test,OU=Kaunas,OU=Users,OU=Workstations,OU=branch Office,DC=Domain,DC=Net" Please remember that it would be something like: Domain.Net ->Branch Office -->Workstations --->Users ... so you have specified that "ARJS test" is inside OU Kaunas, which is inside OU=Users, which is inside Workstations etc. Make sure all of them are OUs and not CNs (Org Units not Containters) If you wanted to specify more than one OU/CN at once - it is not possible using script. You have to specify only one container/OU now and later change it inside agent.

    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Friday, June 20, 2014 6:46 AM