none
Project Server 2010 DM Dynamic Workflow- Deployment problem? RRS feed

  • Question

  • Hi,

    I am having problems deploying Dynamic Workflow in Project Server 2010. I tried to deploy it using these steps:

    http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/82cefbc5-9b50-4753-92d1-9466c2f30f50

    And when I "Run as administrator" the cmd file, I get this error:

    "The argument '.\Deploy.ps1' to the -File parameter does not exist. Provide the path to an existing '.ps1' file as an argument to the -File parameter."

    Does anybody have a clue why is this happening?

    Thank you all for help

    Sunday, May 26, 2013 10:18 AM

All replies

  • Very your Deply.ps1 file closely , open command prompt using run as administrator.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Monday, May 27, 2013 4:16 AM
    Moderator
  • As per following link,  solution starter is no longer directly deployable WSP packages. , you may have to build WSP file using the source code.

    http://archive.msdn.microsoft.com/P2010SolutionStarter


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Monday, May 27, 2013 5:23 AM
    Moderator
  • In this line of that cmd file:

    PowerShell -file .\Deploy.ps1 %SolutionFolder% %SolutionName%

    change '.\Deploy.ps1' to exact path to your file. For example:

    PowerShell -file c:\temp\Deploy.ps1 %SolutionFolder% %SolutionName%

    Monday, May 27, 2013 9:39 AM