none
Cannot change regional settings: "The column **** in the list or library ***** has been marked for indexing"

    Question

  • Hi Everyone,

    I am trying to change regional setting to my online site but I am getting this error:

    "Sorry, something went wrong

    The column "File Type" in the list or library "Documents" has been marked for indexing. Please turn off all indexed columns before changing the collation of this site. You may re-index those columns after the collation of the site has been changed."

    I am going for the solution described in this https://support.microsoft.com/en-us/help/2824721/error-when-you-change-the-locale-setting-for-the-sharepoint-online-public-website which seems that solves my problem but I cannot find in the SITE CONTENTS the SITE ELEMENTS so the workaround stops there.

    Does someone know how or where to find the Site elements, columns, Site Element ID etc, so I can continue with the guide and solve the problem?

    Thank you

    Saturday, January 21, 2017 9:57 AM

Answers

  • Hi,

    Please open your list or library settings, click "Indexed columns", and remove the indexed column, then change the region and re-add the indexed column.

    Example:

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, January 23, 2017 8:50 AM
    Moderator

All replies

  • You need to click on the List in question first, judging by the above screenshot it should be the MicroFeed list. Once in the right List, you need to press the Gear button and select List Settings, then locate the Column in question and continue with the steps.
    Saturday, January 21, 2017 7:22 PM
  • Hi,

    Please open your list or library settings, click "Indexed columns", and remove the indexed column, then change the region and re-add the indexed column.

    Example:

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, January 23, 2017 8:50 AM
    Moderator
  • Dear Dennis,

    Thank you for your reply,

    unfortunately after trying to delete the index as you described I get a new error saying:

    "Sorry, something went wrong

    The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator."

    After searching for a while I found that the List View Threshold is 5000 Items. From Microsoft:

    "Important: The List View Threshold cannot be changed in SharePoint Online. There also is no ability to create a Daily Time Window on SharePoint Online. Those features are only available on SharePoint 2016, SharePoint 2013, and SharePoint 2010."

    I have more than 100.000 items. That means that I cannot delete the index and that means I cannot change regional settings?

    Thank you for help

    Monday, January 23, 2017 7:10 PM
  • Hi,

    We can also use PowerShell to change the regional settings. It works in my test environment using PowerShell, it avoid the error of "The column "File Type" in the list or library "Documents" has been marked for indexing......".

    Add-Type -Path "c:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\ISAPI\Microsoft.SharePoint.Client.dll" 
    Add-Type -Path "c:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\ISAPI\Microsoft.SharePoint.Client.Runtime.dll" 
    
    $siteURL = "https://xxx.sharepoint.com/sites/dennis"
    
    #This is to change the LocalID
    #First, set up your ClientContext in the normal manner:
    $Password = ConvertTo-SecureString -String "yourPassword" -AsPlainText -Force;
    $ctx = New-Object Microsoft.SharePoint.Client.ClientContext($siteURL);
    $ctx.Credentials = New-Object Microsoft.SharePoint.Client.SharePointOnlineCredentials("xxx@xxx.onmicrosoft.com", $Password);
    #Now we need to set up our target web site object:
    $web = $ctx.Web;
    $ctx.Load($web);
    $ctx.ExecuteQuery();
    #Next, update the settings. In this example, I’m setting the LocaleId to 2057 (en-UK)
    $web.RegionalSettings.LocaleId = 2057;
    $web.Update();
    #Finally, run the ExecuteQuery method to apply the changes:
    $ctx.ExecuteQuery();
     

    More information:

    Microsoft Locale ID Values

    https://msdn.microsoft.com/en-us/library/ms912047(v=winembedded.10).aspx

    How to change regional settings with PowerShell

    https://sharepointrescue.wordpress.com/2016/05/31/how-to-change-regional-settings-with-powershell/

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Tuesday, January 24, 2017 2:10 AM
    Moderator
  • Dennis,

    I don't know how, but the regional settings where changed. I didn't run the script or deleted the index.

    I have two site admins. I have changed Regional settings from Admin 1 profile, even though I had a few errors and tried to save a few times. For a couple of days I was trying to change it from Admin 2 profile also because it was showing the old settings. But the settings I guess were trying to propagate from Admin 1 to all users. Now Admin 2 and all users after about 48 hours has also the regional settings corrected. It was a matter of sync.

    Sorry about that but my experience with SharePoint is for starters. I couldn't imagine that it was going to take that long to propagate to all users and I was trying to force the change.

    Thanx

    Tuesday, January 24, 2017 11:15 AM