none
App can't open with built in administrator account RRS feed

  • Question

  • I was getting UAC shields appearing on some of the icons. I found the solution how to get rid of them by going to the "Local Security Policy" > Local Policies > Security Options and disabling "UAC: Run all administrators in admin approval mode". And of course I ran into the bigger issue. I can't open any windows related app. It says "App can't open with built-in administrator". If I re-enable the policy, the programs work again, but the shields appear again. I really don't want them and they bother me and as far as I have researched this is the only solution I found that is working. 

    Now back to the blue message. I have tried creating a new user and giving it admin rights. Still got the blue message. Then I tried disabling the built-in administrator with method I found on google, (What a shame I can't post links and images here..) Restarted PC, still the same result.


    I really ran out of options. Can somebody smarter than me please help me resolve this problem.

    I'm running Windows 10 Pro.


    P.S. I did not upgrage to Windows 10 from earlier versions, I built PC from scratch and booted from usb.


    • Edited by Lazarus23 Tuesday, July 26, 2016 6:54 PM
    Tuesday, July 26, 2016 6:53 PM

Answers

All replies

  • Well wondering what the UAC shield are on the apps in the first place? Does that occur on a non admin user? Not seen that reported before so think the cause of that would be the key.

    Have you tried reregistering the app via an admin powershell prompt and;

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Wednesday, July 27, 2016 12:03 AM
  • Hello,

    Also run Windows Apps troubleshooter to find and fix additinal issues.

    http://www.kapilarya.com/how-to-use-built-in-troubleshooters-in-windows-10

    Let us know if something helps, Good luck!

    Windows Insider MVP, MS MVP (2014-2016)

    Wednesday, July 27, 2016 2:43 AM
  • Hi Lazarus,

    The solution you found out is correct, but it is not enough, kindly find out this GP below and enable it.

    User Account Control: Admin Approval Mode for the Build-in Administrator Account

    Which is in this path:

    Computer Configuration\Windows Settings\Security Settings\Local policies\Security Options

    Also notice corresponding registry key.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\FilterAdministratorToken

    Regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Thursday, July 28, 2016 7:17 AM
    Moderator