locked
Strange IR remote problem (a little long) RRS feed

  • Question

  • Hi all.
    I am having a really strange problem with my remote. 

    It is the  Windows Vista Certified Media Center MCE Remote Control that is located here. http://www.xpcgear.com/xphavistabk.html  (if you need to know what remote it is)

    My OS is Vista X86 Home Premium, used only for the Media Center.

    When the remote was first installed, it was detected and worked fine, then the very next day, it just stopped working,

    I did the usual troubleshooting, of removing , rebooting and all that, when I went into the Device manager(DM) to install it, that is when I noticed that it seemed to be in a loop of trying to detect it, the DM would flash(refresh) and open up the USB section then close, and it just keeps doing this, also when I had minimized my MCE that is when I could hear the sound that windows makes when a USB device is installed, and this sound just kept repeating over and over and the DM kept flashing. I went into safe mode to see if I could uninstall it that way, and I get the same thing, except this time, about every tenth refresh, the ehome IR would be there with the yellow !, so I right clicked on it to stop the flashing and was able to uninstall it, BUT, then after a couple refresh loops I suddenly had a IR transmitter line show up in my system devices also with the yellow ! , so I caught that one between the flashes, and tried to reinstall driver's and it said the "best drivers are already installed" but when I looked at the reaon why it was not working, it says " The device is not working properly because Windows cannot load the drivers required for this device (Code 31) "

       so I try to uninstall, which it did, then I scanned for hardware changes, and it would not come back up, But now I had the FIRST line back from the USB section the Ehome with the yellow !.. so I caught it again, and did the reinstall driver, again, best one was installed,  code 31 again, uninstalled, and it says it was uninstalled, rescanned for changes and then we get the IR Transmitter line back... and this can just keep going and going... it did each time ask me if I would like to check online for a solution, which I did, but it never did anything, once it asked if I would like to send a report, which I did, but again, it didn't look as if it did anything, the box just sits there.
    Now, thinking it was a bad remote or IR connector, I have taken the remote and tried it on another computer (5 to be exact) and it works perfect on all of them, and all buttons, MCE, the works.. so I can't for the life of me figure this out, and since it is a built in driver I can not just reinstall the driver... I have tried to find the registry settings but I have not had much luck, what I did find will not let me remove or even open, I have looked to see if there was any atomatic updates but I saw none for that day, I even used the system restore to go back to the previous day when it was installed and with no luck, a few days earlier then that, and again no luck.

    then I came across this site, and here I am...I have looked thru many USB problems and have tried many of them, like removing all USB devices and Uninstalling in DM, and the INFCACHE thing, and the darknight solution, ect.
    does anyone know where the drivers go for these remotes and how to manually remove them??? or know the registry keys to remove them...or anything that may help to get this remote working again?
    Sytem Stats if you need them are.

    AMD x64 @ 4200

    GIGABYTE GA-MA69GM-S2H AM2 AMD 690G HDMI Micro ATX motherboard

    3 gig DDR2 800 Corsair memory with 1 gig set to internal graphics

    Hooked up thu HDMI to 42" LCD TV

    all drivers and bios are up to date.

    Thank you for your help.

    Wednesday, October 17, 2007 9:16 PM