locked
Is there any way to REALLY disable Excel Web Access? RRS feed

  • Question

  • Dear folks,

    I believe the topics related to "Disabling Excel Web Access" has been a popular/common issue. We actually encountered this before and we got a work around solution, but now our users have reported this to us again and the work around solution doesn't work in this case.

    Folks,

    We have tried the following as many guys suggested in this forum:

    1) Set the document library's advanced settings to open browser enable documents in the client application.

    2) Stop the Excel Services on the server farm. (we stopped the entire from server farm already)

    3) Ensured that Excel Service administration has been removed from the Shared Services

    The very strange thing is that even we have completely removed Excel Services from the Farm, the excel file still opens in Excel Web Access (i.e from IE), anyone has encounterd this before and any suggestions? Is this a Microsoft Bug or we have missed something?

    Kindly advise and help to resolve. Thanks a lot!!


    antibugs
    Monday, November 14, 2011 2:57 AM

Answers

  • Hi antibugs,

     

    Thanks for your post.

     

    If you install Excel Service on SharePoint, a hidden feature , whose name is “Excel Service Site Feature” , will be activated for every site. You can try to deactivate the feature, and check the result.

    The id of the feature is “3CB475E7-4E87-45Eb-A1F3-DB96AD7CF313”.

    Stsadm – o deactivatefeature – id 3CB475E7-4E87-45Eb-A1F3-DB96AD7CF313 –url http://<servername>

     

    Share your views.

     

    Thanks,

    Wayne Fan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.

    Tuesday, November 15, 2011 6:58 AM

All replies

  • Probably only this General questions/discussions space is being monitored.. Anyway, I do really need some gurus like YOU to shed some lights on an Excel Services question. (perhaps i doubt this is a Microsoft Bug and cannot be fixed in SP2007).

    In order not to duplicate the discussion, I copy the original URL below:
    http://social.msdn.microsoft.com/Forums/en-US/sharepointexcel/thread/e79a2342-fdba-4101-8e51-0a4c4e54f479

    Thanks


    antibugs
    • Merged by Wayne Fan Tuesday, November 15, 2011 6:59 AM The same issue
    Monday, November 14, 2011 6:11 AM
  • Hi,

    Did you check this - http://social.msdn.microsoft.com/Forums/en-US/sharepointexcel/thread/5badf61b-5da0-4eb0-ab16-8da88a83825a/ ?

    The EWA feature is associated with enterprise feature, so either you can deactivate the feature or follow instructions mentioned in above article.

    hth


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/ | Posting is provided "AS IS" with no warranties, and confers no rights
    Monday, November 14, 2011 11:01 PM
  • Thank you Pratik. I actually read this article before..

    We are setting a specific permission to a single file which is xlsx. We cannot change to xls as we have some xlsx-specific features enabled in the file..

    I have disabled those Entreprise Features, but somehow it still renders as Web Access for the customized-permission xlsx..


    antibugs
    Tuesday, November 15, 2011 6:29 AM
  • Is this Sharepoint 2007 or Sharepoint 2010 ?

    Tuesday, November 15, 2011 6:38 AM
  • Hi antibugs,

     

    Thanks for your post.

     

    If you install Excel Service on SharePoint, a hidden feature , whose name is “Excel Service Site Feature” , will be activated for every site. You can try to deactivate the feature, and check the result.

    The id of the feature is “3CB475E7-4E87-45Eb-A1F3-DB96AD7CF313”.

    Stsadm – o deactivatefeature – id 3CB475E7-4E87-45Eb-A1F3-DB96AD7CF313 –url http://<servername>

     

    Share your views.

     

    Thanks,

    Wayne Fan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.

    Tuesday, November 15, 2011 6:58 AM