locked
IPV6 problem on Linux running on Hyper-V 2012 RRS feed

  • Question

  • Hello!

    I have a problem with ipv6 connectivity from linux systems running on hype-v 2012. IPV4 connectivity is OK. Windows virtual machines ipv6 connectivity works without any problem but on linux i can't ping anything. If I try to ping my default gateway or any other ipv6 address I get:

    [root@rhel6-test ~]# ping6 xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx
    PING xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx(xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx) 56 data bytes
    From ::1 icmp_seq=2 Destination unreachable: Address unreachable
    From ::1 icmp_seq=3 Destination unreachable: Address unreachable
    From ::1 icmp_seq=4 Destination unreachable: Address unreachable

    The only IPV6 address I can ping is localhost

    [root@rhel6-test ~]# ping6 ::1
    PING ::1(::1) 56 data bytes
    64 bytes from ::1: icmp_seq=1 ttl=64 time=0.165 ms
    64 bytes from ::1: icmp_seq=2 ttl=64 time=0.072 ms
    64 bytes from ::1: icmp_seq=3 ttl=64 time=0.068 m

    My network configuration is the same as on my vmware linux virtual machines and everything works just fine there. In fact I can transfer machine from hyper-v to vmware and ipv6 connectivity will work without changing anything.

    MY CONFIGURATION:

    /etc/sysconfig/network

    [root@rhel6-test ~]# cat /etc/sysconfig/network
    NETWORKING=yes
    NETWORKING_IPV6=yes
    HOSTNAME=rhel6-test

    /etc/sysconfig/network-scripts/ifcfg-eth0

    [root@rhel6-test ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
    DEVICE="eth0"
    HWADDR="00:15:5D:FA:95:13"
    NM_CONTROLLED="yes"
    ONBOOT="yes"
    BOOTPROTO=static
    IPADDR=xxx.xxx.xxx.xxx
    GATEWAY=xxx.xxx.xxx.xxx
    NETMASK=255.255.255.0
    IPV6INIT=yes
    IPV6ADDR=yyyy:yyyy:yyyy:yyyy:yyyy:yyyy:yyyy:yyyy
    IPV6_DEFAULTGW=xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx:xxxx

    I have the lates linux integration services (3.4). I have tried with/without integration services. With legacy and normal network adapter. The result is always the same.

    Did anyone encounter similar problems?

    Thank you for your answers.

    Kind regards,

    Skoofy


    • Edited by Skoofy Friday, October 19, 2012 11:59 AM
    Friday, October 19, 2012 11:58 AM

All replies

  • Hi,

    I have the same issue, also when looking in dmesg i got:

    eth2: IPv6 duplicate address 2001:xxx:xxx::xxx detected!

    This VM CentOS 6.3 server worked without any problems on Hyper-V Server 2008 R2.

    Saturday, January 5, 2013 12:24 PM
  • Hi,

    We are experiencing the same problem. Have upgraded to Server 2012 with Hyper-V and imported a bunch of linux VMs..  all of them have lost IPv6 connectivity...   can only ping ::1.

    Strange thing is that on another test server I also have Windows Server 2012 and Hyper-V, and have installed Ubuntu from scratch there..  and IPv6 is working...

    Did any of you find a solution to this problem?

    Thursday, February 28, 2013 8:48 AM
  • Hi,

    Still no luck with IPv6 on Linux. Even after reinstalling no luck with. Maybe it could has someting to do with all the offloading capabilities of NICs. That is someting I am going to change on the NIC that is configured for virtual machines, the virtual switch.

    Saturday, April 27, 2013 8:36 PM
  • Hi,

    I worked around it, I have added these lines to /etc/sysctl.conf:

    net.ipv6.conf.eth2.accept_dad = 0
    net.ipv6.conf.eth2.dad_transmits = 0

    This gave me atleast IPv6 functionality back in CentOS.

    Regards,
    Hugo

    Monday, May 20, 2013 3:17 PM