locked
Internet Explorer 9 will not install on Windows Server 2008 R2 Enterprise with SP1 RRS feed

  • Question

  • I am setting up a VPS running a fresh install of Windows Server 2008 R2 Enterprise.  Service Pack 1 was slipstreamed within the install.  There are no third party applications installed.  All updates from Windows Update are installed except for Internet Explorer 9.

    While attempting to install Internet Explorer 9, I get the following error message:

    Internet Explorer did not finish installing

    For more information, see the Internet Explorer Troubleshooter. This link is also on your desktop for later reference.

     

    Here is a list of things I've tried:

    • Install from Windows Update screen
    • Install of the redistributable downloaded from http://www.microsoft.com/en-us/download/details.aspx?id=23332
    • Using the "/update-no" switch
    • Disabled the network adaptor
    • Safe mode (minimal/no network support)
    • Deleting all files in C:\Windows\Temp and C:\Windows\SoftwareDistribution\Download
    • sfc /scannow finds no errors
    • Attempting to install KB2454826 displays the message, "The update is not applicable to your computer."

     

    Event Viewer has the following message under the Setup channel:

    Package 982861 failed to be changed to the Installed state. Status: 0x80070002.

     

    From IE9_NR_Setup.log:

            6.1.7601-2.1 SERVER.SERVER\user  OS:AMD64  IENrUtil:amd64  IEversion:8.0.7601.17514  Date(UT):20121128-163933
            Command line: C:\Windows\TEMP\IE9AFEB.tmp\IE9-support\ienrcore.exe /memsec IESETUP_NRCTX_04c8
    ________Parsing dynamic policy file: 'C:\Windows\TEMP\IE9AFEB.tmp\IE9-support\NrPolicy.txt'
    ________ WARNING ________ IESetup environment variable is predefined as 'C:\Windows\TEMP\IE9AFEB.tmp\IE9-support'
            MSU location set to 'C:\Windows\TEMP\IE9AFEB.tmp\IE9-support\IE9-win7AMD64.msu'
            IE version set to '8.0.7601.17514'
            IE bitness set to 'amd64'

            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  IF NOT EXIST "%IESetup%\IeNrCore.exe" exit 1 > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'
            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  IF NOT EXIST "%IESetup%\ieinfra.manifest" exit 1 > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'
            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  IF NOT EXIST "%IESetup%\trustedinstaller.exe.manifest" exit 1 > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'
            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  echo Mumfile = "%IESetup%\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~%IESetupBitness%~~%IESetupInstalledVersion%.mum" > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'
    Mumfile = "C:\Windows\TEMP\IE9AFEB.tmp\IE9-support\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~amd64~~8.0.7601.17514.mum"

            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  IF NOT EXIST "%IESetup%\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~%IESetupBitness%~~%IESetupInstalledVersion%.mum" exit 1 > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'
            executing must-succeed process '"C:\Windows\System32\cmd.exe" /C  IF NOT EXIST "%IESetup%\Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~%IESetupBitness%~~%IESetupInstalledVersion%.cat" exit 1 > C:\Windows\Logs\IESetup_20121128-163933_temp.log 2>&1'


    NRFindPreserviceProblems...

    Wednesday, November 28, 2012 10:07 PM

Answers

  • Hi,

    Thank you for the post.

    First, you should follow the in this kb: http://support.microsoft.com/kb/2409098, and this issue may also occur by Group Policy, so you may try to migrate the server to a new OU and install the IE9 manually and see if it works.

    Regards,


    Nick Gu - MSFT

    Tuesday, December 4, 2012 8:42 AM

All replies