none
Is there a way to change the display project calculated duration to round numbers instead 3.87 d RRS feed

All replies

  • Hi Riollano --

    If your task durations are appearing as fractions / decimals, then perhaps your project and task calendars do not match the calendar options for the projects.

    Check the working hours for your project calendar and compare them to the calendar options for the project, such as default start time and default end time:

    • Project / task calendar working hours: 'Project' tab > 'Change Working Time'
    • Project calendar options: 'File' tab > 'Options' > 'Schedule'

    These instructions assume that you are using Project 2010; if you are using a different version of MS Project, then the process may be slightly different.

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    Monday, August 26, 2013 12:23 PM
  • Riollano,

    Decimal values in the Duration field are most often the result of tasks that do not start and finish at the beginning and end of the work day. For example, a task may start at 8:00 am but finish at 2:00 pm the next day due to the work content. The duration will then show as 8.63 days. There is nothing wrong with this, Project is just being precise.

    Another factor that can show non-integer values for duration is a mismatch between the calendar working hours and the setting for "hours per day". Tony touched on this in his response but let me carry it a bit further. Let's say you created a custom calendar for a 7.5 hour work day but did not change the hours per day setting from the default value of 8. In that case Project will display 0.94 days in the Duration field for a 1 "day" (i.e. 7.5 hour) task.

    Also keep in mind that Project handles all time values in minutes (actually 10ths of a minute). What you see in the Duration field is strictly for display. It is based on the settings for "hours per day", "hours per week", or "days per month".

    To answer you basic question, the Duration field displays the correct value based on your schedule parameters. Short of getting your calendars and default settings aligned as Tony suggests, there is no way to round the values shown in the Duration field. You could however, create a custom text field with following formula:

    Text1=Cint([Duration]/480) & " days" 'assuming a normal 8 hour day

    Hope this helps.

    John

    Monday, August 26, 2013 3:06 PM
  • I have found that when I set the Task Type to 'Fixed Duration' (task information> advanced tab) the duration will remain as a whole number and the assignment work will change.  Other factors may come into play on this but when I set the task type,  enter a task name, enter resource name, enter duration then change the work value the duration remains a round number.  This may not align to your scheduling process but I hope this might be a possible solution for your issue.

    Monday, August 26, 2013 4:04 PM