none
Workflow data parameters not flowing to sync rule RRS feed

  • Question

  • I am using MIM 2016 and for provisioning AD I use a MPR / Set / Workflow. The MPR is set for transition in triggering the workflow

    In the workflow I have used some MIMWAL including Generate Unique Values (for accountname) and Function to populate WorkflowData parameters (vAccountName, vHomeDirectory)

    In the workflow I then use an update resources to set the Target/AccountName to the workflowdata/AccountName value 

    In the sync rule I flow the AccountName to sAMAccountname and also the WorkflowData/vHomeDirectory

    The problem I have is that any value that is set through a Workflow parameter when used in the sync rule has a final value of null

    Have been over everything several times and tried different ways but still the same issue. 

    I do need to set these values in the workflow as opposed to the sync rule directly so looking for the solution more so then a workaround please

    Wednesday, February 1, 2017 8:28 AM

All replies

  • Hi

    In the workflow, you need the activity to add target to the sync rule and in that activity you can specify the workflow parameter. You also need to specify the workflow parameter in the sync rule.

    Remember that a workflow parameter only exists in that workflow instance and will not be saved any ware and there for can only be used as a "initial flow only" rule.

    If you need to have a persistent flow in the sync rule set the value to a new attribute in MIM.

    Thursday, February 2, 2017 2:43 PM