none
open file with default program

    Question

  • Hi,

    I have windows server 2008. I want to create a group policy for user to open a file with extension .xlm with MS Excel program by default. I have two questions. Need help!

    1. Do I have to install Excel program on server? I need to select Associated Program (refer to the image below). If I won't install the program, I can't select it.
    2. Should I create a new policy for it or edit the Default Domain Policy? 

    Need advice!

    Thanks in advance!


    Grace

    Wednesday, February 22, 2017 6:49 PM

All replies

  • Hi Grace,
    1.Even if the app is not installed on the server where you’re editing policy, you can manually type in the full path to the .exe as it would exist on the client. Or, you can install the Remote Server Administration Tools (RSAT) on one of your machines where the app is installed and edit the GPO from there.
    You could see more details from: https://social.technet.microsoft.com/wiki/contents/articles/6452.how-to-configure-an-open-with-preference-group-policy-item.aspx
    2.Generally, i would suggest you create a new GPO instead of default domain policy.
    Best regards,
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, February 23, 2017 1:05 PM
    Moderator
  • Hi Grace,

    Just checking in to see if the information provided was helpful. And if the replies as above are helpful, we would appreciate you to mark them as answers, please let us know if you would like further assistance.

    Best Regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, March 01, 2017 6:13 AM
    Moderator
  • Hi Wendy,

    Thank you for your help! It doesn't work. Here is what I configured, but it doesn't work. The program path is the same as it is on the client computer. Please help!



    Grace

    Wednesday, March 01, 2017 7:41 PM
  • it may be due to the variation of Office installations in your organisation?

    Or the variation of Windows versions in your organisation?

    Or, because your original question was for XLM but your screensnap shows XLS ?

    when I check my Win10, 64bit, with Office2013 (MSI, not C2R O365), I have this..


    C:\Users\Don>assoc .xlm
    .xlm=Excel.Macrosheet

    C:\Users\Don>ftype Excel.Macrosheet
    Excel.Macrosheet="C:\Program Files (x86)\Microsoft Office\Office15\EXCEL.EXE" /dde
    C:\Users\Don>

    you can do a similar check in your organisation.

    I also know that I have no need to set these file types/associations, because the Office installer correctly places these file types/associations during the setup phase.

    Are you sure you need to push these settings? (they should already be there, if all is healthy in your environment)


    Don [doesn't work for MSFT, and they're probably glad about that ;]


    Wednesday, March 01, 2017 8:44 PM
  • Hi Don,

    Thank you for your reply. The file extention is .xls. Sorry! It is typo in the first post.

    I check two Windows 10\Office 2016 computers. One of them has Excel as default program, but the other one set Paint as the program to open .xls. The GP still not work. Please help.

     


    Grace

    Friday, March 10, 2017 1:18 AM
  • Hi Don,

    The GP works now. I think I made mistake for the program path. but the other problem is that we have mixed OS and Office version. so the path to the program are different on different computer. How to resolve this problem?

    Thanks!


    Grace

    Friday, March 10, 2017 8:24 PM
  • The GP works now. I think I made mistake for the program path. but the other problem is that we have mixed OS and Office version. so the path to the program are different on different computer. How to resolve this problem?

    In the GP-Preferences settings, on the 'Common' tab, you can enable Item Level Targeting, and create a condition.
    The condition, could perhaps be;
    "File Match", so that 'if the file "C:\Program Files (x86)\Microsoft Office\Office15\EXCEL.EXE" exists, apply <this setting>.

    Then, have a second preference item (within the same GPO), which has;
    "File Match", so that 'if the file "C:\Program Files\Microsoft Office\Office15\EXCEL.EXE" exists, apply <that setting>

    Note that;

    - 32bit Office15 on 32bit Windows: C:\Program Files\Microsoft Office\Office15\EXCEL.EXE" exists
    - 64bit Office15 on 64bit Windows: C:\Program Files\Microsoft Office\Office15\EXCEL.EXE" exists
    - 32bit Office15 on 64bit Windows: C:\Program Files (x86)\Microsoft Office\Office15\EXCEL.EXE" exists

    - You cannot have both/mixed 32bit Office *AND ALSO* 64bit Office on the same machine, this is unsupported by MSFT and Office setup.exe will detect/block an attempt to do so. So, you should not have to cater for any further permutations.

    some info/examples showing ILT:

    https://technet.microsoft.com/en-us/library/dn789189(v=ws.11).aspx

    http://www.dell.com/support/article/au/windows-server--using-item-level-targeting-with-group-policy-preferences/audhs1/SLN285439/en?lang=EN

    http://techgenix.com/group-policy-preferences-top-5-item-level-targeting-options/


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Friday, March 10, 2017 10:51 PM