locked
Why is msftesql.exe consuming so much paged pool memory in Exchange 2007? RRS feed

  • Question

  • Hi;

    I have been troubleshooting some disk performance issues with our Exchange 2007 server and found that that the paged pool memory is extremely high.

    I have also ran a utility called PAL that analyzes performance counters and lets you know if there are any issues. It states the following:


    This is how it looks in my task manager:

    This server is virtual with 2 vCPU and 12 GB of RAM assigned to it. On average, it consumes about 7 to 8 GB of memory during production. There are approximately 370 mailboxes and approximately 150 mobile devices connected in through active sync. All the mail store volumes and log volumes are presented through iSCSI connections.

    So I guess first off, I'm trying to figure out why the msftesql.exe process has high pool paged memory and what effects this is happening on the server.

    Thanks!



    • Edited by Steinomite Friday, November 2, 2012 10:45 PM
    Friday, November 2, 2012 10:40 PM

Answers

  • Hello:

    Sorry it has taken so long to get back to you, but I have not been able to recreate the issue. The msftesql.exe process has not spikes since a reboot of the server. So it appears that the reboot possibly resolved the issue.

    On a related note, I am still seeing very high paged pool memory. It appears that what wasn't consumed by msftesql.exe has been redistributed between other resources. According to my research, the paged pool memory should never go over 200 K, but mine consistently sits around 900,000+.

    Is this normal? Could the issue still be related to search catalog?

    Thanks

    • Proposed as answer by Zi FengModerator Thursday, November 8, 2012 6:00 AM
    • Marked as answer by Steinomite Thursday, November 8, 2012 5:36 PM
    Wednesday, November 7, 2012 9:29 PM

All replies


  • Could be an issue with Search Catalog build process.

    When you notice this issue, you may try to disable the Indexing on the database and can check if you stll face the same issue. if you have many databases then one or more database might be causing this problem where there could be an issue with Search Index / Catalog Rebuild.

    To disable the SearchIndex for 1 Database:

    Set-MailboxDatabase DatabaseName -IndexEnabled:$False

    for all Database you can run the command below:

    Get-MailboxDatabase | Set-MailboxDatabase -IndexEnabled:$False

    Afer you figure that it is an issue with search catalog , you may either try to run commands below after navigating to your exchange Scripts folder on the Exchange management shell or move the mailboxes if you want to:

    .\ResetSearchIndex.ps1 -Database DatabaseName -Force   => for 1 Database

    Rebuild search Catalog For all databases:

    .\ResetSearchIndex.ps1 -All -Force

    PS: Also make sure to enable the Indexing for the databases if you Disable the Search Index. If you won't enable the Index then "Outlook Online Mode"/OWA Users won't be able to search from their mailboxes.

    Also wanted to know the Service Pack/RU version for you Exchange 2007.


    M.P.K ~ ( Exchange | 2003/2007/2010/E15(2013)) ~~ Please remember to click “Vote As Helpful" if it really helps and "Mark as Answer” if it answers your question, “Unmark as Answer” if a marked post does not actually answer your question. ~~ This Information is provided is "AS IS" and confers NO Rights!!





    • Edited by PK M Monday, November 5, 2012 1:46 PM
    Monday, November 5, 2012 5:33 AM
  • Hi

    Did you try from above post?

    Also you can restart the the "Microsoft Search (Exchange Server)" service to check if it will flush the memory.

    Cheers

    Zi Feng

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Zi Feng

    TechNet Community Support

    Monday, November 5, 2012 7:21 AM
    Moderator
  • Hi Steinomite

    Any update on thread?

    Cheers

    Zi Feng

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com


    Zi Feng

    TechNet Community Support

    Wednesday, November 7, 2012 2:31 AM
    Moderator
  • Hello:

    Sorry it has taken so long to get back to you, but I have not been able to recreate the issue. The msftesql.exe process has not spikes since a reboot of the server. So it appears that the reboot possibly resolved the issue.

    On a related note, I am still seeing very high paged pool memory. It appears that what wasn't consumed by msftesql.exe has been redistributed between other resources. According to my research, the paged pool memory should never go over 200 K, but mine consistently sits around 900,000+.

    Is this normal? Could the issue still be related to search catalog?

    Thanks

    • Proposed as answer by Zi FengModerator Thursday, November 8, 2012 6:00 AM
    • Marked as answer by Steinomite Thursday, November 8, 2012 5:36 PM
    Wednesday, November 7, 2012 9:29 PM
  • Hi

    Glad to hear it is resolved, Please Mark As Answer for this thread.

    Maybe below blog would explain something.

    http://blogs.technet.com/b/exchange/archive/2006/10/11/3395063.aspx

    It said: "You might notice that a third process actually uses most of the CPU - it is because MS-Search is actually composed of the core indexer (msftesql.exe) and a sacrificial filter daemon (msftefd.exe) which can be recycled at will. That's where the protocol handler, filters and word breakers live. "

    Cheers

    Zi Feng

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contacttnmff@microsoft.com


    Zi Feng

    TechNet Community Support


    Thursday, November 8, 2012 5:59 AM
    Moderator