locked
Stsadm Import Error RRS feed

  • Question

  • I'm using the awesome gl-import2 from Gary Lapointe to import an exported web under another.

    I already used this tool many times but this time I have an error that occur that I cannot solve.

    I first ran the command "STSADM -o export -url "http://myportal/is/sba/security/" -filename "\\myserverlocation\Export\IS Security\2011-11-10-IS Security" -overwrite -cabsize 1024 -versions 4" to export the site.

    Then I ran the command "stsadm -o gl-import2 -url "http://myportal/security/infosec" -filename "\\myserverlocation\Export\IS Security\2011-11-10-IS Security.cmp" -retainobjectidentity" to import it.

    But I get the error :

    [11/10/2011 1:37:33 PM]: Progress: De-Serializing Objects to Database.

    [11/10/2011 1:37:34 PM]: FatalError: The folder that would hold URL '/sba/security' does not exist on the server.

    Can you please help me?

    Thursday, November 10, 2011 12:44 PM

Answers

  • I don't exactly know the cause of the problem but and retry with the classic import from stsadm and it worked!

    In my case I didn't have to use the gl-import2 because object identity were not required. I could create new ones.

    • Marked as answer by JaiméS Tuesday, November 15, 2011 11:35 AM
    Tuesday, November 15, 2011 11:35 AM

All replies

  • Hi,

     

    Thank you for your post.

     

    This is a quick note to let you know that we are performing research on this issue.

     

    Thanks,

    Pengyu Zhao

     

    • Proposed as answer by Binod M P Monday, November 14, 2011 2:17 PM
    • Unproposed as answer by Binod M P Monday, November 14, 2011 2:17 PM
    Monday, November 14, 2011 11:05 AM
  • Hello,

     

    I already made research on this an cannot found any reason about this issue.

    This is why I'm posting it.

    Monday, November 14, 2011 2:43 PM
  • Hi,

    "stsadm -o gl-import2 -url "http://myportal/security/infosec" -filename "\\myserverlocation\Export\IS Security\2011-11-10-IS Security.cmp" -retainobjectidentity"

    is not created by Microsoft. This command was introduced by: http://blog.falchionconsulting.com/index.php/2007/10/a-better-import/ which is a third party add-on.

    Please try using stsadm –o import and see if the error returns.

     


    Regards, Savoeurn Va Microsoft Online Community Support
    Monday, November 14, 2011 2:58 PM
  • This command makes exactly the same as the Microsoft Command expect that you can keep objects identity. I do not think the error comes from the object identity. I will try tomorrow and give you a feedback.
    Monday, November 14, 2011 4:27 PM
  • You may find difficulty in finding an "official" resolution to this issue as the gl-stsadm extensions are a third party product. Yes, the tool peforms a similar action to the built-in import operation, but officially Microsoft won't support it since they didn't make it.

     

    That said, may I ask what sort of customizations are in the original site you exported? The error sounds like a problem related to a webpart or other customization that relies on the /sba/security path which doesn't make sense in the new location of /security/infosec.

     

    Put another way, it sounds like there is a webpart that has been configured to use /sba/security. When the import runs, it is trying to activate this webpart in the new location using the old configuration instead of recognizing this new site as a different site than the original (something gl-import2 can't anticipate or resolve).

     

    May I ask why you are performing an export and import? What is your goal? Are you moving the security site to a new location, are you copying the site, or are you attempting some other task? Perhaps there is another way to do what you want.

    Monday, November 14, 2011 7:47 PM
  • Hi,

    Try using powershell script for the same.

    Refer this 

    http://gallery.technet.microsoft.com/ExportImportSiteUsingPowers-d22e2780

    I hope this will help you out


    Thanks, Rahul Rashu
    Tuesday, November 15, 2011 4:33 AM
  • I don't exactly know the cause of the problem but and retry with the classic import from stsadm and it worked!

    In my case I didn't have to use the gl-import2 because object identity were not required. I could create new ones.

    • Marked as answer by JaiméS Tuesday, November 15, 2011 11:35 AM
    Tuesday, November 15, 2011 11:35 AM