none
Using SMTP Mail Relay instead of Exchange RRS feed

  • Question

  • I am trying to use an SMTP Mail Relay instead of Exchange (due to licensing issue) for the FIM Service to send out notification and approval e-mails. So, in the FIM config file, I changed the Mail Server configuration from:

        <add key="mailServer" value="https://XXXX/ews/exchange.asmx" />
        <add key="isExchange" value="1" />

     to:

       <add key="mailServer" value="smtp.lab.XXX.com" />
        <add key="isExchange" value="0" />

    Then I restarted the FIM Service. However, the mail feature has stopped working after switching to the mail relay. Is there any further configuration work needed somewhere else?

    Thursday, December 11, 2014 11:39 PM

Answers

  • Make sure that FIMService server is allowed to connect to this SMTP relay and FIMService account has permission to send emails through it.

    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Monday, December 15, 2014 11:09 AM
  • There are four keys I'd like to draw your attention to in the Microsoft.ResourceManagement.Service.exe.config file that define each instance of your FIM Service:

    • mailServer – you have two options here:
      • Exchange 2007 – this is the http path to the Exchange web services
      • Exchange 2003/Other SMTP – the smtp server address
    • isExchange – Only set this to 1 if this is Exchange 2007, even if it's Exchange 2003
    • sendAsAddress – the SMTP formatted address you are sending from, must correspond to the address assigned to you FIM WS account
    • synchronizationServerName – no effect on mail delivery, but this has to be set to the server or virtual server (in the case of cluster config) your sync service is installed on

    Below is a typical configuration for a non-Exchange 2007 configuration:

    <appSettings>
    <addkey="mailServer"value="mail.domain.com"/>
    <addkey="isExchange"value="0"/>
    <addkey="sendAsAddress"value="svc-fimws@domain.com"/>
    <addkey="synchronizationServerName"value="syncserver"/>
    </appSettings>

    "svc-fimws@domain.com" account has to be mail enabled.

     If you plan to use SMTP for notifications rather than Exchange Server, ensure that this service account has the required permissions on the SMTP gateway.


    Regards~
    Deepak Arora
    -------------------------------------
    If you Find the Answer | Article | Blog Helpful Please Vote As Helpful / Mark As Answer


    Monday, December 15, 2014 2:13 PM
  • FIM Server has to be allowed SMTPRelay.  This is done in SMTP Server.

    Usually this feature is disabled to stop developers from sending emails in excess.

    Best,

    Nosh


    Nosh Mernacaj, Identity Management Specialist

    Thursday, January 22, 2015 12:59 AM

All replies

  • Are there any errors in the Event Viewer when the mail is being sent, or is it not being sent at all?
    Monday, December 15, 2014 9:06 AM
  • Make sure that FIMService server is allowed to connect to this SMTP relay and FIMService account has permission to send emails through it.

    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Monday, December 15, 2014 11:09 AM
  • There are four keys I'd like to draw your attention to in the Microsoft.ResourceManagement.Service.exe.config file that define each instance of your FIM Service:

    • mailServer – you have two options here:
      • Exchange 2007 – this is the http path to the Exchange web services
      • Exchange 2003/Other SMTP – the smtp server address
    • isExchange – Only set this to 1 if this is Exchange 2007, even if it's Exchange 2003
    • sendAsAddress – the SMTP formatted address you are sending from, must correspond to the address assigned to you FIM WS account
    • synchronizationServerName – no effect on mail delivery, but this has to be set to the server or virtual server (in the case of cluster config) your sync service is installed on

    Below is a typical configuration for a non-Exchange 2007 configuration:

    <appSettings>
    <addkey="mailServer"value="mail.domain.com"/>
    <addkey="isExchange"value="0"/>
    <addkey="sendAsAddress"value="svc-fimws@domain.com"/>
    <addkey="synchronizationServerName"value="syncserver"/>
    </appSettings>

    "svc-fimws@domain.com" account has to be mail enabled.

     If you plan to use SMTP for notifications rather than Exchange Server, ensure that this service account has the required permissions on the SMTP gateway.


    Regards~
    Deepak Arora
    -------------------------------------
    If you Find the Answer | Article | Blog Helpful Please Vote As Helpful / Mark As Answer


    Monday, December 15, 2014 2:13 PM
  • FIM Server has to be allowed SMTPRelay.  This is done in SMTP Server.

    Usually this feature is disabled to stop developers from sending emails in excess.

    Best,

    Nosh


    Nosh Mernacaj, Identity Management Specialist

    Thursday, January 22, 2015 12:59 AM