none
Powershell script doesn't show up when scheduled as task, even though it works

    Question

  • I have one question to ask… My scripting works just fine because it does what it’s supposed to do and the logs and history say so… But, whenever the script starts, I don’t see powershell poping up in front, it does everything from the background… I don’t see it happening… Any ideas on how to make powershell show up when running?? Is it because I have the "Run whether user is logged on or not" option marked? Or is it because the Actions tab "start a program" looks like this 

    Action: Start a program

    Program/script: %SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe

    Add arguments (optional): C:\TI\myScript.PS1

    Friday, November 10, 2017 11:08 AM

All replies

  • Hi, Your are correct - Is it because I have the "Run whether user is logged on or not" option marked?

    GD

    • Proposed as answer by Gudakesh (GD) Friday, November 10, 2017 1:41 PM
    Friday, November 10, 2017 12:02 PM
  • Scheduled tasks do not display a UI when run that way.  Select to  run only when user is logged in.


    \_(ツ)_/


    • Edited by jrv Friday, November 10, 2017 1:32 PM
    Friday, November 10, 2017 1:29 PM
  • try -noexit with powershell

    Thanks & Regards Ramandeep Singh

    Saturday, November 11, 2017 6:11 AM