none
Configure Windows Firewall using GPO: Logging file path cannot be set

    Question

  • Hi

    We are having a strange issue with Windows Firewall setting.

    The logging file path cannot be set. After I have enabled the Logging setting and click on OK to save the setting. When I open up logging settings again, the logging file path is set back to "Not Configured". The check box is ticked again. See below screenshot.

    I have ensured the Firewall folder has the correct permission (Modify permission) for the firewall service but I am still seeing this strange behavior.

    Any idea what is causing this issue?


    • Edited by Beau Beau Tuesday, December 8, 2015 4:15 AM
    Tuesday, December 8, 2015 4:14 AM

Answers

  • Hi,

    Thanks for your question.

    I understand that the "Not configured" box won't stay unchecked after hitting OK. However, if you try to run “Gpresult /h C:\result.html", you should see that the firewall logging is actually enabled.

    I have tested this on my local lab, exactly the same behavior. So please go ahead and check whether the change is applied in the environment or not.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 9, 2015 9:18 AM
    Moderator

All replies

  • Hi,

    Thanks for your question.

    I understand that the "Not configured" box won't stay unchecked after hitting OK. However, if you try to run “Gpresult /h C:\result.html", you should see that the firewall logging is actually enabled.

    I have tested this on my local lab, exactly the same behavior. So please go ahead and check whether the change is applied in the environment or not.


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, December 9, 2015 9:18 AM
    Moderator
  • Hi Wendy

    Doesn't look like that's the case. The change is not applied.

    I unticked the box, use the default path and log file name, click on ok to close the window. When I open up the window again, the box is ticked. I am not sure what's causing this issue.

    Regards

    Vickie

    Thursday, December 10, 2015 2:42 AM
  • I unticked the box, use the default path and log file name, click on ok to close the window. When I open up the window again, the box is ticked.

    Hi Vickie,

    I got the same behavior on my end, the "Not configured" box won't stay unchecked after hitting OK. However, when I check in the path that I specified on the dialog, I see the log file created out there.

    It seems the change is applied anyway, though the "Not configured" box is ticked again when you go back and check. So could you please check the same, see if the log file is created in the default path?



    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, December 14, 2015 8:56 AM
    Moderator