locked
Remove Database From DAG 2010 RRS feed

  • Question

  • Need some guidance on removing a database from a 2-node DAG configuration.   I have one database (mailstore) that i moved all mailboxes to a new database and used the EMC to remove the database.  The database no longer exists on the passive Exchange server but still shows up in the EMC on the Active Exchange server.  The database is currently dismounted.  The message I am recieving is this:

    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    The mailbox database 'MBX2' cannot be deleted.

    MBX2
    Failed
    Error:
    This mailbox database contains one or more mailboxes, mailbox plans, archive mailboxes, or arbitration mailboxes. To get a list of all mailboxes in this database, run the command Get-Mailbox -Database <Database ID>. To get a list of all mailbox plans in this database, run the command Get-MailboxPlan. To get a list of archive mailboxes in this database, run the command Get-Mailbox -Database <Database ID> -Archive. To get a list of all arbitration mailboxes in this database, run the command Get-Mailbox -Database <Database ID> -Arbitration. To disable a non-arbitration mailbox so that you can delete the mailbox database, run the command Disable-Mailbox <Mailbox ID>. To disable an archive mailbox so you can delete the mailbox database, run the command Disable-Mailbox <Mailbox ID> -Archive. Arbitration mailboxes should be moved to another server; to do this, run the command New-MoveRequest <parameters>. If this is the last server in the organization, run the command Disable-Mailbox <Mailbox ID> -Arbitration -DisableLastArbitrationMailboxAllowed to disable the arbitration mailbox. Mailbox plans should be moved to another server; to do this, run the command Set-MailboxPlan <MailboxPlan ID> -Database <Database ID>.

     

    --------------------------------------------------------
    OK
    --------------------------------------------------------

    I have run all of the commands suggested in the above mentioned message to no avail.  I am not adverse to bringing in MS to assist but was wondering if anyone on the forum has come across this issue before.  Some additional information:  We have 4 other mailstores that are functioning just fine and no errors are showing up in the cluster. 

    Tuesday, March 5, 2013 11:32 AM

Answers

  • Are you sure that the Arbitration Mailboxes is not in that database you want delete?

    Check with:

    get-mailbox -Arbitration | ft Name,database

    ..and if you need to move them, just run:

    get-mailbox -Arbitration | New-MoveRequest -TargetDatabase DatabaseXX

    UPDATE: Also run Get-MailboxStatistics -Database MBX2 and see what you find.

    Martina Miskovic


    • Edited by Martina_Miskovic Tuesday, March 5, 2013 11:44 AM
    • Proposed as answer by Terence Yu Wednesday, March 6, 2013 5:55 AM
    • Marked as answer by Terence Yu Tuesday, March 12, 2013 5:34 AM
    Tuesday, March 5, 2013 11:42 AM