none
Power Query Fetching data from CRM online error: Error Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host RRS feed

  • Question

  • I am trying to pull data from Dynamics CRM online using OData Feed of Power Query, but after signing in throws error as:

    Error Message:

    Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.

    Stack Trace:

    System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
       at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
       at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
       --- End of inner exception stack trace ---

    Is this issue from CRM online side, or Power Query or local machine on which Power Query is used? ANY IDEAS ?

    Thanks,

    Sagar K 

    (Blog: http://datamazik.blogspot.in/)


    Thursday, August 21, 2014 10:27 AM

Answers

  • Its possible this was an issue on the server that was causing this. If it was a firewall blocking the request then that should be repeatedly occurring and would repro everytime. But since you are able to query now that seems to not be the issue. Over the past month how many times does this happen? How long have you been running this query? Is there a way to see how available the CRM service was over that time there was an outage for you?

    Thanks,

    Chris Robinson


    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by SagarK.CF Tuesday, September 2, 2014 4:03 AM
    Thursday, August 28, 2014 5:52 PM

All replies

  • Hey Sagar,

    Is this an intermittent issue or does it happen every time?

    Thanks,

    Chris Robinson - Power Query Developer


    This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, August 27, 2014 9:02 PM
  • It was there for day or two, today when I checked it worked fine.

    Thanks,

    Sagar K

    Thursday, August 28, 2014 3:30 AM
  • Its possible this was an issue on the server that was causing this. If it was a firewall blocking the request then that should be repeatedly occurring and would repro everytime. But since you are able to query now that seems to not be the issue. Over the past month how many times does this happen? How long have you been running this query? Is there a way to see how available the CRM service was over that time there was an outage for you?

    Thanks,

    Chris Robinson


    This posting is provided "AS IS" with no warranties, and confers no rights.

    • Marked as answer by SagarK.CF Tuesday, September 2, 2014 4:03 AM
    Thursday, August 28, 2014 5:52 PM
  • I tried to investigate and seems this issues is connectivity issue from CRM side.

    Thanks,

    Sagar K 

    (Blog: http://datamazik.blogspot.in/)

    Tuesday, September 2, 2014 4:03 AM
  • Hi Sagar,

    My customer is  facing same issues.

    Is there resolution ? Or way to resolve or escalate ?

    BR,

    Achin

    Friday, July 8, 2016 12:28 PM