locked
not open excel 2010 file template in moss 2007 document library RRS feed

  • Question

  • I have installed microsoft sharepoint portal server 2007.

    In which I specify in one document library excel template. I upload template of excel 2010

    if OFFICE 2007 is installed in my system or in other persons . then it will open a template in excel document . but I update office and now office 2010 installed in my system. now when i click a new button and open a excel document . it is not opening and open only a text file with garbage. and show a dialog box with message.

     

    "The document could not be created.

    The required application may not be installed properly, or the template for this document library cannot be opened."

    How can I open a template in office 2010 with MOSS 2007 document library.

     

     


    Basim Alvi
    • Edited by Mike Walsh FIN Thursday, December 9, 2010 5:44 PM NEVER ask for answers as soon as possible. WAIT your turn. Ring MS Customer Support Services if you are in a hurry and PAY for support
    Monday, November 1, 2010 7:55 AM

Answers

All replies

  • yes, it is possible to open Excel 2010 files from MOSS 2007, however some new features are not available here (check this thread for example: Sharepoint 2007 and Excel 2010 features ). Check "12\TEMPLATE\XML\docicon.xml" file - it should contain mapping for "xlsx" file extension. Also check that Office 2010 was installed successfully (i.e. check that you are able to open xlsx file from hard drive, not from Sharepoint doclib)


    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Graphs visualization in Sharepoint - http://spgraphviz.codeplex.com
    • Marked as answer by Peng Lei Thursday, November 11, 2010 2:44 AM
    Monday, November 1, 2010 1:04 PM
  • Click on edit tempalte link from document library > adv. settings which should open the tempalte itself for editing and then save back without any changes.

    If this does not work then try downloading the tempalte localy modify using excel 2010 and update the template in doc lib.

     

    • Marked as answer by Peng Lei Thursday, November 11, 2010 2:44 AM
    • Edited by Mike Walsh FIN Thursday, December 9, 2010 5:45 PM Sig removed. Do NOT ask people to mark your posts.
    • Unmarked as answer by Mike Walsh FIN Thursday, December 9, 2010 5:45 PM
    Tuesday, November 2, 2010 5:46 AM
  • Did you find a solution to this?  We are seeing the exact same behavior in our configuration.  The two "Answers" below do not address the problem.
    Thursday, December 9, 2010 4:04 PM
  • I'm having the same issue, and when I open the content type from advanced settings, I get a different error, that the location cannot be found. Tried using custom content type, etc, same error. When using a parent, it also notes it as a word document.


    Douglas

    Wednesday, March 7, 2012 5:36 PM