locked
Unable to start Office SharePoint Server Search service. It is stuck in "Starting" RRS feed

  • Question

  •  

    I am unable to set up medium farm

    We have 3 servers in farm

    (1) Front end server (CA, Excel Service, Windows SharePoint Service Web application service "Started”)

    (2) Index server (Office SharePoint Server Search service “starting", Windows SharePoint Services Search “Starting”)

    (3) SQL Server

    Above farm setup was running fine but when we move our serves to another location we use image of front end server and sql server but we rebuilt the Index server so I install MOSS enterprise edition on index server using admin account and run the SharePoint Technology wizard successfully. After installing MOSS on index server when I go to Operation-> services on server and start the "Office SharePoint server search service" it is showing starting. I check services it is showing disable so set manual and start the service but action still showing "Starting". Because of this I am not able to configure SSP for search; when I opened Shared Services Administration and configure SSP I am getting "No indexer" error. I didn't find any error in event viewer but from ULS log I get below error. 

     CheckForUpgradingAndReturnStatus synchronize logic finds the SearchContext.SearchApplication.IndexServiceInstance is null for ssp c7b4ceb8-2231-43a5-9ce7-d09f038052c3, the application registry will get removed. SearchDataAccessServiceInstance.Synchronize(). searchserviceinstance status is bad. Object statuses: ssp status Online sspdb Online searchdb Online ssp search service instance -1 local search service instance Disabled

    I spent 3-4 days but no luck...any help really appreciate.


    Sharepoint Analyst/Developer Pritesh Dhameliya

    Tuesday, February 28, 2012 7:29 PM

Answers

  • Hi PriteshPatel357,

    First, try the following steps to solve the “No indexer” error:

    1
    Open SharePoint Products and Technologies Configuration Wizard, confirm all Windows with YES, OK and FINISH, settings stay default
    2
    Central Administration | Operations | Topology and Services |Services on Server, "Windows SharePoint Services Search" Click on Start, configure the accounts and settings appropriately
    3
    Central Administration | Applications Management | SharePoint Web Application Management | Content Databases, click on "WSS_Content", in "Select Windows SharePoint Services search server" click on the drop down field and select your server
    4
    Finally I restarted the services IIS and Windows SharePoint Services Search

    Second,
    Manually stop the Office SharePoint Server Search service:
    (On the drive on which SharePoint Products and Technologies is installed, open a command prompt window and change to the following folder:%COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\12\Bin)
    Type the following command, and then press ENTER:
    stsadm –o osearch –action stop

    Third, Manually start the Office SharePoint Server Search service:
    stsadm –o osearch –action start

    Thanks,
    Lhan Han
    Friday, March 2, 2012 6:41 AM
    Moderator
  • Thank you Han for reply.

    You are right on above steps but I have done one more step to configure through cmd

    stsadm –o osearch –action start -role Index

    http://jerryyasir.wordpress.com/2007/09/12/microsoft-office-sharepoint-server-search-service-stuck/

    After one miniute of wait I was able to see status from starting to Started.

    Thanks,

    Pritesh


    Sharepoint Analyst/Developer Pritesh Dhameliya


    Friday, March 2, 2012 2:50 PM

All replies

  • Hi PriteshPatel357,

    First, try the following steps to solve the “No indexer” error:

    1
    Open SharePoint Products and Technologies Configuration Wizard, confirm all Windows with YES, OK and FINISH, settings stay default
    2
    Central Administration | Operations | Topology and Services |Services on Server, "Windows SharePoint Services Search" Click on Start, configure the accounts and settings appropriately
    3
    Central Administration | Applications Management | SharePoint Web Application Management | Content Databases, click on "WSS_Content", in "Select Windows SharePoint Services search server" click on the drop down field and select your server
    4
    Finally I restarted the services IIS and Windows SharePoint Services Search

    Second,
    Manually stop the Office SharePoint Server Search service:
    (On the drive on which SharePoint Products and Technologies is installed, open a command prompt window and change to the following folder:%COMMONPROGRAMFILES%\Microsoft shared\Web server extensions\12\Bin)
    Type the following command, and then press ENTER:
    stsadm –o osearch –action stop

    Third, Manually start the Office SharePoint Server Search service:
    stsadm –o osearch –action start

    Thanks,
    Lhan Han
    Friday, March 2, 2012 6:41 AM
    Moderator
  • Thank you Han for reply.

    You are right on above steps but I have done one more step to configure through cmd

    stsadm –o osearch –action start -role Index

    http://jerryyasir.wordpress.com/2007/09/12/microsoft-office-sharepoint-server-search-service-stuck/

    After one miniute of wait I was able to see status from starting to Started.

    Thanks,

    Pritesh


    Sharepoint Analyst/Developer Pritesh Dhameliya


    Friday, March 2, 2012 2:50 PM