none
Windows 10 x64 deployment through WDS fails to import install image RRS feed

  • Question

  • Hi all

    I hope someone can help with this please.

    I've downloaded the RTM ISO release of Windows 10 (tried both home and pro and x32 and x64) through the official media creation tool.  I've extracted both the boot.wim and install.wim files out of it.  My WDS server is 2012R2 and I have added the Win 10 boot image ok, but when I try to add the install image it fails with "The specified image file is either invalid or corrupt"

    I've downloaded it again and its the same result.  I've used the same ISO to create a bootable USB and have successfully upgraded systems with it.  I have previously been testing WDS with Insider build 10166 and it worked ok.

    The only thing that is different this time is that it's the full RTM release.

    Does anyone else have the same problem, or are they still having too much fun doing in place upgrades?

    Thank you


    • Edited by whatNOWagain Friday, July 31, 2015 2:39 AM added info about x32 version
    Friday, July 31, 2015 1:21 AM

All replies

  • I have the same problem. Install.wim from Windows 10 Pro 64 ISO created with MediaCreationToolx64 cannot add to Windows 2012 WDS server. The same message. ISO is OK, because I used it for installation and worked. I tried create ISO again with MediaCreationToolx64. The same situation.

    I wanted download "official" ISO from VLSC and use Install.wim from it, but there is only Windows 10 Pro 64 KN version.

    • Edited by Jimjim75 Friday, July 31, 2015 11:05 PM
    Friday, July 31, 2015 10:47 PM
  • NOW is on VLSC server Windows 10 Pro 64 ISO. I will try to use install.wim from it.
    Friday, July 31, 2015 11:23 PM
  • Hi, Jim,

    How about your problem now? Would please let us know your current situation?


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 3, 2015 9:07 AM
    Moderator
  • I've tried the VLSC ISO and it has imported into the WDS server.  I'm not yet sure what impact thats going to have on our fleet of OEM licensed machines, but will update the post when I have a better idea.
    Tuesday, August 4, 2015 9:01 PM
  • As a follow up I've run into the same issue trying to import the RTM images into MDT Deployment Workbench.  VLSC is ok, but RTM from the media creation tool doesn't work.

    Has anyone found a way to get the non VLSC images to work with these tools?

    Wednesday, August 5, 2015 3:19 AM
  • Add me to the list.  Created both 32 and 64 bit images using the Media Creation Tool (Pro and Home), and WDS says "The specified image file is either invalid or corrupt." and refuses to import them.  I have to wonder if this is Microsoft's way of telling us we can't use WDS for anything but enterprise or volume licensed products.

    Friday, August 21, 2015 3:34 PM
  • The wims in the ISOs created with MediaCreationToolx64 are compressed with the compression type: Recovery

    WDS and MDT cannot import images with this type of compression.

    Try this to get a wim that can be imported in WDS and MDT:

    Download and install the Windows ADK for Windows 10:

    https://msdn.microsoft.com/en-us/windows/hardware/dn913721.aspx

    (Scroll to the bottom of the page to the section, "Customize, assess, and deploy Windows on your hardware.")

    Run as administrator the DISM version 10.0.10240.16384 to export the image included in the wim to a new wim changing the compression type:

    C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment
    Tools> dism.exe /Export-Image /SourceImageFile:E:\sources\install.wim /SourceInde
    x:1 /DestinationImageFile:C:\ExportedWim\install.wim /Compress:max

    Import in WDS the new wim.

    Thursday, August 27, 2015 6:25 PM
  • This worked for me.

    Windows 2012 R2 Deployment Services. Windows 10 Pro RTM ISO. I was able to extract/expand the install.wim and then import it into WDS with no problem.

    Thanks, Daniele!

    Friday, August 28, 2015 3:59 PM
  • Thank you!!

    I've been all over the web trying to figure this out. It was killing me that the boot.wim would work just fine, but the install.wim was being a pain.. As soon as I tried this: No issues, deployment worked fine!

    Thank you again!!!

    Thursday, January 7, 2016 7:47 PM
  • Hello, It seems you (@Daniele Ghirardelli) are the one that coud explain met to fix this. I dont excatly understand your solution. Coud you pls explain me this a bit more? thx in advance greetings, jasper
    Friday, January 8, 2016 12:15 PM
  • Another way to accomplish this is to just install windows 10 on a virtual machine and then sysprep it and capture it with wds. This way you could get your wim file with all current updates on it as well, this will save time and bandwidth on your network.  I never put a factory wim file on my wds server.
    Thursday, February 4, 2016 7:32 PM
  • I got the following error message after I deployed the Windows 10.10240 using WDS and MDT :

    Can anyone please ashare what's the solution to fix that ?


    /* Server Support Specialist */

    Friday, February 5, 2016 2:17 AM
  • get the iso here http://www.microsoft.com/en-us/software-download/techbench

    in WDS it says it is the Technical Preview, but it is actually the release given out as RTM. It's the legit version. I just did it with install.wim in WDS.

    Saturday, February 6, 2016 6:51 PM
  • I got the following error message after I deployed the Windows 10.10240 using WDS and MDT :

    Can anyone please ashare what's the solution to fix that ?


    /* Server Support Specialist */


    did you ever find a solution for this?  I have the same corruption after capturing / deploying through WDS.
    Thursday, August 25, 2016 6:31 PM
  • I tried this method using the new Creators Update 1703 iso that was downloaded using the MediaCreationTool. 

    I downloaded the .iso with the .wim file already included in there without any conversion from .esd from a safari browser.

    After I downloaded the correct iso with the .wim files for boot/install included, I ran the DISM instructions from Daniele above and afterwards, I was able to deploy windows 10 1703 using WDS!

    I was also able to capture/deploy properly from WDS. The only catch was to capture, I would have to use the server2012 capture image and it would be able to capture the windows 10 image using that. (might be different for different people)

    Thanks for the dism tip Daniele! 

    Monday, May 22, 2017 3:26 PM