none
Creating Production Checkpoint fails

    Question

  • Hi Forum!

    Trying to take a production checkpoint with Server 2016 Hyper-V running a VM with Server 2008 R2 fails after a few % with the message "Checkpoint operation failed. <vmname> could not initiate a checkpoint operation.
    The eventlog in Hyper-V shows an event 3280 from Hyper-V-Worker right before the failure, but it cannot be displayed properly:
    “The description for Event ID 3280 from source Microsoft-Windows-Hyper-V-Worker cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    <vmname>
    FD6E050D-2B0C-4F2D-BD3F-0988A92D009F
    %%2147754996
    0x800423F4

    The locale specific resource for the desired message is not present”

    I looked at the eventlog of the VM and I can see 3 errors here:
    • ESENT 489, saying that lsass fails during read access to file "\\?\Volume{771111ed-7618-11df-b2ed-806e6f6e6963}\Windows\NTDS\ntds.dit"
    • VSS 8229, which tells about a VSS writer failure with the same code 0x800423f4 like above
    • vmicvss 2, error with DSS writer NTDS with state 11 and again code 0x800423f4

    But VSS services inside the VM are working normal. A Windows Server Backup can be run, and I can create and delete snapshot of all volumes via diskshadow.exe without problems.

    I need a hint in which direction I can proceed with further Tests ans diagnostics.

    KR,

    Matschek

    Thursday, March 02, 2017 10:08 AM

All replies

  • How did you create the VM?  P2V?  Did you install/re-install integration services?

    . : | : . : | : . tim

    • Proposed as answer by Leo HanModerator Thursday, March 16, 2017 7:08 AM
    • Unproposed as answer by Matschek Friday, March 17, 2017 5:10 PM
    Thursday, March 02, 2017 2:13 PM

  • Hi,
    Are there any updates on the issue?
    You could mark the reply as answer if it is helpful.
    Best Regards,
    Leo

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 16, 2017 7:08 AM
    Moderator
  • Yes, the VM is a physical machine which I converted last autumn.

    I don't know a current possibility to manually reinstall the Integration Services in a VM running under Hyper-V 2016. MS changed the old "insert ISO" method and manages the IS via Windows Update.

    The problem seems so be more complicated than I thought. I did some restarts first, but it did not help. I tried to restart several involved services(like COM+) and suddenly it workedagain. Then for whatever reason, the VSS inside the VM stopped to work, the Windows Server Backup which I am using to export the Systemstate to a separate drive errored.
    A VM reboot later it worked again, but the Hyper-V is no more able to create a snapshot.
    It's really confusing right now...

    Friday, March 17, 2017 5:10 PM
  • P2V is notorious for leaving 'artifacts' from the conversion process.  Sometimes it works.  Sometimes it doesn't.  That is why the recommendation is to build the VM from scratch whenever possible.  Otherwise you live with issues that may take a long conversation with support to figure out.

    tim

    Friday, March 17, 2017 11:11 PM