none
Project Professional 2013 bug RRS feed

  • Question

  • Hi guys,

    Is there any chance that it will be possible to add in multiple tasks by right click on a few selected rows in a Project file and choosing Insert Task? This was something I used a lot in previous versions.

    Just now when I select the tasks and right click, it unselects the previously created tasks. So for the time being it's 1 by 1.

    Thanks!

    • Moved by Max Meng Wednesday, December 5, 2012 8:57 AM (From:Office 2013 and Office 365 ProPlus - IT Pro General Discussions)
    Tuesday, December 4, 2012 5:47 PM

Answers

  • Please check your installed updates in control panel.  I don't believe you have SP-1 for Project 2013 installed.  From:

    http://support.microsoft.com/kb/2817433/en-us

    In order to determine whether SP1 is already installed, you can look for the program version in the list of installed programs in the Programs and Features Control Panel item. If SP1 is installed, the version will be 15.0.4569.1506 or higher. Additionally, if you have installed the SP1 update for a Windows Installer (MSI) product, SP1 will be listed in Installed Updates in that same Control Panel item.

    Install SP-1 and test again.

    Tuesday, April 22, 2014 2:26 PM
    Moderator

All replies

  • Hi, Johhny.  As far as I can tell my version of Project Pro 2013 is behaving normally. I highlight four tasks and use any of the typical methods for inserting new tasks (right click&insert tasks, Task->Insert from the Task tab on the ribbon, hit the keyboard insert key, etc.) and I get 4 new tasks.

    The only way I can replicate what you're describing is by doing two group inserts in succession - and then the second set frequently defaults to inserting just a single task. I guess it's arguable whether this is a bug or a feature but the work around of using the insert key is a pretty good work-around

    Graham

    Wednesday, December 5, 2012 3:38 PM
  • Johnny Mango --
     
    Using the final RTM release of Microsoft Project 2013, I cannot duplicate the bug you are reporting.  I can select a block of tasks, right-click in the selected block, and choose Insert Task item on the shortcut menu.  And then the software inserts new tasks for the number of rows I have selected.  Are you still using the public beta of the software by chance?  If so, I think you will see the problem is resolved in the RTM release.  Let us know and we will try to help.
     

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Friday, December 7, 2012 2:34 AM
    Moderator
  • Hi,

    UPDATE:

    Figured out that this issue happened because I have view critical path clicked.

    >>>

    I have MSDN download of RTM Project 2013. Running on Win 8 x64.

    0. Need to have View > Highlight > Critical Path

    1. Select few cells in a column or few consecutive rows

    2. Right click

    3. Menu displays but all cells are deselected except for the one where your mouse was hovering

    Issue only happens with these steps

    This has made my installation useless and I will have to go back to previous project version.


    • Edited by ICryWhenITry Wednesday, December 19, 2012 10:44 AM
    Wednesday, December 19, 2012 10:14 AM
  • Hi,

    Sorry but even doing exactly as you tell us, the insert function works as before. Is this the final release version?

    Greetings,

    Wednesday, December 19, 2012 1:24 PM
    Moderator
  • I too get the same behavior in 2013 as in 2010. The insert works filter on or off.

    Rod Gill

    The one and only Project VBA Book

    Rod Gill Project Management

    Wednesday, December 19, 2012 11:51 PM
    Moderator
  • Hi, thanks for your replies and interest.

    I have Project Professional 2013 15.0.4420.1017.

    The curious thing is I opened a previous version of a Project file and it worked as expected, but in a new Project 2010 file it doesn't.

    To clarify I select my tasks by selecting the lines in the task number column, then when I have, say, 4 selected to insert 4 new tasks, I right click my selection and the selection defaults to one line. The new task button in the ribbon works fine to insert multiple tasks.

    Thanks again.


    • Edited by johnny mango Thursday, January 31, 2013 5:28 PM typo
    Thursday, January 31, 2013 5:27 PM
  • Johnny --
     
    Thanks for the additional explanation.  I also have Project Professional 2013, not connected to Project Server.  However, I still cannot duplicate what you are experiencing.
     
    On the other hand, I do notice something a bit odd.  The build number for my copy of Microsoft Project 2013 is 15.0.4433.1506, which appears to be a later build than yours.  By chance, did you have the private beta or public beta of Project 2013 installed on your computer before you installed the RTM version?  On my laptop, I never installed the private or public beta, so my RTM install is a fresh one.
     
    Let us know when you get a chance.  Hope this helps.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Thursday, January 31, 2013 9:25 PM
    Moderator
  • Hi Folks!

    I have Project Professional 2013 Build 15.0.4420.1017.
    I'm experiencing the same problems that Johnny.
    I'll have to reinstall the 2010 version until the problem is resolved, because it is impossible to work.

    Regards

    José Nunes

    Saturday, February 16, 2013 5:42 PM
  • Hi,

    Johnny reckons his problem was solved as soon as he chose No Filter.

    Moreover, do you sort by ID? Is grouping set to No Group?

    All of this must be satisfied before you can do what Johnny tried.

    Greetings,

    Saturday, February 16, 2013 10:01 PM
    Moderator
  • Alright guys,

    Here's the rub:

    Those of you who are able to select a couple of consecutive task lines using the mouse, and then right click without having the selection disappear just haven't examined it far enough.  I am using 2013 pro as well, and when I select certain project tasks (5 or 6) in a given area I can right click with no problem; the tasks remain high-lighted.  But when I move further down to another area and try the same thing again the selection is lost.  Then, at times I can go back to the areas where the select function used to work, and then it doesn't.

    I think this really is a bug in the software; I can't find any other information on it online so perhaps it so new that enough people haven't reported it to Microsoft yet.

    Anyway, it's really, really annoying!

    Friday, March 8, 2013 6:21 AM
  • Keith --
     
    For whatever it is worth, I am now seeing this bug.  However, the problem is that the bug is intermittent.  The bug comes and goes.  I cannot determine under what conditions the bug occurs or does not occur.  For example, in one file I can select a block of tasks and right-click, and the entire block stays selected.  In another file, I select a block of tasks and right-click, and the software selects ONLY the task on which I right-click.  Can anyone else see the same results as I can?  If so, can you determine under what conditions we see the bug and do not see the bug?  I would like to report this as a bug, but I need to be able to reproduce the conditions that makes the bug occur.  Please let me know what you find.  Thanks!
     

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Sunday, March 10, 2013 2:42 PM
    Moderator
  • I am also seeing the bug intermittently, but pretty consistently.  For whatever it's worth, a perfectly good workaround to me is to select multiple rows and hit the "Insert" key instead of trying to do the right-click "insert tasks" command.
    Saturday, May 25, 2013 9:45 PM
  • Bruce --
     
    Thanks for the additional confirmation.  Yup, I use the same workaround as you, but it is annoying we have to do that.  Hope this helps.

    Dale A. Howard [MVP]

    Sunday, May 26, 2013 12:13 AM
    Moderator
  • Chiming in. Yes, I can repro the bug as well.  No filters or groups or sorting applied.  Seems that first selection works as expected, others deselect.  It appears as though selecting tasks closer to the top of the file work more consistently that tasks lower in the file.
    Monday, May 27, 2013 4:41 PM
    Moderator
  • Hi there. I can confirm that I am able to reproduce this bug as well. Nothing in terms of filters or groups sorted and in trying to select 17 lines to then insert new tasks to fill in, by right clicking on the left hand side of the screen with the row numbers, I am left with one row being selected.

    This seems to be consistent across the whole file I'm working on (the selection started at row 41) - quite how you can insert multiple blank tasks at the moment with the right click option not working as there is no "insert" option in the ribbon that I can see.

    The same thing happens when you use the "right click" key on the keyboard as well.

    Wednesday, May 29, 2013 2:59 PM
  • Fellow community members --

    I wanted to let you know that the Microsoft program manager who works with our MVP community has reported that she can finally reproduce this bug.  It is now slated to be fixed.  When I do not know, but it will be fixed, perhaps sooner than later.  Hope this helps.


    Dale A. Howard [MVP]

    Thursday, May 30, 2013 5:14 PM
    Moderator
  • Hello,

    Is there any news regarding this issue?

    Thanks in advance.

    Monday, June 24, 2013 6:27 PM
  • Our contact within Microsoft reported that they have reproduced the bug, and indicated they will fix it in an upcoming Cumulative Update.  They did not say exactly when the fix would be released.  Hope this helps.

    Dale A. Howard [MVP]

    Monday, June 24, 2013 10:58 PM
    Moderator
  • Here it is, October and I still deal with this issue daily.

    Is it going to be fixed?

    Monday, October 14, 2013 5:23 PM
  • Mrfitz98 --

    Our contacts within Microsoft say it will be fixed, but they never tell us when it will be fixed.  That is about the best we can tell you.  Hope this helps.


    Dale A. Howard [MVP]

    Monday, October 14, 2013 8:04 PM
    Moderator
  • Dale,

    (Enjoyed your MSP 2013 book, btw--very thorough and instructive.)

    I have 15.0.4535.1507 and experience the same thing.  Very frustrating when "muscle memory" has you trying to do things the way you always have.

    I have noticed two other actions that I used to do in MSP2010 that I cannot now.  (If this hijacks the thread and each should have its own post, I apologize.)

    First, in Task Usage, I am used to right-clicking and inserting a resource assignment from the resulting context menu.  That option is now grayed-out, and I must use the Resource Assignment dialog box to accomplish the same thing.

    Second, in the past if I wanted to move a task around in the plan, I would simply unlink it, highlight the whole row(s), left-drag it to the new location, drop it, and relink it.  MSP2013 won't let me do that.  I have not thoroughly tested it, but it seems to let me move it that way if I move it somewhere on the current screen.  But, if I drag it somewhere else away from the current screen, it does nothing--the task(s) stay right where they were.

    I switched to 2013 from 2010 thinking the additional reporting features would be worth it. So far, I have been rather nonplussed.

    Thursday, October 17, 2013 5:13 PM
  • Project Mgr --

    Because of the bug we have discussed in this thread, our book editor for the Ultimate Study Guide: Foundations book had to rewrite many of the Hands On Exercises to work around the bug.  That was surely a frustrating exercise for him to do.

    Regarding the other two items you mention, I am not sure I can duplicate the first item, but I can definitely duplicate the second item.  When I apply the Task Usage view and right-click on a task, what item do you select on the shortcut menu in Project 2010?  And which item is grayed out on the shortcut menu in Project 2013.

    Regarding moving tasks using drag and drop, like you, I am not able to drag and drop a task more than one screen-full.  If I drag it to the current screen-full of tasks, the task moves.  If I attempt to drag it beyond the current screen-full of tasks, the task does not move.

    Please give me more information about the first item.  After you do this, and I can confirm what you see, I will report these two items as bugs.  Let me know.  Thanks!


    Dale A. Howard [MVP]

    Thursday, October 17, 2013 10:09 PM
    Moderator
  • Scenario:  I am in Task Usage view and right-click a resource name listed under a task.  In 2010 I could simply select Insert Assignment to assign an additional resource to the task.  In 2013 that option is grayed out (Delete Assignment is available, but not Insert Assignment).

    Instead of being able to select it from the right-click popup menu as I could in 2010, I now have to go to Resource tab, Assign Resources, scroll through list, select resource, click Assign, close box...  It's a workaround (the insert key on the keyboard might work, too--haven't tried), but takes quite a few more clicks to accomplish than simply selecting Insert Assignment from the popup and typing the first few letters of the resource's name.

    Regards

    Saturday, October 19, 2013 3:48 AM
  • Hi Dale,

    Have you had a chance to try to replicate the bug I reported with the additional information I provided?

    Also, here is a third issue.  Seems to be related to the issue that began this thread.  Inability to add multiple tasks (contiguous or non-contiguous) to timeline from context (right-click) menu.

    Scenario:  In MSP 2010, I could--in the Gantt chart view--

           ctrl-left-click (select) contiguous or non-contiguous tasks,

           right-click to open the context menu,

           select Add to Timeline.

    In MSP 2013, when I right-click the selection, the selection truncates to whichever task has the focus of the mouse pointer.  I now have to use the Existing Tasks button on the Format tab (Timeline Tools) to perform the action.

    Regards

    Friday, October 25, 2013 3:35 PM
  • I can confirm the "Insert Assignment" command is not available through the shortcut menu in the Task Usage view as you describe. However, I was able to select "Assign Resources" from the shortcut menu with the task selected in the Task Usage view.

    Yes, the problem with multiple selected tasks and the shortcut menu still exists.  The multi-selection and right click only appears to work for the first multi-selection.


    Friday, October 25, 2013 5:26 PM
    Moderator
  • How about now? Has there been a fix generated?
    Thursday, November 28, 2013 5:51 PM
  • I believe SP-1 for Project 2013 is in beta testing.  I do not know whether this particular issue is on the fix list.
    Saturday, November 30, 2013 2:54 PM
    Moderator
  • Well, here it is, mid-February and this is still broken. MSRP for this junk is $1160. I cannot believe that in a year Microsoft has decided that people who use project do not use the right mouse button.
    Thursday, February 13, 2014 1:50 PM
  • It functions as expected in Project Professional for Office 365 and also on the latest updated version of Project 2013 MSI installation.

    Thursday, February 13, 2014 8:23 PM
    Moderator
  • Yup same problem still as well.  

    Mine was a direct download from the MS repository (am assuming as its company funded and downloaded).  Version is 15.0.4551.1007 and still happening.

    So looks like its pressing insert to me!

    Tuesday, April 22, 2014 2:04 PM
  • Please check your installed updates in control panel.  I don't believe you have SP-1 for Project 2013 installed.  From:

    http://support.microsoft.com/kb/2817433/en-us

    In order to determine whether SP1 is already installed, you can look for the program version in the list of installed programs in the Programs and Features Control Panel item. If SP1 is installed, the version will be 15.0.4569.1506 or higher. Additionally, if you have installed the SP1 update for a Windows Installer (MSI) product, SP1 will be listed in Installed Updates in that same Control Panel item.

    Install SP-1 and test again.

    Tuesday, April 22, 2014 2:26 PM
    Moderator
  • Hello,

    I have installed SP1 and the original issue (right click on selection) seems to be fixed. Thanks for the tip Julie.

    Kind regards.

    Friday, May 23, 2014 3:07 PM