locked
Autologin to Deployment Wizard not working RRS feed

  • Question

  • Hey can someone tell me what is wrong here.  I am trying to make my MDT Deployment Wizard autologin, however no matter what I try it Keeps prompting for User, Password and Domain.  I have modified the Bootstrap.ini with USERID=user, UserPassword=password and UserDomain=domain, yet it still comes up blank every time i boot up.  I have updated the share and boot media. 
    Friday, May 19, 2017 3:00 PM

All replies

  • The username/password in bootstrap is only used for connecting to the deployment share initially, but doesn't affect anything beyond that.

    That said if you use LocationServer.xml to define multiple deployment shares in the dropdown list, it will ignore your username settings in bootstrap.ini


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, May 19, 2017 4:24 PM
  • Hi,

    UserID; UserPassword and UserDomain won't be of any help to login to a PC, they are used to log to your deploymentshare.If you want to autologin, you'd better use AdminPassword property on the customSettings.ini file.

    Thursday, June 8, 2017 7:36 PM
  • It's been a while, but pretty sure this problem was/is related to the current bug in MDT where the autologin is wiped from the registry. The simple fix so far is to write and run a powershell script in the task sequence to set autologin.

    $RegPath = "HKLM:\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon"
    $AdminPass = 'Pa$$W0rD'
    Set-ItemProperty $RegPath "AutoAdminLogon" -Value "1" -type String
    Set-ItemProperty $RegPath "AutoLogonCount" -Value "999" -type String
    Set-ItemProperty $RegPath "DefaultPassword" -Value $AdminPass -type String
    Set-ItemProperty $RegPath "DefaultUsername" -Value "Administrator" -type String
    Set-ItemProperty $RegPath "DefaultDomainName" -Value "." -type String
    

    It'll get cleared like normal when the TS finishes.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, June 8, 2017 7:44 PM