locked
Inquiry for {Delayed Write Failed} Windows was unable to save all the data RRS feed

  • Question

  • Hi,

    Our Windows Server 2012 R2 (Web Server) are having a lot of errors from even viewer logs:

    {Delayed Write Failed} Windows was unable to save all the data for the file \:$I30:$INDEX_ALLOCATION. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

    Can you please explain what's causing the issue and how to resolve this?

    Thank you so much.

    Wednesday, September 7, 2016 9:48 AM

Answers

  • Hi anniebella19,

    Microsoft has released a hotfixfor Windows Server 2012 for when you perform an IO stress test from WS2012 or Windows 8 clients against a WS2012 cluster and you experience "Delayed Write Failed" errors. This problem occurs because the client redirector does not calculate the SMB signature properly.

    Please refer to the link below to check the cause and resolve it.

    https://support.microsoft.com/en-us/kb/2842111

    Hope it will be helpful to you


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, September 8, 2016 2:50 AM

All replies

  • Hi anniebella19,

    Microsoft has released a hotfixfor Windows Server 2012 for when you perform an IO stress test from WS2012 or Windows 8 clients against a WS2012 cluster and you experience "Delayed Write Failed" errors. This problem occurs because the client redirector does not calculate the SMB signature properly.

    Please refer to the link below to check the cause and resolve it.

    https://support.microsoft.com/en-us/kb/2842111

    Hope it will be helpful to you


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, September 8, 2016 2:50 AM
  • Hi anniebella19,

    Haven't received your message a few days, was your issue resolved? Because the case may be closed few days later.
    If you feel the suggestion could be helpful to you, please "mark it as answer" to help other community members who have same questions and find the helpful reply quickly.
    If no, please feel free to post back and tell us the current situation in order to provide further help.
    Best regards,
    Carl Fan


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, September 13, 2016 7:49 AM
  • I installed KB2842111 back in Sep. 2014 and it worked until last month.  This issue showed up again starting 2/7/19.  Any idea when a new hot fix releases for this issue?  Thanks
    Friday, March 8, 2019 3:08 PM