locked
Get-CsServerApplication : Cannot open database "xds" requested by the login. The login failed. RRS feed

  • Question

  • Dear SFB Experts, 

    We are facing a weird issue in SFB 2015. Our environment is we have deployed single SFB 2015 front end server in Enterprise pool with the SQL back end server on different server.   

    After deploying FE server with published topology and all the services are running. Also we are able to login to SFB control panel. But in the control panel we cannot see the published topology and giving the below error. 

    "Get-CsServerApplication : Cannot open database "xds" requested by the login. The login failed."

    Also we have checked the Event Viewer in the SFB server, it's giving the below error. 

    Event 2032, LS Master Replication Agent Service 

    "Failed to register with back-end database. Skype for Business Server 2015, Master Replicator Agent will continuously attempt to reconnect to the back-end.  While this condition persists, no replication will be done.

    Please advise as we are unable to enable users.

    Highly appreciate guys your urgent support. 

    Regards,

    Tuesday, January 2, 2018 4:50 AM

All replies

  • Hi,

    Please check the account of login SFB control panel have a group permission from RTCUniversalServerAdministrator ,CsUserAdministrator, CsServerAdministrator and CsAdministrator


    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, January 2, 2018 5:56 AM
  • Thanks Leon for your reply. 

    But still it's the same issue. I have cross checked all the required permission as mentioned above. 

    I believe there is an issue with the SQL back End connectivity. is there anything need to check on the SQL server? We are using SQL 2012 cluster environment for SFB 2015 enterprise pool. 

    Thanks,

    Wednesday, January 3, 2018 6:14 AM
  • Check you SQL Txn logs. They might be full. You need to clear it up periodically.
    Wednesday, January 3, 2018 7:31 AM
  • Hi SalmanAslamIT,

    Did you deply the SQL Server AlwaysOn Availability Group for Skype for Business Server 2015?

    If so , have you performed a full backup on the second SQL server?select the “xds”

    When you added second SQL Server and published the topology ,did you run the following cmd and change the SQL server FQDN to the “sqlpool.domain.com”

    Install-CsDatabase -Update -ConfiguredDatabases -SqlServerFqdn sqlpool.domain.com -Verbose

    You could refer to the following link about Deploying SQL Server AlwaysOn Availability

    https://blogs.technet.microsoft.com/uclobby/2015/05/08/deploying-sql-server-alwayson-availability-group-for-skype-for-business-server-2015/



    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, January 3, 2018 8:44 AM
  • Hi Leaon, 

    Actually I have checked with my DB Admin, we have not installed SQL AlwaysOn Availability Group in our environment. We are using SQL Server 2012 clustering technique. Also to share with you, I cannot see and change any permission in the properties of xds and lis database. But we can change the permission in the rtcxds database. Looks like there is an issue with the xds database. On the SFB control panel it's giving an error “cannot open xds data base by login failure”. Can we change from database from xds to rtcxds in topology and publish it again? It might works. Need your advice.

    Also refer the below screenshot. 

    Wednesday, January 3, 2018 10:10 AM
  • You may try open the topology and update database once again.also verify the permissions given during SQL deployment is proper.

    Any of the front end server install SQL management Studion and connect to backend SQL server.Are you able to connect to backend sql from FE server?


    Jayakumar K

    Wednesday, January 3, 2018 1:59 PM
  • Are there any update for this issue, if the reply is helpful to you, please try to mark it as an answer, it will help others who has similar issue.



    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, January 8, 2018 8:38 AM
  • this same issue happened to me but in my case i made the mistake of running to this point without adding the admin to the right schema admins group it's about the only issue I see from my end.

    Error: Cannot open database "xds" requested by the login. The login failed. Login failed for user 'Domain\admin'.

    The Prepare Schema (Steps 1 and 2), requires Schema Admins credentials to be performed, we can find that out by checking the Active Directory Users and Computers or running net user <user> /domain and check if the Schema Admins has the current user as member.

    the problem persists even after adding the user to the right group.

    http://techgenix.com/deploying-skype-business-server-part-1-preparing-active-directory/

    Since I was not using the buil-in administrator the Server Roles were not assigned correctly and the securables were not granting the connect to data base option so I had to log out of my Domain admin and log into the local administrator to open the SQL management studio to set the permissions for my domain user in the data base.

    All worked afterwards.

    

    Wednesday, October 10, 2018 6:23 AM