none
"fsutil file setshortname "Program Files" PROGRA~1"=>"Error:Access is denied." RRS feed

  • Question

  • I am trying to use the fsutil file setshortname to set "Program Files" to PROGRA~1,

    but the system is giving me an "Error: Access is denied" response.

    what I have typed:

    Microsoft Windows [Version 6.3.9600]

    (c) 2013 Microsoft Corporation. All rights reserved.

    C:\Windows\system32>cd /d D:\

    D:\>fsutil.exe 8dot3name set 0

    The registry state is now: 0 (Enable 8dot3 name creation on all volumes).

    D:\>fsutil file setshortname "Program Files" PROGRA~1

    Error:  Access is denied.

    And I try it in Safe Mode.It is also "Access is denied.".

    Can someone help me?

    Wednesday, November 26, 2014 6:56 PM

Answers

All replies

  • Hi TimFF,

    This might be related with the UAC settings, check this thread:

    give full permission for the users in program files folder

    The steps in the above thread is not recommended.

    For the short name usage, we may consider to create a directory-junction from PROGRA~1 to C:\Program Files:

    With the following commands:

    mklink /J "C:\PROGRA~1" "C:\Program Files"

    Reference: Mklink

    Best regards


    Michael Shao
    TechNet Community Support


    Friday, November 28, 2014 2:50 AM
    Moderator
  • Your "Program Files" is currently used by the system - that's why you cannot set short name.

    You can still do it by following these steps:

    1. Run Windows in Safe mode with Command Prompt
    2. cd to C:\
    3. fsutil file setshortname "Program Files" PROGRA~1
    Monday, May 18, 2015 11:11 PM
  • Just close all the folder opened in exploerer. 
    Tuesday, March 12, 2019 12:41 PM