locked
URL Set Issue with Methods RRS feed

  • Question

  • Hello,

    I have a problem with configuration of what I thought would be a simple URL Set entry.

    Some info:

    Trunk Name - TestTrunk

    Application - WebTest

    Application Type - "Web"

    Web_Rule1 (Automatically created) - Action=Accept, URL=/.*, Parameters=Ignore, Methods=Post,Get

    This seems to work fine, but our developers have created an application that requires the Method Put.  Fortunately they put it in a sub-directory so I though I could create a simple rule to allow the Method for that application only.  I have used HTTPWatch to confirm the exact request matches the error message we receive.

    Error message - "A request from source IP address <IP ADDRESS>, user <USERNAME> on trunk TestTrunk; Secure=1 for application WebTest of type Web failed because the method used PUT is not valid for requested URL /APPS/Scan/ScanJob/1."

    Web_Rule50 (new rule I added) - Action=Accept, URL=/apps/.*, Parameters=Ignore, Methods=Post,Get,Put

    After adding the rule I saved and activated the configuration, but continue to see the exact same error message.

    I also tried using more detailed URLs in the Rule and experienced the same error.

    I also tried using the name "Web_Rule2" with the same result, but went back to the higher number based on recommendations of using high numbers for custom rules in the event that some automated rule was created at a later date and might overwrite your custom rule.

    Any ideas are appreciated!

    Thanks

    Wednesday, January 28, 2015 11:22 PM