locked
Parameters are ineffective when chart is configured for Excel export RRS feed

  • Question

  •  Proclarity Dashboard Server 6.3

    My user wants to add the import to excel feature to charts in ProClarity Dashboards.  These are the steps they follow.

    1. Change Type to Web URL
    2. Enter the URL and add the following commands to the end of the string
         a. &tabsVisible=false&contentNavigation=false
    3. Apply changes close Dashboard studio

    When they do this the chart now ignores changes to the Parameters defined for the chart and the data then becomes static.

    Is there a way to add the import to excel feature and still have the chart change when the paramenters change.

    Friday, January 23, 2009 9:41 PM

All replies

  • For parameters to be applied to URL views, those views have to be configured to receive the parameters.  See the Dashboard Server help file, and specifically the "Set up parameters" section in "Using Parameters" for information on how to do this.
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, January 26, 2009 11:12 PM
  • Sorry for tardiness in getting to your reply but I was depending on the application to notify when a reply was posted and that never came through.  I will check more often now.

    Being new to ProClarity and being in the support role and not a view designer/developer I will take some time to read the manual and attempt to implement.

    After a quick glance and the book though, I gather that what I aim to do is possible, that is, to add a parameter to a Web URL view that is configured with the import to excel feature.  The technique is to add the parameter to end of the URL like so

    http://xyz.company.com/pas/en/src/proclarity.asp?uiConfig=&book={F2C96CFD-1CD6-4076-8B90-456B108B8E4A}&expr=[[ParameterName:xml(<m>{0}</m>)]]&tabsVisible=false&contentNavigation=false

    Is this what it should look like?

    Thank you,

    Jim

    Friday, January 30, 2009 2:18 AM
  • Yes, that's the method I was referring to.  You may have to play with the URL syntax, but that's the right track.
    Microsoft ProClarity | This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, January 31, 2009 12:41 AM