locked
Legacy OCX Fails to Register RRS feed

  • Question

  • We have a need to register an OCX for a legacy application on Windows 10 Pro.  The OCX registers without issue on a Windows 10 Enterprise machine, but does not register on W10 Pro.  No error message at all -- just the blue spinning circle for 20 seconds or so and then nothing.  We have a second OCX from the same source that registers with no issue.

    It is a 32bit application, so we have tried without success regsvr32 from both system32 and syswow64 and using "Run as administrator".  Regsvr32 shows as still running in task manager after each attempt to register. 

    We have tried disabling virus protection, but still no success.

    Restarting in safe mode, we are able to successfully register the ocx using syswow64\regsvr32 and the app runs as expected in safe mode with networking.  Restart to full OS and the app hangs up when attempting to call the functions in the OCX.

    W10 enterprise has no issue registering the OCX or running the app. 

    Any suggestions appreciated.

    Friday, December 15, 2017 6:14 PM

All replies

  • seems like regsvr32 also hangs when you tried to register in not-safe mode.
    Are you using some 3rd party Antivirus?

    As the OCX now seems to be registered, you try to understand why your app hangs when calling the OCX?
    Is it you own App?
    Friday, December 15, 2017 6:59 PM
  • It is my app, but the OCX is third party.  I can definitely register it in safe mode, but obviously will not be running the app in safe mode.  Since Enterprise works, I'm wondering if anyone has any suggestions on what differences between PRO and Enterprise might be causing the problem or any work around other than using Enterprise.

    Friday, December 15, 2017 10:20 PM
  • as this is working in safe mode, I doubt it has anything to do with Enterprise or Pro.
    When you are using 3rd party Antivirus: uninstall it, disabling might not be enough.

    When you can run it in the Debugger: look at the CallStack, even without symbols for the OCX you might be able to see on what its blocking.

    Friday, December 15, 2017 10:32 PM
  • Thanks, I'll give that a go.

    Friday, December 15, 2017 11:59 PM