locked
Remove and reconnect Exchange 2007 from Domain RRS feed

  • Question

  • I have an Exchange 2007 server running on a Windows 2008 server. For some reason the server will not run group policies. It hangs for a very long time when logging in on "Applying Group Policy Printers Policy" And also won't shutdown hanging on "Applying Group Policy". The only wany I can shut it down is to manually power off the server.

    I also ran the Group Policy Results Wizard and get a timeout when I run it against the Exchange server. DNS is working fine. I have tested all of the other servers using the same DNS and they all work fine. The server in question has been having other problems for a while now, but I have been able to resolve all the other problems except for this one. The server is old and will be replaced this year, but I have to make it work until I get a new server. Maybe 6 months or so.

    I am thinking of removing the server from the domain and then joining the domain again. I'm not sure that will fix it, but I hope it will. The only thing I'm worried about is getting the Exchange database and server running again after I remove and rejoin it to the domain. I have heard I can shutdown and disable all Exchange services, then remove the server from the domain and rejoin. But I have never done that and want to be sure it can be done without destroying connectivity to AD and the users. So, is this possible?

    Any help is appreciated.

    Doug

    Tuesday, April 7, 2015 2:21 AM

All replies

  • You should try fixing the AD issues instead of removing the Exchange server from the domain. You should start by analyzing what was done to cause the issue in the first place and remedy that.

    Here is a bit similar concern that has been discussed earlier and has been suggested some good steps to sort-out the issue : http://community.spiceworks.com/topic/267400-removing-and-re-joining-an-e2k7-server-to-the-domain

    Moreover, when need to recover mailbox items back into previous format, you may also give shot to this automated solution (http://www.exchangeserverrecovery.com/) that could be a good approach while dealing in such crucial circumstance.

    Tuesday, April 7, 2015 6:46 AM
  • I would love to fix AD issues on that server, but I have tried and tried with no luck. I have seen the the post of the link you provided, but my network does not have the same problem. My only problem is the Exchange server itself. All other DC's and PC's are fine.

    The main problem is that it seems the problem started after a series of sever crashed on the Exchange server. It got shutdown hard about a half dozen times from power outages. So figuring out exactly what is wrong is difficult to do. 

     
    Tuesday, April 7, 2015 4:43 PM
  • UPDATE!!!

    So I have an update to my original post. It seems that only the Administrator account is affected by this problem. I created a new account with domain admin rights and was able to login viz RDC. Because this problem was caused by the server crashing, I'm thinking that just the Administrator profile on the server got corrupted somehow. 

    I did not do the original installation of this server, but I'm pretty sure it was installed using the Administrator account. So my question now is will it affect the server at all if I delete the Administrator profile on the server and recreate it? That seem a whole lot better than removing it from the domain and rejoining the domain.

    Tuesday, April 7, 2015 7:47 PM
  • This server is driving me nuts! I thought everything would be fine once I deleted the domain administrator profile from the server. But after I deleted, rebooted and logged in, I'm having the same problem. The only difference is not it hangs on "Applying Scripts Policy". 

    I can login as any other user who has rights to login to the server, but not with the Administrator account. I ran the Group Policy Results Wizard again. And it works on all accounts except Administrator.

    I'm not sure where to go from here.

    Wednesday, April 8, 2015 5:14 AM
  • What group policies are applied to the server?

    Only the default domain policy?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Thursday, April 9, 2015 2:42 PM
  • There are currently two policies running on the server. Once is the Default Domain Policy and the other is a Windows Update policy. The only thing the update policy does is set the WUS server and update time. 
    Thursday, April 9, 2015 5:52 PM
  • From your description, I'm not sure removing and re-adding  the server form the domain would fix things.

    It seems to be something with the domain admin account. How soon are you planning to migrate to Exchange 2010/2013 or O365?

    I suppose you could manage the server with another account in the meantime.

    Have you run a disk check on the OS drive after all the crashes (there were several, correct?)?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Friday, April 10, 2015 1:02 PM
  • I'm not sure it's a problem with the admin account. The admin account works fine on all other 8 servers we have and all of the workstations. It's just the exchange server that is having the problem. I have already advised the other admins to use the new admin account I setup. So we just may leave it for now. 

    We are planning to migrate to Office 365 sometime before summer. So it won't be long before I decommission the server anyway. 

    I have not run chkdsk on the server and probably won't. In my opinion, this server is somewhat crippled now and has had problems with the RAID array as well. The last thing I want to do is run chkdsk and find that my server is no longer bootable. 

    Friday, April 10, 2015 5:45 PM