Server 2003 R2 - Entire network can't watch youtube videos


  • I have searched the internet high and low and cannot even seem to find another instance of this problem, let alone a solution.

    I have a client who is using Windows Server 2003 R2. The server is controlling Active Directory, DHCP, DNS, and serving some custom business applications. No matter what I do, I cannot get any system on the network to view youtube videos. I can get to load, and I can click on a video, and the video's page will load but the embedded video itself will not. This happens on every system on the network, and the OS does not seem to matter as the problem is present in XP, 7, 8, and the server itself. Just for the sake of troubleshooting, I plugged a MacBook Pro into the network and the problem occurred on it as well, and I didn't even join it to the domain. The problem does not occur on all flash content, just youtube videos. Systems on the network can still view any other flash content, including games.

    I have already checked for content filtering, and nothing is being blocked by the router, server, or ISP. At this point I'm not entirely sure if this is a server problem or a network problem, but I'm going with server for now.

    Any suggestions would be appreciated.

    Tuesday, August 27, 2013 8:59 PM

All replies

  • Hi,

    Do you have the same problem when browsing any other videos website?

    Please confirm port 1935 is open. Since non-domain joined client has the same problem, I recommend you to check the edge devices.

    Try to access the internet directly instead of routers if possible.

    If the problem persists , you can ask the ISP for help.

    Wednesday, August 28, 2013 9:27 AM
  • Hello,

    if no ports are blocked with firewalls and all web pages can be opened without any problem, there may run some GPO that blocks this.

    As i read your DC does also host business application i recommend that you redesign your network. A DC should NEVER run anything else then AD/DNS/GC, keep in mind that a DC is the heart of the domain and contain security related informations. So NO user should be able to connect that direct to a DC and especially have NOT to logon to a DC.

    Hopefully the DC is not configured for RDS/TS access.

    Best regards

    Meinolf Weber
    Microsoft MVP - Directory Services
    My Blog:

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Wednesday, August 28, 2013 9:49 AM
  • Which Internet browser application you are using from all OS ?

    Try other application like, Google chrome / firefox, etc.., and confrim if the issues persists.

    Thanks & Regards,
    Amit Katkar (MCITP Windows 2008)
    This posting is provided "AS IS" with no warranties or guarantees and confers no rights.

    • Edited by Tech Love Wednesday, August 28, 2013 10:04 AM r
    Wednesday, August 28, 2013 10:04 AM
  • Daniel -

    It looks like it's just isolated to For example, videos on work.

    I triple checked, and there is no ports being blocked, so 1935 should be open.

    Also, I did contact the ISP and they told me they weren't filtering any content, and essentially since it's not their equipment causing the problem they can't help me.

    I am not onsite right now, so I'm working remotely, but next time I'm in this office I will try hooking up direct to the internet.

    Meinolf -

    No, the users aren't using TS or RDS. There's only one business app they use that contacts the server, and it's a DOS based program for tracking calls, but it's installed on each workstation... it just uses the server for a place to store it's data (on a separate HDD, not C). There's a shared network drive on the server too for file storage, again, not C.

    <input id="0149c30f-79cf-4a53-87f4-ee034448814a_attachments" type="hidden" value="" />

  • Amit -

    I have tried IE (8, 9, & 10), Chrome, Firefox, and Safari. They all fail. The embedded video on the page just says...

    An error occurred, please try again later.
    Learn More

    When I click on "learn more" it tells me to update flash, try html 5, and so on... I've tried all of those steps as well.

  • Edited by jerwiles Wednesday, August 28, 2013 3:06 PM
Wednesday, August 28, 2013 2:57 PM
  • The ISP came out to the site and was able to confirm that it is not their equipment or the line causing the problem. They even brought a new modem and tried it and the problem is still occurring on this network. Checked the router and all content filtering is turned off. At this point is HAS to be the server. What on the server could cause this?
    Thursday, September 05, 2013 1:05 PM
  • Hi Daniel, I have same problem. did you find solution for this problem? 


    Wednesday, October 15, 2014 9:24 AM