locked
your client does not support opening this list with Windows Explorer RRS feed

  • Question

  • HI all,

    I have moved a SharePoint Farm to Another .I have made the farm exactly the same . I have both the farms running side by side . 

    Now when i open the new farm document library with the Internet explorer 8 but i get the foollowing error when i open the document library in windows exporer 

    "your client does not support opening this list with Windows Explorer"

    To troubleshooting the issue i google and did the following methods but still i am falling short 

    1)  install KB910365 

    2)  Start WebClient 

    3) Install root certificate 

     

    Sunday, October 23, 2011 5:53 AM

Answers

  • Hey Guys ,

    i finally figured it out .

    Since the SharePoint has its own Internal Webdav implementation , the IIS seems to get consfused on which Webdav to use .

    SO the resolution is delete the Webdav entry in the MODULES Of the IIS .

     

    • Marked as answer by Austin Dsouza Friday, November 11, 2011 7:20 PM
    Friday, November 11, 2011 7:20 PM
  • Removing WebDav Publishing from IIS (remove role services) does the trick!

    Thank you Austin!


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    • Marked as answer by Austin Dsouza Tuesday, April 23, 2013 11:50 AM
    Friday, June 22, 2012 9:38 AM

All replies

  • Are you using a win 2008 server to browse the site? See both http://mossdefinitely.blogspot.com/2010/08/enabling-webdav-in-sharepoint-windows.html and http://blogs.technet.com/b/seanearp/archive/2010/07/08/your-client-does-not-support-opening-this-list-with-windows-explorer.aspx
    AK
    Sunday, October 23, 2011 7:38 AM
  • Make sure that you have installed the following updates on the servers http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=15123
    http://moss-solutions.blogspot.com/
    Sunday, October 23, 2011 8:39 AM
  • Yeah i did try both the methods , still no luck ..

    moreover when i add the kbarticle  it says installtion successful but when i check the view installed updates in the control panel it doesnt show up.But then again that's the case on the first farm too but still over there the explorer feature works

     

    So frustrating when you really don't know where to look upto

    Monday, October 24, 2011 3:24 PM
  • Hmmm .. looks like i am gonna fall short on this one ..

     

    Thursday, October 27, 2011 6:15 AM
  • I once had similar issue and it was due to IIS Web DAV Services are they Up and running? You also need to enable Desktop experience Feature also. check this out it can be of some help to you.

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/023f4b23-3ce6-4d83-8cb0-7398b88ba6ab/ 


    Raghavendra Shanbhag | Blog: http://moss-solutions.blogspot.com
    Please click "Propose As Answer " if a post solves your problem or "Vote As Helpful" if a post has been useful to you.
    Disclaimer: This posting is provided "AS IS" with no warranties.
    Friday, October 28, 2011 6:13 AM
  • Thanks  Raghavendra Shanbhag

     

    But i have already done that and still it gives me the issue ..

    Very strange in nature .. If anyone could guide me where i could c the logging information then i would get an idea on understanding the rectifying it .

    Saturday, October 29, 2011 7:05 PM
  • Try disabling the loopback check if using WEBDAV on the server.

    http://support.microsoft.com/kb/896861

    Remember to only use the BackHostConnectionNames registry key change for PROD servers.


    Dan Luciano - Sogeti USA - MCITP, MCTS WSS 3.0 and MOSS 2007 Configuration WSS 3.0 Applicaton Development SharePoint 2010 Admin and Config
    Sunday, October 30, 2011 5:48 PM
  • Web Client Service comes when you already have Desktop Experience Feature enabled.

    What is the OS on the Client machine from where you are trying to open the explorer view? Do you have URL scan enabled on the SharePoint Server?


    Regards, Vishwas
    Sunday, October 30, 2011 9:12 PM
  • Sorry for the late reply .

    Thank you guys for ur suggestions .

    Well i have tried it all but nothing seems to work

    Regarding the question of Vishawas B

    What is the OS on the Client machine from where you are trying to open the explorer view? Do you have URL scan enabled on the SharePoint Server?

    I am opening it on the same server (Win2k8 R2 64-bit) even tried on Win7 32-bit .

    i dont think i have installed the URL scan  . I will and check to see the results .

    Wanted to if there are any other way of debugging this . May be some tool to see how the process takes place . Tried using Fiddler but didnt get anything substantial .I am a novice when it comes to IIS related stuff

     

    Thanks guys in advance . 


    Wednesday, November 9, 2011 6:37 AM
  • After Careful observation of the IIS LOGs i found this error

     PROPFIND <> <> ::1 Microsoft-WebDAV-MiniRedir/6.0.6002 405 0 0 0

    Well i have also tried tried the request filtering method of giving the verbs PROPFIND and OPTIONS the ALLOW VERB .

    Since i am a novice i am having some trouble in troubleshooting this issue debugging it Any Help would be great

    Thankx in advance once again GUYS

    Friday, November 11, 2011 7:02 AM
  • Hey Guys ,

    i finally figured it out .

    Since the SharePoint has its own Internal Webdav implementation , the IIS seems to get consfused on which Webdav to use .

    SO the resolution is delete the Webdav entry in the MODULES Of the IIS .

     

    • Marked as answer by Austin Dsouza Friday, November 11, 2011 7:20 PM
    Friday, November 11, 2011 7:20 PM
  • Just install Desktop Experiance from Server Management -> Features, and you're problem is gone

    I know it's already resolved you're probleme, but.. I had to write.. :)


    Microsoft Certified Technology Specialist: SharePoint 2010, Configuring
    Microsoft Certified Personal
    • Proposed as answer by Zahid Sayyed Wednesday, November 30, 2011 10:36 PM
    Friday, November 11, 2011 8:13 PM
  • This is the right way!

    thanks a lot Gokhan

    Wednesday, November 30, 2011 10:37 PM
  • Your client does not support opening this list with Windows Explorer or There was an error opening this document.  The filename, directory name, or volume label syntax is incorrect.

    OPTION 1

    Switch to the All Documents view to resolve lists.
    All Document View
    OPTION 2
    1. USING WINDOWS 7 (X32 OR X64 BIT)
      1. Click Start
      2. type regedit.exe in the Start Search box
      3. Locate and expand the list and navigate to the following location
        1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameter
      4. Locate the value BasicAuthLevel
        1. Right click the value and choose Modify.
        2. In the Value data box, type 2, and then click OK.
      5. Exit Registry Editor, and then restart the computer.

     

    Sai
    Thursday, December 1, 2011 1:41 PM
  • Thanks for your solution

    Tuesday, February 28, 2012 5:54 AM
  • The solution we found that worked was to add our sharepoint site to the Trusted Sites collection in Internet Explorer.

    (IE8: Tools -> Internet Options -> Security Tab -> Trusted Sites -> Sites button)

    Wednesday, March 7, 2012 5:40 PM
  • I have a user Windows XP, IE 7 who cannot use this feature. We have made sure he can use it on other computers fine and he has the site in his trusted sites list. His webdav is enabled and this did work at one point in time, but broke. User isn't sure when it broke. Thoughts?

    Benrey

    Friday, March 9, 2012 6:31 PM
  • The "your client does not support opening this list with Windows Explorer" message box popping up seems to be intermittent.  Once it happens, it will persist until I restart WebClient.  Then it'll work again, until it decides to fail again.  At which point I have to restart WebClient to get it working again.  Is anyone looking at making this horrible software robust?

    Tuesday, March 13, 2012 11:45 PM
  • Same problem overhere. Using Windows 7 x64 and Webdav is intermittent failing. Target sharepoint doesn't seem to matter. Sp2007 Sp2 x64 or SP2010 x64.

    We are going to migrate to Windows 7 x64 from Vista x86 on which this wasn't a problem.

    If any one has a solution.

    Friday, March 16, 2012 6:51 AM
  • I found online where the error would occur intermittently with SharePoint 2010, however I think the SharePoint version is irrelevent. I read where the client would sometimes poll for a SharePoint root site and the error would occur if there was none. We have not seen the error since I created a root site even though we're only using WSS3. Our errors began when we changed clients to Windows 7. So it sounds to me like the issue could be from root site polling due to an IE8 security change in Windows 7.
    Thursday, May 24, 2012 6:25 PM
  • Removing WebDav Publishing from IIS (remove role services) does the trick!

    Thank you Austin!


    MCTS - Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. http://mariusene.wordpress.com/

    • Marked as answer by Austin Dsouza Tuesday, April 23, 2013 11:50 AM
    Friday, June 22, 2012 9:38 AM