none
IE 11 not able to add Search Provider RRS feed

  • Question

  • This is brand new Windows 8.1 install, freshly installed O365 and all critical updates installed.

    So I click on the gear in IE, select Manage add-ons.

    This opens the Manage Add-ons window, I click on Search providers, it only shows Bing.

    I click on Find more search providers... at the bottom of the window, this opens IE with a list of the search engines. I click on Google, which loads the google search page.  When I click the Add to Internet Explorer button nothing happen, nothing gets added, no message gets display, NOTHING.

    I see the button wants to run a javascript, so I go back in add this site to trusted sites, thinking that will allow it to run.  Close browser, re-open, try again, same outcome .... NOTHING.

    So next I go and reduce the security level to low for trusted sites, figuring this will allow the script to fire off.  No luck, still nothing.

    Next I go to windows features, un check IE 11, reboot, go back in again check IE 11.  Try it again, still nothing.

    Finally I installed the Google Toolbar for IE check the box for making google the default search, after install reboot, guess what .... still nothing but Bing listed in search providers.

    Is there another way to repair IE 11 on Windows 8.1?  I have done this many times in the past, why now is this such an issue? Can I manually put this into the registry?


    Cheers,
    Curt Winter
    Certified Microsoft Professional
    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied. If you found my post helpful, please mark it as the answer.

    Wednesday, April 15, 2015 7:43 PM

Answers

  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams

    • Marked as answer by Curt Winter Thursday, April 16, 2015 4:11 PM
    Thursday, April 16, 2015 1:48 AM

All replies

  • So next I go and reduce the security level to low for trusted sites, figuring this will allow the script to fire off.  No luck, still nothing.

    Did you try booting in safe mode or otherwise doing some clean-boot troubleshooting?  This sounds like a case of interference.  For example, some Dell users found that their McAfee pre-installed trial caused this kind of thing.  Apparently the uninstall doesn't work completely and leaves active bits of it behind.



    Robert Aldwinckle
    ---

    Wednesday, April 15, 2015 8:19 PM
    Answerer
  • I'm having the exact same problem. Reset my Surface Pro 3 yesterday, installed Norton 360, Office 365, Macrium   Backup, Bing Desktop and Hot Virtual Keyboard. Can't install any search providers, same symptoms as above. So I grabbed my wife's SP3 and tried on hers. Same problem. I wonder if it might be a bad IE update. 

    Edit: All updates have been installed.

    Wednesday, April 15, 2015 11:33 PM
  • Can't install any search providers, same symptoms as above.

    Looks like there is a coding error there.  Use Developer Tools, Script Debugger, Break on All Exceptions to see

    Syntax Error line 2660 http://az307127.vo.msecnd.net/?v=46697e4_e7ae975679d216836cd7329fa6343870&p=scripts&js=jquery-1.5.1,jquery-ui-1.8.11,jquery.tools.scrollable,jquery.tools.scrollable.autoscroll.pete,jquery.tools.scrollable.navigator,jquery.jscrollpane.min,jquery.mousewheel 

    This has happened before and there is a workaround for it...  Right-click Properties on the button shows (for example)

    javascript:BrowserDetectionAddonInstallSearch('/en-us/AddOns/DownloadAddOn?resourceId=816','False', '816', '00000000-0000-0000-0000-000000000000');

    So, I think you can just convert that to a URL from that site and see what happens...

    http://www.iegallery.com/en-us/Addons/DownloadAddOn?resourceId=816 

    Does that work for anybody?  It's showing me the XML that would be downloaded by the Add to Add-ons UI but I think that I have got my XML formatting switched off.  E.g. I think I was fiddling with the ActiveX add-ons involved with that.  But if that procedure works for you I wouldn't have to bother trying to figure out what I needed to do to get it working properly again for me.   ; )

     

    Good luck



    Robert Aldwinckle
    ---

    Thursday, April 16, 2015 12:52 AM
    Answerer
  • Didn't work for me.
    Thursday, April 16, 2015 1:16 AM
  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams

    • Marked as answer by Curt Winter Thursday, April 16, 2015 4:11 PM
    Thursday, April 16, 2015 1:48 AM
  • Didn't work for me.

    What didn't work.  Can you click on my example link?  What happens?


    Robert Aldwinckle
    ---

    Thursday, April 16, 2015 2:51 AM
    Answerer
  • Didn't work for me.


    What didn't work.  Can you click on my example link?  What happens?


    Robert Aldwinckle
    ---

    I get to ieGallery.com and just see some XML code

    Thursday, April 16, 2015 8:52 AM
  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams


    I uninstalled that update and was able to add search providers. After I got everything set, I reinstalled the update. All is well.
    Thursday, April 16, 2015 9:06 AM
  • I get to ieGallery.com and just see some XML code

    Thanks for the feedback.  Same as me then.

    OK.  Then you could use the XML as input to this procedure

    http://blogs.msdn.com/b/ieinternals/archive/2012/04/28/building-custom-search-providers-for-the-internet-explorer-search-box.aspx

    But I just tried that in the Console tab, e.g. entered this

    javascript:window.external.AddSearchProvider("http://www.iegallery.com/en-us/Addons/DownloadAddOn?resourceId=816")

    and just got back  Undefined  and nothing added to the list of Search Providers.  Strange.  I used Eric's utility recently to add a Search provider which is no longer being supported by the IEGallery and it worked fine.  Doing it this way, ideally in the Address bar itself would have been easier.

    On W10 I get Access denied which is more positive I suppose.

    I'll have to try using ProcMon to see if I can figure out what is going on.  TBD.



    Robert Aldwinckle
    ---

    Thursday, April 16, 2015 2:28 PM
    Answerer
  • I removed KB3038314 and was able to change the search provider without issue.

    Looks like MS will need to update the update, unless this is designed to help drive traffic to Bing.

    Thank you Thomas, I hope this works for others also.


    Cheers,
    Curt Winter
    Certified Microsoft Professional
    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied. If you found my post helpful, please mark it as the answer.

    Thursday, April 16, 2015 4:12 PM
  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams


    I also can't add Google as provider after recent updates. I uninstalled "KB3038314", and after that I added

    Google search provider seamlessly.(Thanks Thomas Albert Adams!)

    I just want to add another workaround to able to add Google search provider again with "KB3038314" installed and reset IE settings was applied.
    (Tested on Windows 8.1 Pro 32bit.)
    Remember: If you have "KB3038314" installed and do "Reset Internet Explorer Settings" Google Search Provider will disappear and can't set it back with "KB3038314" installed, unless you have saved settings for "SearchScopes" key before "KB3038314" was installed.

    I recommend to "Reset IE Settings", and "Restore Advanced Settings" everytime a new version/patch/update for IE was installed, to avoid bugged surfing/options/menus/sounds. After that you need to reconfigure your browser settings again.

    Let's finish the job...

    1. Uninstall "KB3038314" (If you not installed this update go to step 5)
    2. Restart PC
    3. Start IE and add Google search provider from IE gallery Microsoft site.
    4. Close IE
    5. Run "regedit" as administrator privilegies nad navigate to "HKEY_CURRENT_USER">>>"Software">>>"Microsoft">>>"Internet Explorer">>>"SearchScopes"
    6. Right Click on "SearchScopes" key and click "Export" and save it under what name you want.
    7. Close "regedit" and install again "KB3038314"
    8. Restart PC
    9. Right click on the saved Registration Entries from "Step 6" and click "Merge", press Yes.
    10. Run IE, go to "Tools"-->"Manage add-ons"-->"Search Providers" and add/set Google/default search provider.
    11. Thats it.

    Thursday, April 16, 2015 7:03 PM
  • Another confirmation on Windows 7 x64, removing KB3038314 restores IE11 add search provider functionality.  Microsoft please provide an 'update' for this update that restores this functionality.

    Cordially,

    Shannon Garrett

    Thursday, April 16, 2015 9:36 PM
  • Good workaround. It's indeed not a bug on the IE gallery site. All versions of IE have stopped being able to add a new search provider after the last cumulative update. Some, some bug got introduced in this area and I hope they fix it with the next update.

    However, one point needs clarification.

    There is absolutely no need in resetting IE after an update. Don't do it unless you really want to do it for "good taste" or whatever. Really, no need.


    IEFAQ: http://iefaq.info

    Saturday, April 18, 2015 3:18 PM
  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams

    Yeah! Many thanks Thomas, it did the trick for me. I spent hours trying to fix it with changes to URL of iegallery.com (content and language) to no avail. I just uninstall the Windows update and reboot. Then I was able to add new search engines to IE11. Thanks again.

    Cheers from France


    I hope I'll ever prefer snow free ride than computers

    Saturday, April 18, 2015 11:30 PM
  • @Thomas Albert Adams

    <qp>

    I uninstalled that update and was able to add search providers. After I got everything set, I reinstalled the update. All is well.

    </qp>

     - Validated.  All five (Google, Bing, Wiki, Yahoo!, and Youtube) of my Search providers added quite some time ago and prior to installing KB 3038314 remain intact after installing KB3038314.  Also, like others have reported post install of KB 3038314 the ability to add other optional search providers fails.

    Thus it's it appears to be prudent to add the desired search providers before installing KB3038314. Though there is a probably a subset of folks that don't even use the search providers added or even desired to be added.


    ...winston
    MSFT MVP Consumer Apps

    Monday, April 20, 2015 8:07 PM
  • I just finished a Clean install of Win-7x32 and installed all updates.  Removing KB3038314 did NOT restore the ability to add search providers.

    Monday, April 20, 2015 9:48 PM
  • There is absolutely no need in resetting IE after an update. Don't do it unless you really want to do it for "good taste" or whatever. Really, no need.
    +1!

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Community and TechNet Forums
    My MVP Profile

    Tuesday, April 21, 2015 4:59 AM
  • However, one point needs clarification.

    There is absolutely no need in resetting IE after an update. Don't do it unless you really want to do it for "good taste" or whatever. Really, no need.


    IEFAQ: http://iefaq.info

    Do you really think that what I said above are empty words?
    These words are based on 12 years of experience(I use IE since 2003), so I know "what" and "why" I write it.

    Once happened to me when I press the "Clear SSL State" to nothing happens - either out pop-up window, nor sound when I press "Clear SSL State". I had not been reset IE settings for a long time, I also was installed IE updates from "Patch tuesday" for IE previously.  You can guess how to fix everything from scratch - by resetting the settings of IE. (Not accidentally this option has it in BIOS, tablets, phones, TV, software products and so on.)

     Also, search providers sometimes periodically update their search provider little icon that appear in IE. So If search provider update their icon service, you need to reset IE settings to refresh that icons. This icons is located in C:\Users\"Your Name"\AppData\LocalLow\Microsoft\Internet Explorer\Services.

    Are you absolutely sure that it can't occur bug after any update, update circumstances, interactions with other software, with a particular version of the software? When preconditions exist, so potentially is fully possible. If not happened to you then does that mean that there is not exist? Do not ignore the experience of others. I can did not write it, but I decided to share my experience, because it may be useful to someone.

    "Don't do it unless you really want to do it for "good taste" or whatever. Really, no need."
    I said it clearly - "to avoid bugged surfing/options/menus/sounds"
     This is not for a "good taste" this is for "to avoid bugged surfing/options/menus/sounds" and messed settigs/conflicts and "This can be useful for troubleshooting problems that might be caused by settings changed after installation."

    There is absolutely no need in resetting IE after an update. Don't do it unless you really want to do it for "good taste" or whatever. Really, no need.

    +1!

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows & Security Expert - since 2003.
    Moderator in the Microsoft Community and TechNet Forums

    Sir, the same thing that I wrote to Kai Schätsl, goes to you.

    Thursday, April 23, 2015 8:18 PM
  • Apparently Security update 3038314 is designed to prevent you from changing your search provider from Bing to anyone else. I hate that awful bing. I know some url's by heart and I'll type them in the address bar and any machine that has bing will typically redirect to a bing results page.

    I sincerely hate how microsoft tends to use practices like this to force their products on us

    Thanks for the solution Thomas

    Monday, April 27, 2015 6:36 PM
  • I know some url's by heart and I'll type them in the address bar and any machine that has bing will typically redirect to a bing results page.

    Sounds like you are typing only a host name and you have Search from the Address bar enabled probably also with the default Search Provider's Search Suggestions also enabled.  Try using a full URL from either your History or Favorites to avoid that feature.  In the case of having a Search provider which does not have Search Suggestions enabled I think it may also be sufficient to type a full URL including its protocol prefix (which you would also get by using a URL from the Address bar's AutoComplete drop down suggestion list).


    Robert Aldwinckle
    ---

    Wednesday, April 29, 2015 8:23 PM
    Answerer
  • No need. Full stop. If you want to do it with each cumulative update you're welcome, but you do it for "good taste" or "good feeling" or whatever you want to call it. You once or twice had a problem. You do not even know if the problem would not have surfaced, anyway. But it's not necessary and not even recommended. I won't tell you how long I use IE or how long I've been an MVP, but it's much longer ...

    IEFAQ: http://iefaq.info

    Thursday, April 30, 2015 8:26 AM
  • Nonsense. 1. this has nothing to do with Bing, 2. if you type an existing URL it goes straight to that URL. If you enabled searching from the address bar you can type "something" in the bar and it will search on your default search provider (which could be Google or Wikipedia or whatever) and display a results page, because this is not a URL. But if you type http://www.something.com or just "www.something.com" it goes straight to that website without searching as it exists. That's normal behavior and all browsers have this or a similar behavior.

    IEFAQ: http://iefaq.info

    Thursday, April 30, 2015 8:33 AM
  • Wow. You must have spent some time figuring out which update caused this. I thank you very much for your time and effort, and for posting this solution. It worked perfectly for me!!!!!
    Friday, May 1, 2015 4:32 AM
  • I installed all the Windows Updates on 3 systems yesterday (2 W7 & 1 W8.1.1). Since then I haven't been able to add a search provider to IE 11. I just finished uninstalling KB3038314 on one of the W7 systems and that resolved my problem.  Hope it works for you also.


    Thomas Albert Adams

    I was having the same issue and uninstalling the above update resolved the issue for me. Thanks!
    Wednesday, May 6, 2015 2:56 PM
  • I have the same problem on Windows 7 & 8.1. Since I just wanted to add Google search, I found that if I added the Google toolbar, it automatically added Google search to IE. This works for me until MS fixes the bug.
    Wednesday, May 6, 2015 5:56 PM
  • If this is designed to drive traffic to bing it's a terrible idea.

    Chrome would let you add bing, yahoo, etc.

    Firefox would let you add bing, yahoo, etc.

    Honestly I think this is either a bug or a really stupid business decision. I like Microsoft products and I'm optimistic for Edge, I just don't like losing a simple choice of a search engine. Chrome and Firefox both let me chose search engines despite having their defaults. Vivaldi and Opera too.

    If anything they should let the user add search engines manually via a settings dialog without editing the registry, with an option for administrators to block that. That's just my opinion though.

    Saturday, May 9, 2015 11:08 PM
  • Supposedly fixed with the 12 May-15 release of KB3049563 (MS15-043).
    Tuesday, May 12, 2015 8:41 PM
  • This is definitely the fix. I've had to do it to three of my customer's machines and it also fixes it for windows 10 with IE11
    Monday, May 18, 2015 5:02 PM
  • +1

     ...w


    ...winston
    MSFT MVP Consumer Apps

    Monday, May 18, 2015 8:15 PM
  • I do not understand this issue at all. I am working on a customer's computer and started searching for solutions to this when I could not add Google to the list of installed search engines, set it as default and remove Bing and all the rest (something I routinely do).

    The computer I am working on does not have the mentioned KB installed so why is the issue present?

    What worked was to go to google.com and on that page, in a tiny blue info bar, it asked me if I wanted to set goog as my default. THAT worked and allowed me to remove Bing.

    I have wasted a great deal of time on this issue and this just leaves a bad taste in my mouth as far as Microsoft is concerned. How in the world do you code something in a browser that completely ignores all of the alternate links to the IE gallery I have seen posted to work around this problem? Seems to me they are being redirected at the whim of Microsoft and not as a result of a security update. Bah.

    Good thing I already had google installed on my own box, I would have been furious if this had happened to me. I don't like google but I like bing even less, even though it has pretty pictures. It just does not do the job as it misses too much info. Like using Startpage does.

    And a moot point, really. I have used firefox since ver 1. I keep trying IE and it just does not work for me but I let my customers use it until they get into trouble from indiscriminate browsing. IE does not have the best track record...

    • Edited by DS210 Friday, June 5, 2015 10:28 AM
    Friday, June 5, 2015 10:21 AM
  • I just went through this entire fiasco today while setting up a new computer for my wife. Fortunately I found this thread which give me some help. However she had the update mentioned that was supposed to solve the problem and it didn't. I ended up having to install the Google toolbar which asked me if I wanted to set Google as the default search engine. After I did I was unable to go and remove Bing. No matter how hard Microsoft tries people are not going to use Bing and my trying to force people into using it it just makes people hate it more!
    • Edited by Msradell Sunday, June 7, 2015 2:29 AM
    Sunday, June 7, 2015 2:29 AM
  • The MSDN Blog Building Custom Search Providers for IE's Search box (Just copy and paste that into your favorite search provider :) )

    has a link to a tool that will work to add google as a search provider

    2) If you want google to make suggestions find someone who has windows 7 and have them mail you the string value

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes\{GUID}

    Find the correct sub -entry for Google

    and get the value for the string named SuggestionsURLFallback and add it to your entry. (I would give you the string but I don't have permissions to submit URLS yet).

    3) Go into Tools -> Manage Add-ons -> Search Providers   and make Google the default

    Bob


    • Edited by OldGuyBob Sunday, June 7, 2015 10:47 PM
    Sunday, June 7, 2015 10:46 PM
  • IE11 > Help > About
    Update Versions: 11.0.18 (KB3038314)
    After installing KB3049563
    Update Versions: 11.0.19 (KB3049563)

    Search Provider choice is working again.

    Comes with the Windows Updates.
    Manual install: wusa.exe Windows6.1-KB3049563-x86.msu /quiet /norestart

    Had solved this earlier with a regkey but this patch recovers this issue. For the interested ones:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\SearchScopes\{0633EE93-D776-472f-A0FF-E1416B8B2E3A}]
    @="Google"
    "URL"="http://www.google.com/search?q={searchTerms}"
    "DisplayName"="@ieframe.dll,-12512"





    Monday, June 8, 2015 11:00 AM
  • You can try this

    It work for me

    http://www.iegallery.com/en-us/Addons/Details/813

    Sunday, June 14, 2015 5:14 AM
  • Google finally submitted an HTTPS version

    But now it looks like they have changed it again.

    I got one called Google HTTPS when I got it but now instead search finds something new called Pin Google

    http://www.iegallery.com/en-us/PinnedSites/Details/16621

    It seems every time I comment on it they change it.

    http://answers.microsoft.com/en-us/ie/forum/ie11-iewindowsrt8_1/google-search-not-on-internet-explorer-add-ons/8cb3df5f-1836-4162-954d-c1065682392d?msgId=43599f7d-a93e-4c5c-b626-9c377b4a3bbb



    Robert Aldwinckle
    ---

    Sunday, June 14, 2015 11:53 AM
    Answerer
  • THE SILVERFOX [and] Jayp285, You are missing the point: It does NOT work!

    The BUTTON IS *DISABLED* -- how "LOUDLY" do we have to shout that?! The button looks normal, but when you click it, nothing happens.

    It's great that you have a direct link, but it just does NOT work, since Microsoft has, in effect, "disabled" the button, and it gives zero warning or errors -- when you click the button, nothing happens.

    Also, it is not just that mentioned KB that is the problem; because I do not have that KB, but my IE11 will not allow Google to be added. Haven't tried other search providers. Supposedly, it may be some javascript coding error? But, isn't it funny that it is disallowing "the competition?" It makes people wonder if Microsoft did this on purpose; because, prior to a certain point, it was working just fine.


    tnjman

    Thursday, July 16, 2015 11:43 AM
  • See my other comment (and please read the entire thread!) -- it just does NOT work - the button is, in effect, disabled. People already stated that they get directly to the page to add Google search provider but, when clicking the button, nothing happens.

    tnjman

    Thursday, July 16, 2015 11:44 AM
  • Hi @TNJ,

    try going directly to this link - http://www.iegallery.com/Addons/Details/813

    there appears to be a glitch in the landing page with filtered by Addons... I was able to reproduce the issue, but after waiting and clicking the Google Search Provider button a number of times it eventually took me to the url above, when you can finally click the Add Search Provider button.....

    I was going to add a screen shot, but apparently that is being fixed here at the moment, so I can't.

    I once was a rubber man... Toyo and Dunlop.

    Regards.


    Rob^_^

    Friday, July 17, 2015 2:11 AM
  • button is, in effect, disabled.

    Sounds like you are missing some maintenance.  That problem has been fixed.

    However, just to test that without reference to Google which seems to be a bit of a problem by itself, try the one for Yahoo instead:

    http://www.iegallery.com/en-us/Addons/Details/816



    Robert Aldwinckle
    ---

    Friday, July 17, 2015 4:26 AM
    Answerer
  • Hello all read the posts and i also have had this issue many times but the update 3038314 is not installed on either of the two new installs of win7 and i could not change the setting as stated so i did do and export from a pc with google as the default search provider hkcu\software\microsoft\internet explorer\searchscopes

    took the google search key exported to a reg file importated it to the machines in question and all is well set it to default search provider deleted bing, just a note for anyone who does not find the update 3038314 installed and still has an issue.

    Monday, July 20, 2015 7:47 PM
  • Hi,

    Open your Internet Explorer --> Help --> About --> Check your IE "Update version".  This will confirm if you have 3038314 installed.  If you do, download and install Cumulative Security Update for June 2015 fixes it.

    I had the same issue but uninstalling 3038314 didn't fixed it.  Technically it should have been fixed but it didn't.  However, applying the Cumulative Security Update for June 2015 fixes it (KB3058515).


    Thursday, July 30, 2015 11:20 PM
  • This just happened this week-what was trigger if the update was in April 2015 (rhetorical question, I guess)?

    Uninstalled KB3038314. rebooted. Google search is listed but is 'Not Available'.  

    Cumulative Security Update for June 2015 KB3058515 was installed awhile back routinely, guess until the trigger this week.

    Am completely mystified.  

    Any help would be wonderful!!!  Thanks!

    Thursday, October 29, 2015 9:42 PM
  • visit the link below. click on the add link below the google logo. then close and reopen your IE.  then tools>internet options> programs> manage add ons>search providers I managed to add google search to IE 11 this way.

    www dot Microsoft dot com/en-us/iegallery

     
    Friday, April 13, 2018 10:37 AM
  • This answer is no longer relevant.  Which is not surprising since its over 3 years old.

    To add new search engines in IE use this URL:

    https://www.microsoft.com/en-us/iegallery


    Renegade Java Convert

    Tuesday, May 15, 2018 1:08 AM