locked
How to remove "View in Web Browser" and "Snapshot in Excel" from ECB menu in SharePoint 2007 RRS feed

  • Question

  • I have noticed that whenever I upload an Excel document to any document library in SharePoint 2007 I get two additional options in the ECB menu; "View in Web Browser" and "Snapshot in Excel". I need to remove these two options so my question is how can I do this? Are they added as part of a feature being activated or are they added when enabling Excel services?

    I would like to avoid modifying the ECB menu if it is simply a matter of disabling Excel Services or deactivate a particular feature.

    Thursday, January 3, 2013 12:08 PM

Answers

  • I found out how to do it, apparently I missed the farm feature completely. Open Central Administration->Operations->Manage farm features and simply disable the feature "Excel Services Farm Feature".
    Friday, January 18, 2013 12:50 PM

All replies

  • I found out how to do it, apparently I missed the farm feature completely. Open Central Administration->Operations->Manage farm features and simply disable the feature "Excel Services Farm Feature".
    Friday, January 18, 2013 12:50 PM
  • Hi,

    well - it cannot be the fix to deactivate these features on a farm wide level. Isn't there any other configuration that forces Excel 2007 documents to be opened in client application even though a user has only read access?

    Sven

    Thursday, September 12, 2013 11:00 AM
  • Hi,

    yesterday I found the reason for the issue that people with only read permissions can only get the browser version of a XSLX file instead of downloading the file or open .XSLX documents locally in their client application anymore. It always opened in the web browser.

    A base permission in permission level "READ" was missing. The base permission "Open items handler" was not checked.

    OpenItems => View the source of documents with server-side file handlers.

    In the browser it is the base permission "open items handler". If you check this box in the read permission then it works perfectly fine.

    Best Regards

    Sven

    Friday, September 13, 2013 7:08 AM