locked
Vista Ultimate x64: domain login results in "Preparing desktop," blank screen RRS feed

  • Question

  • I have a machine with Vista Ultimate x64 on it (more specs at the end). It is joined to a Windows SBS 2003 domain.

    When I log in to either my domain account or the local administrator account, I get "Welcome," then "Preparing your desktop," then a blank blue screen with just mouse cursor.

    Ctrl-Shift-Esc does not invoke task manager. Win-R does not bring up the Run dialog. Ctrl-Alt-Delete provides security screen, but Task Manager can't be invoked there.

    I can boot into safe-mode or safe-mode with networking and successfully log into both accounts. (WTF?)

    Things I've tried:
    * Done Vista startup repair. It claims there is no problem (and it's sorta right - I *can* startup a normal windows startup, I just can't properly log in)
    * Logged in with safe mode and done chkdsk /f on all relevant volumes
    * Done sfc /scannow - nothing interesting
    * Changing HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\Shell to "Explorer.exe" (it used to b cmd.exe /k start cmd.exe)
    * Deleted the HKLM\SYSTEM\MountedDevices key and allowed it to be regenerated. No effect.
    * Removing the machine from the domain, and adding it back
    * Using net user Administrator /active:yes to activate the machine\Administrator account. I can log in (to a normal windows startup) on that account and get a desktop. But...then what.

    No ghosting, drive letter shenanigans, etc. have been carried out.

    Running out of ideas. Thanks in advance for any advice.

    ***** UPDATE *****
    I booted to safe-mode with networking and logged in with my domain account. I ran msconfig and disabled UAC there. Then restarted.
    After that I was able to log in to my domain account from a normal windows startup.

    BUT:

    Things are very askew.

    * If I try to do Properties on Computer, no properties appear
    * Start > Control Panels is empty
    * The Event Log service is not running, and when I try to start it, I get Access Denied.
    * Same with the ISA Firewall Client. (not running, access denied trying to start)
    * Windows defender wants to get new definitions but gets 0x8024402c trying.
    * Internet access doesn't seem to work (dns errors), even though ipconfig looks ok and DNS service is running
    * My Antivirus software is running (Computer Associates eTrust) and does not seem to be upset
    * Mamutu anti-Malware is running and doesn't seem to be upset about anything

    -Bryan

    ABit IP35 Pro Mobo
    Intel Q6600 stock clock
    6GB OCZ PC6400 RAM stock clock/voltage
    250 GB boot partition on a RAID 1 pair on the Intel ICH9
    Vista Ultimate x64 box copy
    Sunday, December 28, 2008 10:49 AM

Answers