none
Windows Server Storage Service Stopped Working

    Question

  • I can't acces my hard drives, I allready checked event viewer and then i get the error below. Also the Windows is up to date. 

    CHKDSK - no errors
    SFC /scannow - no errors

    Starting / restarting all services - no change

    Faulting application name: storageservice.exe, version: 6.3.9600.16384, time stamp: 0x5215ea92
    Faulting module name: storageservice.exe, version: 6.3.9600.16384, time stamp: 0x5215ea92
    Exception code: 0xc0000025
    Fault offset: 0x0000000000052e48
    Faulting process id: 0x103c
    Faulting application start time: 0x01d3dd29e4cbd32e
    Faulting application path: C:\Windows\System32\Essentials\storageservice.exe
    Faulting module path: C:\Windows\System32\Essentials\storageservice.exe
    Report Id: 2353ba15-491d-11e8-80e9-000c296911f5
    Faulting package full name: 
    Faulting package-relative application ID:
    The Windows Server Essentials Storage Service service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 60000 milliseconds: Restart the service.

    Essentials Dashboard on Server 2012 R2 Storage not visible
    Windows Server Essentials Storage Service stops after 3 tries starting
    Service dependencies are started

    Windows Server Storage Service Stopped Working.


    Thursday, April 26, 2018 11:07 AM

All replies

  • Hi,

    If possible, please try to re-start system in Clean Boot and confirm that if problem happens again.

    Perform a clean startup to determine whether background programs are interfering with your game or program:
    https://support.microsoft.com/en-au/help/331796/perform-a-clean-startup-to-determine-whether-background-programs-are-i

    Open %ProgramData%\Microsoft\Windows Server\Logs, check storageservice.log file, search key word such as fail, error.

    Also, please open Run, type “regrdit.msc” and end with enter, open below location:
    HKLM\SOFTWARE\Microsoft\Windows Server\StorageService\Folders

    Check sub entry confirm that if there is any one had mentioned in storageservice.log file and causing error/failure. You can try to re-name the registry entry, then, re-start system to check the result.

    Note:
    You can change the registry name back to original one in order to undo the change. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, April 27, 2018 6:14 AM
    Moderator
  • Have you installed the latest April update Rollup?

    Robert Pearman Cloud & Datacentre MVP
    @titlerequired | LinkedIn | Google+
    Facebook | Windows Server Essentials.com

    Friday, April 27, 2018 7:06 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 30, 2018 1:55 AM
    Moderator
  • I am having the exact same issue.  WS 2012R2 Essentials Dashboard.  The storage service fails with  Exception code: 0xc0000025.

    I am at a complete loss as to why this has suddenly occurred, but all dependencies are running and the service fails after running for a blink of an eye....please help

    I have done all updates, but have removed some of them now in case that is the issue 


    Adding to this is an error I get in the storage service log.  Weird thing is all the shares are still fine, but the error on this looks like they have been deleted.
    [05/01/2018 09:08:42 32b0] ++++ Folder::SendEvent (342b796d-08b8-4062-b31f-2f0baeb166f0)@0x281c9a90
    [05/01/2018 09:08:42 32b0] [Folder] properties for folder 342b796d-08b8-4062-b31f-2f0baeb166f0
    [05/01/2018 09:08:42 32b0]      drive ID = 00000000-0000-0000-0000-000000000000
    [05/01/2018 09:08:42 32b0]      name = Component3
    [05/01/2018 09:08:42 32b0]      devicename = TSSPHO-AD
    [05/01/2018 09:08:42 32b0]      description = NULL
    [05/01/2018 09:08:42 32b0]      localpath = H:\Component3
    [05/01/2018 09:08:42 32b0]      sharename = Component3
    [05/01/2018 09:08:42 32b0]      cRef = 1
    [05/01/2018 09:08:42 32b0]      size = -1
    [05/01/2018 09:08:42 32b0]      free space = -1
    [05/01/2018 09:08:42 32b0]      last size update = 0
    [05/01/2018 09:08:42 32b0]      shared: FALSE
    [05/01/2018 09:08:42 32b0]      hide from remote: FALSE
    [05/01/2018 09:08:42 32b0]      flag: 1
    [05/01/2018 09:08:42 32b0]      status = Missing
    [05/01/2018 09:08:42 32b0]      usage = 0
    [05/01/2018 09:08:42 32b0]      quota = 0, Disabled
    [05/01/2018 09:08:42 32b0]      share status = Deleted
    [05/01/2018 09:08:42 32b0] [Folder] folder ADDED event sent.
    [05/01/2018 09:08:42 32b0] ---- Folder::SendEvent
    [05/01/2018 09:08:42 32b0] [Manager] LoadFolders ERROR_NO_MORE_ITEMS
    [05/01/2018 09:08:42 32b0] ---- Manager::LoadFolders
    [05/01/2018 09:08:42 32b0] ---- Manager::OnLanmanserverInit
    [05/01/2018 09:08:42 32b0] [Manager] Lan share service monitor thread exited.
    [05/01/2018 09:08:42 32b0] ---- Manager::LanShareServiceMonitorThread
    [05/01/2018 09:08:42 24bc] ++++ Folder::GetAccess (a82b573d-3a97-4e43-a405-67d9e81a34ba)@0x281c6f10
    • Edited by DetoxIT Monday, April 30, 2018 11:33 PM
    Monday, April 30, 2018 10:21 PM
  • Hi,

    @ DetoxIT
    Please post a new thread on this forum, also, please provide detail OS name and version, with complete log files.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 1, 2018 6:59 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 1, 2018 7:00 AM
    Moderator
  • I don't see the reason to start a new thread as my issue is identical to the one listed on this thread. I have also just had a comment added on the Experts Exchange Site with another user having the same issue..WS2012R2 Ess Dashboard.

    My next step is to remove all latest updates and test.  After that time to lodge a ticket with MS Support

    Tuesday, May 1, 2018 8:26 AM
  • Removed all recent updates and problem still exists.  This is now getting urgent.  Would love some assistance
    Tuesday, May 1, 2018 9:01 AM
  • Hi,

    Please provide a screenshot about sub-entries under:
    HKLM\SOFTWARE\Microsoft\Windows Server\StorageService\Folders

    Besides, please provide complete storageservice.log file.

    You can upload file to OneDrive(https://onedrive.live.com/), share it and provide me the access link.

    Note:
    In general, in order to avoiding confusion, and collecting relate log file and system information, we would recommend customer to post a new thread, and provide necessary information/log file.

    Thank you for your understanding.

    Best Regards,
    Eve Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, May 2, 2018 6:23 AM
    Moderator
  • Here is the link with the files.  Please let me know once you have them so I can disable the share

    https://detoxit-my.sharepoint.com/:f:/g/personal/vaughan_detoxit_onmicrosoft_com/EhradinzZJVBpOOQKTW_nL4BGNBz3o6YY_3G2ImQmMyp6A?e=Rpb5H5

    Thursday, May 3, 2018 12:37 AM
  • Following as I'm seeing this error too.  As soon as the Dashboard is opened, storageservices.exe crashes.  This means no folders or drives are visible anywhere in the Dashboard, so you can't even add users since you can't select their folder permissions.

    I tried also tried Chkdsk, DISM, updates, etc.       

    The only thing I have to add is I found these errors:

    

    ---------------------------------

    Log Name:      Microsoft-Windows-Windows Server/Admin
    Source:        Microsoft-Windows-Windows Server
    Date:          5/3/2018 5:34:46 AM
    Event ID:      132
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      private.local
    Description:
    Process storageservice failed at storage\service\folder.cpp(194).

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Windows Server" Guid="{26A2F182-2EAD-423F-9D7D-500B74FF9295}" />
        <EventID>132</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2018-05-03T12:34:46.492982700Z" />
        <EventRecordID>5847409</EventRecordID>
        <Correlation />
        <Execution ProcessID="9944" ThreadID="5692" />
        <Channel>Microsoft-Windows-Windows Server/Admin</Channel>
        <Computer>private.local</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="ExecutableName">storageservice</Data>
        <Data Name="FileName">storage\service\folder.cpp</Data>
        <Data Name="LineNumber">194</Data>
      </EventData>
    </Event>

    ---------------------------

    Log Name:      Microsoft-Windows-Windows Server/Admin
    Source:        Microsoft-Windows-Windows Server
    Date:          5/3/2018 5:34:46 AM
    Event ID:      130
    Task Category: None
    Level:         Error
    Keywords:      
    User:          SYSTEM
    Computer:      private.local
    Description:
    Unexpected error 14007 from GetRecordInfoFromGuids: 14007
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-Windows Server" Guid="{26A2F182-2EAD-423F-9D7D-500B74FF9295}" />
        <EventID>130</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2018-05-03T12:34:46.492982700Z" />
        <EventRecordID>5847408</EventRecordID>
        <Correlation />
        <Execution ProcessID="9944" ThreadID="5692" />
        <Channel>Microsoft-Windows-Windows Server/Admin</Channel>
        <Computer>private.local</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="ErrorCode">14007</Data>
        <Data Name="ApiName">GetRecordInfoFromGuids</Data>
        <Data Name="ErrorHR">14007</Data>
      </EventData>
    </Event>

    -------------------------------------------------------------------------

     I don't suspect it's related but the server's RWA SSL certificate had expired, when I first noticed this storageservice.exe issue.




    • Edited by ToddLaw Thursday, May 3, 2018 1:08 PM Grammerly add weird txt to post
    Thursday, May 3, 2018 1:02 PM
  • Did you install the April Update?

    Robert Pearman Cloud & Datacentre MVP
    @titlerequired | LinkedIn | Google+
    Facebook | Windows Server Essentials.com

    Thursday, May 3, 2018 2:13 PM
    Moderator
  • Yes...and removed it, but is still broken.

    I believe it is probably a patch but I have removed all the recent ones I did rebooted and tested, but this made no difference.  I am sure there are lots of others with this issue, but it will only come to light as people use the Dash

    Friday, May 4, 2018 2:27 AM
  • Hi,

    In general, working share folder should has “status = Healthy” instead of “status = Missing”. Also, I had found VMware relate configuration based on your log file.

    Is there any specific change before problem happens? Such as new installation, disk replacement and etc.?

    Please try to re-name Folders registry entry as Folders.old:
    HKLM\SOFTWARE\Microsoft\Windows Server\StorageService\Folders

    Save the change and re-start system, then check the result.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 4, 2018 5:37 AM
    Moderator
  • I will try this tonight.  I had tried to delete all the keys under folder previously and it made no difference. Failing that am going to roll back to an backup prior to the April updates.

    The only thing that was done was to extend one of the drives...am not sure if it was still working after that or not

     
    Friday, May 4, 2018 6:10 AM
  • Tested deleting the folder registry key but it has not made any difference...time to roll back
    Friday, May 4, 2018 10:43 AM
  • Hi,

    >The only thing that was done was to extend one of the drives...am not sure if it was still working after that or not
    May be you can consider of undo the change.

    I am sorry that I am unable to provide you more detail suggestion. If necessary, I would suggest you contact Microsoft Customer Support and Services where more in-depth investigation can be done so that you would get a more satisfying explanation and solution to this issue. 

    Global Customer Service phone numbers:
    https://support.microsoft.com/en-us/help/13948/global-customer-service-phone-numbers

    Or, if there is anything else web can do for you, please feel free to let us know.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, May 7, 2018 9:41 AM
    Moderator
  • I cannot undo the addition of storage.  I tried contacting MS support but got told I have to go via Dell as it is Dell OEM
    Tuesday, May 8, 2018 9:15 AM