none
Cannot connect to Deployment Share RRS feed

  • Question

  • So I have a Windows 7 Pro, image I have created in MDT and I am trying to deploy it to a bunch (well, actually just one at this point) of Lenovo E73 SFF PCs using WDS/PXE.

    I created the image working with a VM. I deployed that image to the VM by mounting the ISO. None of the issues I describe below occur in the virtualised build. In fact, that works perfectly. It's once I introduced Hardware that things get complicated.

    I can successfully PXE Boot the PCs, and they get an IP address. They load Windows PE. However, I usually get the message "A Connection cannot be made to the Deployment Share" and the message suggests Network Credentials may be the issue.

    I have set the credentials in the Bootstrap.ini and quadruple checked that they are correct. What is more odd is that there have been occasions where this message does not appear. Although they are perhaps only 5% of occasions.

    When this message appears i will usually hit F8 and enter a net use command to re-enter my credentials. There seems to be three outcomes when I do this. 1. Error 5(?)2 Path Not Found. 2. It works and the install runs as planned. 3. It take my credentials, but MDT will only run very briefly and the PC will restart.

    Furthermore, as I mention in "2." above, there are cases whereby the install will run. It installs the OS successfully but not the Applications (presumably because it cannot connect to the network). At the end of the process I am left with the desktop and the message "A connection could not be made to the Deployment Share" and this time it specifies the ID of the "PCI/Ven_10E...etc". I have verified that the drivers I have in MDT have this ID in their supported PNP IDs and imported the Win7 and 8 versions, both x86 and x64 architecture.

    Just for the sake of clarity, I am updating the Deployment Share each time (I have tried completely rebuilding it) and updating my boot images in WDS.

    I am relatively new to all this. So I it's clearly possible I am doing something basic wrong.

    My thinking at this point is that any of the following might be an issue, but I have read so much different articles I just feel a bit overwhelmed.

    Also, I also just tested an old HP 3135 I have spare, to eliminate some sort of Lenovo specific issue. On one hand there were none of the issues relating to "credentials". But after running through the task sequence I got the same message, "Cannot connect to the Deployment Share" relating to the Network Driver. I have added the network drivers for the HP to my deployment before proceeding too.


    Any advice would be very welcome.

    Wednesday, July 8, 2015 10:33 AM

All replies

  • Just to eliminate it from the list of possible issues.

    Have you tried using a different Ethernet cable? Have you tried a different Ethernet port?


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Wednesday, July 8, 2015 1:29 PM
  • I have. I have four ports setup on the same VLAN as the MDT/WDS Server. All seem to produce the same results.

    Thanks for the response. I appreciate any advice.


    Wednesday, July 8, 2015 1:32 PM
  • Just to add some more detail to this:

    I suspect there are two problems with my deployment.

    1. The Lenovo's produce the "cannot connect to Deployment Share" message upon looking for my Network Credentials at the very outset of the Deployment phase. The error specifies Network Credentials. I have tried innumerable things to get this to work, and it does not happen on the HP I tested. 

    I have found a way around it, but it's not a practical solution. So perhaps someone could tell me what this is indicative of:

    To resolve the first error I hit F8 and enter the following commands (A and B):

    A.) DiskPart > List Disk > Select Disk 0 > List Part > Select Part 1 > Clean > Create Part Primary > Assign > Active > Exit

    B.) net use \\SERVER\DEPLOYMENTSHARE$ /user:domain\user

    I came across these two when researching the error "Cannot connect to the Deployment Share". In combination they seem to do the trick. I lean towards "A" as being the significant one of the two but cannot rationalize why?

    Nevertheless, if I enter these, reboot and PXE boot a second time it seems to correctly load the Bootstrap.ini and prompt for credentials.

    That said, I had to enter the credentials 6 times before it accepted them. I entered them exactly the same, carefully, each time...

    2. This problem has occurred on both the Lenovo PCs and the HP I tested (But not the VM). Essentially the Image gets deployed but without the driver being installed. And no applications from the Task Sequence. I just see my favourite message "A connection could not be made to the Deployment Share" and the ID of the NIC.

    The obvious conclusion is that I have the wrong drivers. I don't think I do, but I'm not ruling that out.

    There was something not quite right with the Lenovo drivers. I noticed that in MDT they did not show up as WHQL signed. I read that can cause issues. It seemed odd since I got them from Lenovo. This was compounded by the fact that when I added the drivers to WDS, in order to test injecting them directly into the boot image, the system returned an error and could not add the drivers.

    So I downloaded them anew and tried to add them to WDS, and they worked. I then, out of curiosity and for thoroughness deleted all drivers from my Deployment Share and re-added new ones. This time the same driversshow as WHQL signed...

    This may not actually change anything. But it feels like progress. Since i am on test deployment 43 now I'll take any sort of progress at this point.


    • Edited by OliGarlick Wednesday, July 8, 2015 2:52 PM
    Wednesday, July 8, 2015 2:52 PM
  • How are you managing your drivers? Are you injecting everything and hoping for the best with PnP or are you using a selection profile so only the proper drivers are injected? (See: Lite Touch Driver Management)

    I would suggest using a form of driver management with "Total control" being the best way to go. Using the driver management method you should have a selection profile for just WinPE drivers. These should only include network and storage drivers. Even though you aren't dealing with Dell computers, you can probably get away with just importing this http://en.community.dell.com/techcenter/enterprise-client/w/wiki/5029.winpe-5-0-driver-cab into your WinPE driver folder.

    Now once you switch to this method you will need to update your deployment share and replace your boot image to include the new drivers. If you use a USB Ethernet adapter (useful for tablets or ultrabooks) then be sure to import that Ethernet driver into both your PE folder and the folder that matches the model you are deploying to.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Wednesday, July 8, 2015 3:10 PM
  • Thank you. I will take a look at the link you posted and see if there is something I am not doing correctly. I will reply back with any progress.

    Oli

    Wednesday, July 8, 2015 3:14 PM
  • You also might want to try to change your deployroot from \\server\share to \\<IP>\share

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Wednesday, July 8, 2015 8:25 PM
    Moderator
  • Apologies for not reporting back earlier. We had a tube strike here in London, so didn't get to look at it yesterday.

    So, I followed the advice in the link you sent me. But unfortunately it does not seem to have made a difference.

    Here is run down of what I have done:

    I created both WinPE folders for each architecture, and corresponding selection profiles. I also amended the settings as per the guide.

    I also created the sub-folder for the OS drivers following the "Total Control" methodology. I have the %model% set in the task sequence. My only concern here is the correct naming of the model as my folder name. I set it to ThinkCentre E73 which seems correct.

    I then injected the Network and Storage drivers for Windows 8.1 into the corresponding WinPE 5.0 folders. And the relevant ones into the Windows 7 x64 folders. Both downloaded from the Lenovo website. The result of this is the same as before. The first time run the process I need to enter "Diskpart" commands and reboot before the bootstrap.ini will even load. Once I have done this the process runs seemingly without issue until it loads the desktop and shows the "cannot connect to deployments share. The following device [NIC ID]..."

    I then tested it with the Dell Drivers you linked to. When I run the install using these, the image deployment gets so far and then then a blacvk window appears saying that there is a corrupt file in Windows, insert installation media. I tried this on multiple devices with no luck. It always does the same. At this point

    Friday, July 10, 2015 11:56 AM
  • Thanks for your reply Ty. I was out of the office or would have responded sooner. I took your advice and updated the bootstrap.ini Deployroot to the IP address of the server I am using for MDT/WDS. I also, changed the UNC path to the IP under the General tab.

    Unfortunately, this made no difference. And I still see the same error message. It shows the "cannot connect to DS" message before the bootstrap loads the Welcome screen, so it's strange that it wants references credentials as the possible issue since that only comes up after the Welcome Screen?

    Also, if I clean and reassign the Primary partition using the F8 and then Diskpart commands it loads the next time without issue. But at the end of the deployment I get the same problem but in reference to the NIC drivers. That suggests there is an issue with permissions or access to the Deployment Share right?

    I feel like I've been hitting a brick wall for weeks now. So frustrated with this!

    Friday, July 10, 2015 12:04 PM
  • I have the %model% set in the task sequence. My only concern here is the correct naming of the model as my folder name. I set it to ThinkCentre E73 which seems correct.

    Try running this simple script I made, on computers you support when you aren't sure what the name reported to MDT would be.

    @echo off
    powershell -command "& {gwmi Win32_Bios | Select SMBIOSBIOSVersion, SerialNumber | ft; gwmi Win32_ComputerSystem | Select Model, Manufacturer | ft }"
    pause

    Just save it as a batch file. It will output all that you might need. You can drop the BIOS version and serial if you want. I have it for informational purposes.

    Example:

    As for your error about a corrupt file in Windows, try rebuilding your boot image. Check the radio button that says "Completely regenerate the boot images."


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Friday, July 10, 2015 1:19 PM
  • Thanks again Dan.

    I used the batch file as you recommended to get the correct model number. This did make a difference, but only in the sense that the error changed slightly.

    So I had the same issues with the "credentials at the start of the imaging process, which I was able to work around. The image was deployed and when "completed" I saw the message "cannot connect to deployment share" as always.

    The only difference being that it did not reference the NIC ID this time. It again says "invalid credentials". In an attempt to circumvent this issue I did some checkiong online to ensure I have permissions setup correctly for the PCs to access the server. To be thorough I created a new local user called "MDT" and gave it access to the server. I added those credentials to the bootsatrap.ini and totally rebuilt the Deployment Share.

    The upshot is that I still get the message saying it cannot connect to the Deployment Share, and it specifies "Invalid Credentials" as the possible cause. So frustrating.

    Monday, July 13, 2015 11:18 AM
  • After the changes were made did you delete the MININT folder from the computer you were trying to image or did you just try to deploy to it again? It could have been a message from an earlier attempt. If it was just a yellow warning page and you still had a successful deployment, then no worries. Try a different machine that you haven't run the deployment wizard on and see if it succeeds without errors or warnings.

    Your deployment share permissions should be set to Everyone (Change), then under security remove everyone if it exits and only add the accounts you wish to give permission to. It can be one generic MDT account or several accounts. I have given access to the individual techs domain accounts so that in the logs I can see who authenticated and therefore who was the person who imaged a particular machine. These accounts should be given Modify permissions.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, July 13, 2015 1:21 PM
  • I tried deploying to a new machine. Unfortunately I get the same issue at the very start, which is the "invalid credentials" error.

    I went back to my VM to test and the deployment runs fine. That means the changes I made to the bootstrap.ini should not be an issue since they are accepted when I run it in the VM.

    At this stage I am assuming it can be only a small number of things:

    Something caused by the fact I am deploying Windows 7 to a UEFI enabled PC? I have made changes in the BIOS to allow legacy booting though.

    Drivers. But I downloaded the drivers from Lenovo and cross-referenced the Pnp IDs to ensuire they are the correct ones. I also added the Win 8.1 drivers to a separate folder for WinPE 5.0.

    The only other thing I can think of is somehow network related??

    Clutching at straws I feel somehow.

    Tuesday, July 14, 2015 12:11 PM
  • Well at this point you can enable dynamic logging and post your BDD log file to onedrive and share the link here. Hopefully something in the logs can point to the issue.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Tuesday, July 14, 2015 1:29 PM
  • There are two on the server, as I understand things, one in C and one in Windows/Temp.

    The BDD in Windows shows an error: "FAILURE ( 5210 ): ValidateDeployRootWithRecovery: Cancel LiteTouch 17/06/2015 10:26:38 0 (0x0000)"

    The one in Windows/Temp shows: "ERROR - no credentials were returned from LTICredentials.hta, so no connection is possible. LiteTouch 17/06/2015 10:26:10 0 (0x0000)" and "Unable to connect to the deployment share (server\share) Connection OK. Possible cause: invalid credentials. LiteTouch 17/06/2015 10:26:10 0 (0x0000)" The date on the second one is 17th of June though, which would refer to an earlier, deployment attempt.

    Tuesday, July 14, 2015 2:16 PM
  • Ok so I have had a different, but no less frustrating result today.

    One of my attempted builds was successful, in relative terms at least. In previous deployments I got the error I described in my prior posts and no "completion" box, just an error. That's presumably because the Task Sequence could not complete.

    Anyhow today I have one that did complete, but with errors (yellow box at the end). It had 18 errors in fact. All of which were either "Path not found" or "could not connect to the deployment share". The interesting thing though is that while it displayed errors it did install the NIC drivers for that device. That tells me the configuration I have in MDT is correct.

    Unfortunately, when I tried to run the deployment a second time it failed and produced the same error as before. This is consistent with the problem I had when manually entering credentials. I knew the credentials were correct but it would mostly say there was no path, but work sometimes. I also notice the link light is not always on...

    Nonetheless, it would seem the configuration of MDT is correct and that the issue is either with the connection to the deployment share server (I have moved it to a different cable and Ethernet port there to eliminate bad cabling) or something with the NIC on those Lenovo boxes?

    Thursday, July 16, 2015 2:51 PM
  • Interesting. Are you able to try a different machine, Dell, HP, something else? You could even test using a USB to Ethernet adapter, but you would need to add the driver for WinPE.

    If this post is helpful please vote it as Helpful or click Mark for answer.

    Thursday, July 16, 2015 3:28 PM
  • Hi Dan,

    Apologies for the delay. A file server died and that caused havoc for a day or so.

    I did eventually find another PC to test. An old Fujitsu we had in a cupboard. Anyhow, it worked first time - no problems at all.

    I also acquired a USB Ethernet adaptor. But the BIOS would not pick that in pre-boot so it's a non starter. I am told there are some Lenovo specific ones but that's another issue entirely.

    I ran another attempted deployment today to one of the Lenovo's, I think I can get past the first issue (bootstrap not running) and the image itself now deploys but none of the applications can be installed since it cannot connect to the deployment share.

    I copied the log files fr4om the machine I imaged. Only error, and last line, of the BDD.log is "No networking adapters found. The network drivers for your device are not present". Except they are! We built a few of these PCs manually because time is a serious issue now and I checked exactly what driver they have. Made sure that I have it in the share, etc, etc. This is driving me nuts. I can only assume it's something with drivers. But I have tried all of the ones from the Lenovo site for this model and matched them to PnPs... It's ridiculously frustrating.

    Wednesday, July 22, 2015 1:45 PM
  • Sorry to hear about the server crash.

    Well you wouldn't be able to PXE boot off of a USB Ethernet, but you should be able to boot to a USB drive that contains your MDT boot image. If you imported the drivers for the Ethernet adapter (Into the PE folder and also into the model's folder) and created a new boot image, when you boot to it, it should be able to use the adapter.

    At least the Fujitsu proved your deployment server works, you're just dealing with a driver issue now.


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Wednesday, July 22, 2015 1:59 PM
  • Oli,

    Have you had any success with this? I'm experiencing a similar issue and I just can't seem to find a fix. Thanks.

    Tuesday, December 8, 2015 9:06 PM
  • For generic questions about missing drivers:

    How to Debug missing Drivers in MDT Litetouch


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Thursday, December 10, 2015 10:47 PM
    Moderator