locked
Failed to import the latest Advisor Management Packs to the Management Server RRS feed

  • Question

  • After configuring Systems Center Advisor, I ran in to this issue. 

    Reason: System.ArgumentException: The requested management pack is not valid. See inner exception for details.
    Parameter name: managementPack ---> Microsoft.EnterpriseManagement.Common.ManagementPackException: Verification failed with 2 errors:
    -------------------------------------------------------
    Error 1:
    Found error in 2|Microsoft.IntelligencePacks.StorageDataCollection|7.0.9211.0|Microsoft.IntelligencePacks.StorageDataCollection|| with message:
    Could not load management pack [ID=Microsoft.SystemCenter.VirtualMachineManager.2012.Discovery, KeyToken=31bf3856ad364e35, Version=3.1.6011.0]. The management pack was not found in the store.
    : An error occurred while loading management pack c6d64ce2-2213-e6c8-9e2a-cbd36e868a12 from the database

    -------------------------------------------------------
    Error 2:
    Found error in 2|Microsoft.IntelligencePacks.StorageDataCollection|7.0.9211.0|Microsoft.IntelligencePacks.StorageDataCollection|| with message:
    Could not load management pack [ID=Microsoft.SystemCenter.VirtualMachineManager.PRO.V2.Library, KeyToken=31bf3856ad364e35, Version=3.1.6011.0]. The management pack was not found in the store.
    : An error occurred while loading management pack ed969e31-a8dc-b6d9-bc99-94dd55ab154d from the database

    I had to find and download the two MP's to get rid of the warning alert. Can anyone tell me why these MP's are  needed for systems center advisor?

    ID=Microsoft.SystemCenter.VirtualMachineManager.2012.Discovery

    ID=Microsoft.SystemCenter.VirtualMachineManager.PRO.V2.Library

    Thursday, May 29, 2014 7:04 PM

Answers

  • Hi,

    System Center Monitoring Pack for System Center 2012 - Virtual Machine Manager include the two file:

    Microsoft.SystemCenter.VirtualMachineManager.2012.Discovery.mp

    Microsoft.SystemCenter.VirtualMachineManager.PRO.V2.Library.mp

    Please download them here:

    http://www.microsoft.com/en-us/download/details.aspx?id=29679

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Yan Li_ Wednesday, June 4, 2014 1:26 AM
    Tuesday, June 3, 2014 8:28 AM
  • Ok so I imported Management Packs from C:\Program Files\Microsoft System Center 2012 R2\Virtual Machine Manager\ManagementPacks who were in my VMM Server to my SCOM Server and the error message has disappear :)

    Thanks Yan for the beginning of the solution.

    • Proposed as answer by Flodu31MVP Tuesday, June 3, 2014 12:12 PM
    • Marked as answer by Yan Li_ Wednesday, June 4, 2014 1:26 AM
    Tuesday, June 3, 2014 12:11 PM

All replies

  • Hi P.Bradford

    Do you have a server running VMM monitored in SCOM?


    www.coretech.dk - blog.coretech.dk

    Friday, May 30, 2014 9:03 AM
  • I will need to verify. I know i have some Hyper-V hosts in my environment.
    Friday, May 30, 2014 5:30 PM
  • Check that you import correct Management Pack.

    Also you can check below link

    http://scug.be/scom/2011/05/02/using-system-center-advisor-management-packs-in-opsmgr/


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer" Mai Ali | My blog: Technical | Twitter: Mai Ali

    Friday, May 30, 2014 6:43 PM
  • Same issue for me. 

    I can't install the gateway on WS2012R2 and SCOM 2012 R2 to import MP ("advisorsetup has stopped working").


    • Edited by Flodu31MVP Monday, June 2, 2014 1:07 PM
    Monday, June 2, 2014 12:38 PM
  • Hi,

    System Center Monitoring Pack for System Center 2012 - Virtual Machine Manager include the two file:

    Microsoft.SystemCenter.VirtualMachineManager.2012.Discovery.mp

    Microsoft.SystemCenter.VirtualMachineManager.PRO.V2.Library.mp

    Please download them here:

    http://www.microsoft.com/en-us/download/details.aspx?id=29679

    Regards,

    Yan Li


    Regards, Yan Li

    • Marked as answer by Yan Li_ Wednesday, June 4, 2014 1:26 AM
    Tuesday, June 3, 2014 8:28 AM
  • This version is 3.0.6019.0 and Advisor needs version 3.1.6011.0...
    Tuesday, June 3, 2014 11:14 AM
  • Ok so I imported Management Packs from C:\Program Files\Microsoft System Center 2012 R2\Virtual Machine Manager\ManagementPacks who were in my VMM Server to my SCOM Server and the error message has disappear :)

    Thanks Yan for the beginning of the solution.

    • Proposed as answer by Flodu31MVP Tuesday, June 3, 2014 12:12 PM
    • Marked as answer by Yan Li_ Wednesday, June 4, 2014 1:26 AM
    Tuesday, June 3, 2014 12:11 PM
  • You are welcome, glad to help.

    Have a nice day!

    Regards,

    Yan Li


    Regards, Yan Li

    Wednesday, June 4, 2014 1:26 AM
  • I have the same error but don't run VMM. The warning is on only one of the two management servers. I have already tried resetting the healthstate folder to see if that was the issue. I really just want to back out and remove the Advisor connection until i have time to work on the issues. I can't find anything on the web to disable or remove the Advisor connection.
    Monday, July 28, 2014 11:20 PM
  • I have the same error but don't run VMM. The warning is on only one of the two management servers. I have already tried resetting the healthstate folder to see if that was the issue. I really just want to back out and remove the Advisor connection until i have time to work on the issues. I can't find anything on the web to disable or remove the Advisor connection.

    This Article by Marnix Wolf Should Help You. This what I used to disable the SCA integration until i could work on it.

    http://thoughtsonopsmgr.blogspot.com/2014/07/scom-2012-r2-sca-integration-when-not.html

    Monday, July 28, 2014 11:26 PM
  • Thanks you. I was really hoping that it would be as easy to just unregister Advisor from the console. Did you removed the Internal Connectors that are created as part of the initial configuration? 

    thanks,

    Mike

    Tuesday, July 29, 2014 12:14 AM