locked
The response from the Autodiscover service at 'https://otherdomain.com/Autodiscover/Autodiscover.svc/WSSecurity' didn't return a valid value for user setting 'ExternalEwsUrl'. RRS feed

  • Question

  • Getting the following error in Exchange 2010 in my domain. I am trying to access autodiscover in another domain that is setup to do federated trust with my domain. This error occurs when a client on my domain tries to retrieve calendar info for a user in the other domain.


    Log Name:      Application

    Source:        MSExchange Availability

    Event ID:      4001

    Task Category: Availability Service

    Level:         Error

    Keywords:      Classic

    User:          N/A

    Computer:      myserver

    Description:

    Process Microsoft.Exchange.InfoWorker.Common.Delayed`1[System.String]: <>SMTP:user@otherdomain.com failed. Exception returned is Microsoft.Exchange.InfoWorker.Common.Availability.AutoDiscoverFailedException: Autodiscover failed for e-mail address <>SMTP:user@otherdomain.com with exception Microsoft.Exchange.InfoWorker.Common.Availability.AutoDiscoverFailedException: The response from the Autodiscover service at 'https://otherdomain.com/Autodiscover/Autodiscover.svc/WSSecurity' didn't return a valid value for user setting 'ExternalEwsUrl'.

    . Name of the server where exception originated: myserver. ---> Microsoft.Exchange.InfoWorker.Common.Availability.AutoDiscoverFailedException: The response from the Autodiscover service at 'https://otherdomain.com/Autodiscover/Autodiscover.svc/WSSecurity' didn't return a valid value for user setting 'ExternalEwsUrl'.

    . Name of the server where exception originated: myserver

       --- End of inner exception stack trace ---

    . Name of the server where exception originated: myserver. This event may occur when Availability Service cannot discover an Availability Service in the remote forest.

    I have access to the exchange servers on both domains. On the domain I am trying to contact, I run "get-webservicesvirtualdirectory | fl", and confirm that the internal and external URLs are valid. OA is enabled on both domains.

    Any advice would be appreciated.



    • Edited by cpaisley Tuesday, March 25, 2014 8:09 PM
    Tuesday, March 25, 2014 8:08 PM

Answers

  • I am using only Microsoft Federation.

    I opened a ticket and here was the solution:The EXPR provider was not being listed in queries of active directory, though is was present in active directory. (DC=<domain>, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<Organization Name>, CN=Client Access, CN=Autodiscover, CN=OutlookCN=EXCH or CN=EXPR)

    He discovered this by running the command: Get-OutlookProvider |fl name,*cert* , which listed the providers, then comparing that to the output of the "test email autoconfiguration" tool in the outlook client - and there found EXPR was missing (only Web and EXCH listed).

    The tech used the following command to delete the existin EXPE entry: Remove-OutlookProvider -Identity EXPR

    Then the following command to recreate it: New-OutlookProvider -Name EXPR

    He then when into sites and services and forced the AD servers to replicate. Then the issue was resolved.

    • Marked as answer by cpaisley Tuesday, April 1, 2014 4:54 PM
    Tuesday, April 1, 2014 4:54 PM

All replies

  • see if that help 

    https://testconnectivity.microsoft.com/

    Office365 Tab and then FRee/Busy Test


    Where Technology Meets Talent

    Wednesday, March 26, 2014 2:52 AM
  • I have tried that, the tests all pass.
    Wednesday, March 26, 2014 7:52 PM
  • do they have setup their Sharing Policy? 

    Is the Federation Trust is Org Wide or Per User? 


    Where Technology Meets Talent

    Wednesday, March 26, 2014 8:08 PM
  • Yes, federation trust is setup on both orgs, and the org relationship and sharing policy are setup. I believe the trust is org wide, if I understand the question. I did not limit the sharing to a security group.

    When I setup the org relationship, I had to use the manual option. I received an error with the automatic option.

    Thursday, March 27, 2014 12:14 PM
  • has it been working and suddenly stopped working?

    is it just with single user you can't pull the calendar information?

    are you bale to pull the free/busy for other users?

    is there a firewall blocking any ports?

    I'm running out of options now - nothing helps then better open a ticket with MS Support.


    Where Technology Meets Talent

    Friday, March 28, 2014 1:00 AM
  • It has never worked between these two orgs, it is just being setup for the first time.

    It is with every user - this error occurs when any user attempts to retrieve calendar info from the other domain.

    No, cannot pull for any user on the other domain.

    There are firewalls involved, but its all port 443 best I can tell, and that is not blocked.

    A ticket with MS support is what I was also thinking I would need to do.

    Monday, March 31, 2014 1:33 PM
  • So it is croess-forest configuration between to different site.

    Are you using ADFS or Microsoft Federation services?


    Where Technology Meets Talent

    Tuesday, April 1, 2014 2:35 AM
  • I am using only Microsoft Federation.

    I opened a ticket and here was the solution:The EXPR provider was not being listed in queries of active directory, though is was present in active directory. (DC=<domain>, CN=Configuration, CN=Services, CN=Microsoft Exchange, CN=<Organization Name>, CN=Client Access, CN=Autodiscover, CN=OutlookCN=EXCH or CN=EXPR)

    He discovered this by running the command: Get-OutlookProvider |fl name,*cert* , which listed the providers, then comparing that to the output of the "test email autoconfiguration" tool in the outlook client - and there found EXPR was missing (only Web and EXCH listed).

    The tech used the following command to delete the existin EXPE entry: Remove-OutlookProvider -Identity EXPR

    Then the following command to recreate it: New-OutlookProvider -Name EXPR

    He then when into sites and services and forced the AD servers to replicate. Then the issue was resolved.

    • Marked as answer by cpaisley Tuesday, April 1, 2014 4:54 PM
    Tuesday, April 1, 2014 4:54 PM